3 beep csm issue

Not sure where to put this, but after help with gop update on my rx580. Won’t let new users upload the zip file of original vbios and gop updated version.
Can anyone help a i have the 3 beeps issue when csm is disabled
There is also a discrepancy between gpuz and aida64

3 beeps but boot in UEFI or just in CSM/LegAcy? Before the GOP update did the card booted in UEFI mode? Former mining card?

EDIT: A CSM enable or AUTO it’s NOT a PURE UEFI environment, so the card doesn’t boot in UEFI, witch is strange as its not such old card, motherboard bios is updated?
Running HWInfo or MSinfo32 will tell you in what mode the OS is running.
So before the the card was ok, flash the previous vbios before GOP updater or from TPU database.

VGA Bios Collection: Asus RX 580 8 GB | TechPowerUp

If not flashed yet… are you telling us then that it never boot in UEFI mode since you bought it?

Files can be uploaded and linked into your own sharing provider like Google drive, Mediafire etc…

Hi yes booted in uefi mode with csm enabled as soon as i disable csm 3 beeps, no access to bios but windows
10 boots. There is also a discrepancy between aida64 and gpuz with the dates of the vbios.
No i bought the card new so not a mining card, just overclocked to 1431 with msi afterburner
OS is on nvme drive in gpt format
Card is not updated i have just added gop to original vbios, saved from atiflash.
Not flashed card yet as i want someone to look at the update vbios with gop before i flash. Unable to upload files here as i am a new user.
Thanks for any help

csm enabled, pure uefi and system boots normal.
csm disabled, uefi then get 3 beeps no access to bios, but winodws 10 boots.
Card has never been flashed, as i stated i ran atiflash and saved the original vbios then dropped that on gopupd.bat and have saved the rom to my pc. Wanted somebody to check the gop injected vbios before i flash the card

has always worked in uefi mode. Only when i disable csm that there is a problem. 3 beeps no access to bios but win 10 boots

Again… with CSM enable your’re not assuring no one only by your word that its a PURE UEFI, run the tools mentioned before.
CSM disable its the only PURE UEFI.
Maybe your motherboard doesnt like your GPU as PURE UEFI mode (CSM NOT ENABLE nOR AUTO)
Theres nothing to check and no one can assure you of nothing…this is MOD world.
Others ports in the card same behaviour DP or HDMI or DVI

EDIT: The “bios_updGOP.rom” its not updated, its the same GOP as the original…lol, the latest is

here is a link to the original vbios (bios.rom) and gop injected vbios(bios_updgop.rom)

yeah, only tried both hdmi ports. NO dp available. linked to my 4k nanocell tv

msinfo i have removed the rest for security

i dropped my original vbios on gopupd.bat and that was the resulting rom

Well heres my opinion, the TV signal may not be not compatible with the sync from GPU or a bad/old hdmi cable.
That motherboard and GPU should have no problem with that, have you tried another display output, a real monitor. And how about a DP link between the 2 devices…just saw it… a 4k with no DP ports…shame
Use the latest GOP updater on the forum:
AMD and Nvidia GOP update (No requests, DIY) - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

please explain tv signal not compatible, please i do not understand. I have replaced the hdmi cable some time ago as i did have a bad hdmi cable. I will try a real monitor

can you link the updater as when i try it says file not found

I can t explain that… ask LG or ASUS, why such surprise in issues regarding compatibility… its a common issue that always haunted end users

Some users had old cables/revisions HDMi 1.0… yours supports 2.0b (GPU) and 2.0 (LG)
HDMI - Wikipedia

The link is valid, country ISP restrictions, browser, firewall etc…

There’s always a first time, welcome to the real world.

very true, but never had problems with games or using the pc through my lg 4k nano