970A-UD3 3.0 back to classic BIOS from r. 1.2

I would like to upload BIOS Award from revision 1.2 of this board using UEFI2AWD, unfortunately the program reports incompatibility, which is not surprising. Would anyone be able to modify the latest BIOS of revision 1.2 to make it uploadable on revision 3.0 with UEFI?
Thank you in advance.

you could try to use flashrom to flash that board, and see if it works.

What is “flashrom”?

try read this

The problem is that I can’t use efiflash because it won’t load the classic BIOS Award. I have to use efi2awd (I tested the software, it works on a P67 board, for which there is both Award and UEFI BIOS beta).

yes that is why try to read the Annex section. it explains how to use flashrom for backing up/flashing a bios with that. its like “Intel FPT” but not intel exclusive.

I tried to use flashrom 1.2, but ended up corrupting the main bios, but was restored to UEFI from the second bone. I selected programmer, chip model. I uploaded the BIOS with the extension as I downloaded it with (F7, such as the BIOS version). Should I change them?

Do you throw yourself to a pit when someone told you so?
Some users would like to see that… just to see what happens cause they wont do it.
Its the same here, besides SPI chip IDs and size, that was a big structural change from legacy AWARD to the so called first earlier “Hybrid” UEFI bios versions, not even close to the current pure UEFI specs of today.
You wont find successful cases among Gigabyte users, at least to my knowledge… among mboard revisions of that period, and your not the first with this wish, im not being “negative” here but good luck anyway.

It worked! I finally uploaded this BIOS.
Of course, it couldn’t go without problems:

  • BIOS misreads vcore and CPU temperatures (only in BIOS)
  • PWM control does not work
  • checksum errors at startup, then the BIOS “uploads” the BIOS from the other bone, and it doesn’t really do that, because they are the same, probably the fault of the flash bone model. Fortunately, this is harmless, because it does not overwrite anything, and lasts only a moment.

Despite these problems, I’m much more satisfied than with the UEFI BIOS.
Now how I did it :slight_smile:
I changed the UEFI ID in the hex editor to that of the BIOS Award (rev 1.2) and then uploaded it via a modified version of efiflash.
Now I was able to upload the Award BIOS via EFI2AWD without any problems.