Alienware 17 R5 Engeneering sample need help to mod bios

Thanks for testing. I see, we can’t really know how these Pre-Production systems work unless we try. Most people ask for help with Production systems, that’s why. Anyway, I don’t think the PMC can be updated further. Now that the CSME firmware is cleaned and the PMC cannot be updated, let’s focus on the BIOS. I’ve attached below the latest Production BIOS region, extracted from Dell HDR BIOS v1.7.0. We can base any changes to the previously attached “552read_clean.bin” SPI image. One difference is that the Production BIOS does have BootGuard enabled. The CPU microcodes are compatible. I think we could try a quick & dirty test by replacing the Engineering BIOS with the Production one, after modifying FIT to remove the ACM/BG entries. If that fails, replacing/cleaning the NVRAM of the BIOS region might help. I’ll tag @Lost_N_BIOS who might be able to help there. Please wait for his reply.

alienware_15_r4_17_r5_1.7.0_BIOS.rar (4.08 MB)




No boot/fan spin on this one.

@code9523 - That’s probably because you didn’t wait for my reply, I think plutomaniac meant that several edits need to be done with the linked file because it’s not something you would ever be able to straight program and use.
The file attached at post #10 is only a BIOS region (7MB) = part of the BIOS, not a whole BIOS (32MB) - this is why he said to wait for me to make you some test BIOS builds various ways.

First test these two BIOS - Straight stock region swap in - one with latest original included microcode for your CPU, other with 2017 microcode from BIOS at post #4 ACM/BG removed from FIT on ALL
Stock2017
Stock2019

Then if both fail to boot, test these BIOS, same as above but with your original NVRAM in place and old original Setup, AMISTE, AMITSE/SetupData, 2 x StdDefaults outside NVRAM swapped in
This much easier than NVRAM swap of setup entries in NVRAM - other way nearly impossible for me, takes hours to redo all NVRAM especially when there is 100’s of entries
Stock2017NV
Stock2019NV

* Edit code9523 - please wait until I get reply back below about the size difference, sorry!

Plutomaniac Which FITc can work on that BIOS, if any? I tried V12 >> from R8, R12, and R17 packages, all fail to open, revert to default
I simply wanted to be sure Bootguard profile was set to profile zero, if you did that already, or that is stock, then nothing I need to do there.

Aside from this, I think I will need to find and use some stock dumped BIOS region as the stock replacement, due to original BIOS region - 8MB and the one you gave above from HDR - 7MB
It doesn’t rebuild properly like that, and I don’t know proper way to increase that (ie where to pad, if any pad will = fail etc). So, I wait your thoughts, and then I’ll find some stock dump instead unless you have known tested method about this issue.

If you want to inspect and see what you can come up with as swap possibility with the size differences, here is stock region redone as you mentioned, ACM/BG removed + FIT Fixed, and then ucodes done as I mentioned above (one OG, one with 2017 906EA)
http://s000.tinyupload.com/index.php?fil…944426009693788


Thank You for the reply!
I know that 7mb bios body will not work but any way I flashed it. I’m not a bios modder many things are unknown for me. I just can do basics flashes by programmer or other ways but i never build a firmware that would work on laptop or other stuff. I tried to make couple modifications to this firmware (32mb) but it didn’t work. I tried FIT but it failed as You mentioned I also tried Uefi tool to inject bios body but it fails due to sizze mismatch. The only sucess i got on this firmware is reading 8mb by afudos but it never flashed anything aas it gives an error that dump is write protected. So I’m here looking for help.

By the way. May be this production dump 16mb is broken? I downloaded it from forum but can only confirm that it’s not working on my board. I havent checked it on production board as i dont have such. May be it needs some mods like clean me region and bootguard disable?

What do You think?


Only the ancient FIT v12.0.0.1020 to be honest (for two different reasons which are not important). But to answer your question, yes BG is completely absent/disabled (Profile 0, No_FVME) so there’s noting to worry about there. Besides, even if it was active at the CSME firmware, the user would need to intentionally activate it by closing the manufacturing mode via “fptw -closemnf”. The dumped BIOS also lacks BG entries at FIT, only the Production BIOS is configured that way (which is normal).


That’s not possible as this is a Pre-Production system so only the OEM has access to these internal SPI images. I did notice the 8MB vs 7MB difference.


Why do we need to increase it? The PRE system has an even larger 32MB SPI chip so size is definitely not a problem. The normal way to deal with this is to take the space from the Engine region. That’s what FIT does. All extra space is appended at the end of the Engine region because the BIOS must always be at the end. I’m sending you the old FIT. You can replace the BIOS region within it and re-build the entire SPI image in that way. If you’re talking about UEFITool failing to modify the BIOS, I can’t be of help there. But I don’t think working with the BIOS region only will cause issues at UEFITool. Leave the rest of the SPI rebuilding for FIT.


Obviously it didn’t work and no, the provided Production dump is ok. As I said, your system uses Pre-Production firmware which won’t accept the Production firmware from the Production dump. I’m mostly talking about CSME and PMC firmware which use different RSA Keys at PRD vs PRE PCH so they are inherently incompatible with one another. You can’t take the PRD SPI image and flash it at your system. It will fail immediately because the CSME firmware won’t load and thus won’t allow the CPU to take control and boot further. The goal is to use the PRE CSME and PMC firmware from your dump and then modify the BIOS region to hopefully make it work.

@code9523 - you are too funny! >> “I know this partial BIOS wont work, I know it’s wrong size… But I flash it anyway” ??? Since you knew it was wrong size, and wouldn’t work, what did you think the outcome would be when flashing? Magic?
Yes, I would not use AFU on this system anyway, it’s Intel based so use Intel FPT. Don’t use blindly, ie without help, instructions, us telling you to do this or that, I’m only speaking in general here in regards to AFU or FPT and my preference.
You have a hardware flash programmer, so you really never need to use either of these, except maybe later once you get it all sorted and put back together, then I would use FPT for any flashing I needed to do.

About 16MB file? It could be broken, did they say it was working dump wherever you grabbed it from? I’ve not looked at or used any 16MB file for anything, and didn’t plan to either, so it doesn’t matter to me if it works or not.
But yes, if that is a working file, it would need BG disabled and ACM/BG entries removed from FIT before it could ever have a chance to work. And another but, it can’t work anyway due to production ME FW is there, so you can basically toss that out.
I may use it for what I mentioned above though, so please attach by themselves into a single zip/rar so I only have to download those if I need them later.

Now, I have tool to work with this BIOS properly, please wait, test BIOS coming soon

plutomaniac - Thanks for the FIT info, I tried old and new, but didn’t have one old enough I guess Thanks, that was all I really wanted to check in FIT, about the BG, I assumed you did but wasn’t sure and since he mentioned it at first post I wanted to check to be sure.
On the stock dumped region thoughts I mentioned, I only thought maybe an actual stock dumped region would = 8MB vs that HDR region, but yes if it’s same then same issue would be presented anyway.

Yes, I wanted to increase it due to UEFITool would not rebuild at a BIOS region swap only, and I’m not great at FD editing to resize region, so wasn’t sure if I could build it manually in hex and then correct the FD BIOS region size etc.
And now mentioning that, this would leave final file 31MB, so still 1MB too small, so something’s got to be corrected in my mind (as you mentioned, by build with FIT instead)I did consider FIT building too, but it wasn’t working for me yesterday so never made it that far.
I’ve never built a BIOS like that with FIT, changing region sizes etc, so this may be best done by you at first, unless you don’t want to do it? I will try now since you sent me that FIT
* Edit - I looked, and don’t see what I expected at Flash Layout, all sizes are zero, so lost on doing that with FIT - Edit 2, never mind, that ways easy, and not unexpected

** Edit - @code9523 - Here is BIOS to test, put on with programmer only

First test these two BIOS trying the 2017 one first - Straight stock region swap in - one with latest original included microcode for your CPU, other with 2017 microcode from BIOS at post #4 ACM/BG removed from FIT on ALL
Stock2017
Stock2019

Then if both fail to boot, test these BIOS again trying 2017 first. These are same as above but with your original NVRAM in place and old original Setup, AMISTE, AMITSE/SetupData, 2 x StdDefaults outside NVRAM swapped in
This much easier than NVRAM swap of setup entries in NVRAM - other way nearly impossible for me, takes hours to redo all NVRAM especially when there is 100’s of entries.
These may fail no matter what, for many various reasons related to the new/old swapping of the modules mentioned above, but also due to AMI Hash mismatch (Sometimes that cause any BIOS edit to fail, other times nothing)
Stock2017NV
Stock2019NV

http://s000.tinyupload.com/index.php?fil…731289720798234

No boot. Only fans spin and cpu error.

Please give me full exact report for each BIOS, or did you mean that is same for all 4 BIOS? If yes, same for all 4, then you may not be able to use retail stock region with old PRE ME FW.
You are erasing chip, then blank check, before write/verify each time correct? If not, please always do this, otherwise you can have issues, failure etc.

Maybe only thing we can do is mod the original BIOS and see if we can correct the problems you are having.




So there is no boot on 4 dumps. I always erease chip and do blank check. On a stock bios with clean me laptop boots like this:
I press power button than it turns on lights and fans for 3 seconds and cuts power.
Then i press power button once again and it spin fans for like 5 times and shows picture.

On your 4 dumps laptop is starting like on 32mb dump with old me region:
I press power button it turns on like 5 times without any flashing lights only fans spins and after 4 or 5 times it turn on alienfx light and power button start blinking CPU error code 2 red 1 blue. Then it shuts down buy it self.

For me it looks like it cant initialize cpu or something as i checked woltage on cpu coils and it’s cutting it after couple seconds. It looks like when i press power button it gives 1.0…v on cpu coils then turn it off.

Thanks for detailed info!

My four BIOS I sent you are 32MB and have the old ME region, they were built from BIOS in post #4 that Plutomaniac did clean ME in (552read_clean.rar)
Seals the deal for me, on stock BIOS region not being compatible, especially since first set acts no different than second set. I expected different results from first to second set, at least something different between the two sets.

Back to 552read_clean, flash that. Then explain to me the issues you have, we’ll go from there. Also, once you do that, please zip or rar for me one image of each main BIOS page (ex. main, adv, chipset, security, boot, save and exit etc)
Unless it’s not standard AMI type looking BIOS (Gray/blue), and looks like Dells crap BIOS instead. If you are unsure which type I mean, show me a single image of the BIOS, then I’ll tell you if I want the rest of the images or not.
Please resize images, I don’t need 3-5MB images just to look at the BIOS, thanks [wnk]

I agree with LOST. There are many different things which could cause the Production BIOS to not work with PRE hardware of Engine/PMC firmware. Since these tests failed, the last thing to do is try to fix the current BIOS, if possible.

@ Lost:

Ok, I assume you figured out FIT then. It’s very simple and automatic. You load the components (BIOS, EC, Engine etc) and it will automatically figure out the padding. For a ready SPI image it’s even simpler. Just replace the BIOS region and rebuild. You should see at UEFITool that the BIOS is at the end and the Engine region is now larger by one 1MB, in this case.

I figured out what stalled me at first about the BIOS region size and swap with FIT, then few minutes later I realized duh same as swapping out ME . That’s what I did, opened file, saved XML, replaced that region, opened FIT, loaded XML and built.
Yes, all looked correct in UEFITool after that too, I just never did region swap that way so it confused me at first. I was expecting to see and change the BIOS region size at flash layout

You could do it like that but I think you can simply adjust the BIOS location input field at Flash Regions (or whatever it’s called) and end up with the same result, just without the xml hassle.

I’m used to doing the ME process a little bit now, and so that seemed easiest to me, since I don’t play with that tool often enough.
It’s too bad CPU is soldered to PCB in this case, otherwise I’d probably suggest retail CPU at least to try, in case that silicon is part of what’s causing him the issues with the temps/fan speeds, and since it is soldered this is something we can never test to confirm/deny too

Well as I said in my first reply, there are a lot of “mays” and “ifs” when working with PRE hardware and firmware. We can only try but don’t get your hopes up.

Guys! How about thundertbolt? Can it cause an issue? In the production bios there are thunderbolt settings in es there is no thunderbolt settings. also when i try to update TB firmware using dell/intel TBFW tools they both said that there is no TB devices found in the system! Also i have USB C controller error code 43 in device menager and laptop does not recognise USB hub with devices connected to it.There is I think a TB firmware chip near TB controller. May be i should flash there firmware?

Also there is a chip with a (I suggest) with a Alien FX firmware should be or a separate EC firmware like it is on AW 17 r4 and all old AW’s. May be we need to extract it from the factory dell’s bios. Because as far as i know when i was working with dell systems you always had to flash both chips with 16mb and 4mb may be this is an issue?

I mean mean if we swap bios body to dell’s offical bios update may be then EC controller needs a separate firmware on separate chip?

Board chips https://drive.google.com/file/d/1NwLoW6i…iew?usp=sharing

By the way I done clean windows install. And I installed aw command center and it recognized laptop as aw17 using Fn + F12 key I turned off alienfx for good. Now its compleatly dark even when i start laptop. But now alien cc says no alienfx devices detected!

Please use the edit button to add info to your posts within a small time frame before some else replies.

It is very likely that some features don’t work at these Engineering machines because they weren’t ready at the time, their firmware was bugged, old hardware revisions etc. There’s not much one can do without Dell’s internal firmware for that Engineering sample so the goal is to get basic functionality working. TBT is extra at this point and I don’t think its firmware is included in the BIOS region. Explain exactly what important problems you’re facing and provide whatever info LOST requested, just in case something can be done. There is no need to send me the stuff requested by LOST as well.

It doesn’t matter if that can or cannot cause issues, it’s not easily removable from the stock BIOS, so not something we can address.
As for TB and USB, don’t try to flash them, until you first dump them with some programmer or software, they may be fine and have working FW in them now (I suspect they do), you just have to find proper software that will work with them.
Yes, it’s very likely there is a EC chip, this is common with Dell. This would control, or at least help control the lights and fans sometimes too. EC FW is not something I can edit, well I can edit anything, but I mean I have nothing that will break this down into readable settings to change etc (usually)
Dump the EC chip and send me a copy to look at.

EC chip is empty. I checked there is no firmware there.