Anyone know how to mode CSMCORE manually?


Was wondering how would you go about replacing orom modules on older Aptio 4 bioses inside Csmcore? I have tried using Uefitool to open up the compressed section inside Csmcore and extract the Raw file body but when I reinsert it it becomes corrupt with Uefitool complaining of bad Dos signature in pe32 volume. Is this a checksum issue or just not counting bytes correctly?


@davidm71 :
If you want to update/replace any Option ROM module of any AMI Aptio IV BIOS, you can do it easily by using the UBU tool.
If you want to do it manually, the easiest way is to use the AMI MMTool v4.50.0.23 or v5.0.0.7. Dont forget to check the “Link present” option.

@Fernando ,

I am aware of that and have tried that however I have come accross a bios file belonging to user Net7 for a Buffallo 5800 NAS that has two Intel GE Lan modules duplicate of each other in succession after each other in the Raw file. Ubu only updates the first one and ignores the second. Same goes for Mmtool from version 4.5 and up!

It is quite perplexing.

Just in case anyone is wondering how to manually insert the ROMs into CSMCORE I figured it out this morning. What you have to do is extract the Raw file with Uefitool, open it in a hex editor, search for the header of the rom you want to replace and then select it and copy paste the new one over. The trick though is to update the size field that is located to the left of the header to match the new rom. I was able to easily use that size information to select exactly the beginning and end offsets of data I wanted to replace. Worked out well. Not to forget about reinsering the body of csmcore raw file back into your rom!