Asus BIOS Update Failed

Hi guys, Just joined the forum after hanging around for a while and find a lot of information from this great website. Thank you very much for accepting my request…

I have this old ASUS F2A85-M motherboard, everything was working fine until I tried to update the bios to the latest version that I downloaded on Asus website, and now it won’t boot…the MEMOK LED is constantly flashing and beeping. I tried different version of the BIOS with the help of CH341A Programmer, but to no avail. I’ve also check the Memory Module and it is ok…Unfortunately I don’t have any copy of the original BIOS…

Is there any chance that the motherboard can be revived?

Thank you again for this very helpful forum…Yes, I learned here how to use CH341A Programmer…
Apology for my bad english…


1. Asus F2A85-M Motherboard
2. AMD A4-5300 Series CPU
3. Zeppelin DDR3/1333/4Gb Memory Module
4. 25Q64FVAIG-1305 - BIOS chip

@bubbles - So you did not dump the chip with programmer, before you wrote to it with programmer?

For W25Q64FV you need to use software version 1.30 or 1.34 and W25Q64BV ID or writes will fail, these versions included in below package if you don’t already have them…213094641136166

You need to remove the capsule from the stock BIOS before you write to chip, if you didn’t know this.
Here is latest BIOS 6508 with capsule removed, program in using 1.30 or 1.34 and BV ID and the board should start. Do this >> Erase chip, blank check, then open BIOS file, then write, then verify.

@Lost_N_BIOS - Thank you very much for your reply!

I revived my motherboard after I post…using the method I learned in this forum…

The only thing that baffles me is that, I replace my memory module with the one I borrowed from my friend. They are the same brand (Zeppelin), the only difference is the speed (1600) and mine is (1333)…After I installed my friend’s module, the motherboard boot-up…I shutdown the power and replace the memory with mine, and to my surprise the motherboard boot-up…

Out of curiosity, I reprogrammed again the bios chip, and I retain my module in the board. The same problem appears again, the MEMOK LED is constantly flashing and beeping…I repeat the process by swapping again the two memory modules…and now my motherboard has been revived with my original Memory modules…but I’m still observing it.

Again thank you very much for this very helpful forum, I really appreciate it!

Stay safe!

@bubbles - You’re welcome, and I’m glad you got it booting now! Yes, sometimes if you switch memory, or try to boot without any and then with only one stick, it will reset the BIOS and or load fail-safe.
Now, load optimized, save and reboot back to BIOS, then make all the changes you want. Maybe the BIOS does not like your 1333 stick so much