Asus G501JW M.2 NVMe/Original M.2 not recognized

Good morning,

I have a somewhat special case and I’m looking everywhere without finding a solution… So, I’m addressing you (once again) please.

I changed the motherboard of a PC (UX501J). The seller sent me a different revision which appears to be from a G501JW PC.
I looked at the differences and only the revision changes (N501JW rev 2.1 for the original, rev 2.0 for the new).

So I find myself with a motherboard that works but without my data (serial etc) and above all that refuses to boot on the original M.2! It is not recognized or anything but readable on a USB drive.

So I tested with another new M.2, I can install Windows on it but when it restarts, it doesn’t see it and boots to the Bios in a loop.
I tried with a classic SSD, on the 240GB, it starts and everything is fine but with a 480GB, same result as with the M.2!

So I put the original Bios chipset on the new one, same thing.

I think there is a modification to make for this card to accept M.2 (knowing that it is equipped with the M.2 port!) but I can’t find it.
Could someone help me mod this and put the info in the new bios please?

I attach the dumps:

DumpOld contains information from the original PC
DumpNew is the dump of the replacement motherboard.

Thank you so much !

dumpAsus.rar (6.6 MB)

like board fault or bad bios installed

Possible but since the M.2 is recognized during the installation of Windows, I tell myself that the port works.
I’m thinking of the bios but I don’t know how to do for this type of case.

try reflash bios or upgrade it

I try it without success. I think support is missing in the bios file. Maybe the Intel part ?

And whats the model of that M.2 drive?

EDIT: Thas what i suspected. Theres reviews of the G501JW-xxxxxxx with M.2 PCIe AHCI SSD.
EDIT: Correction, the NVMe review is NOT NVMe is also AHCI
Asus ROG G501JW Laptop Review | KitGuru
Asus ROG G501JW Gaming Laptop (

Both your dumps (and original Asus file) do NOT contain the AMI NVMe dxe driver to support the use of NVMe.
Want to try to mod it? Follow the guide:
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (

If another M.2 AHCI SATA drive is detected in bios then the slot is not dead… at least as logical view.
The Kingston is an M.2 AHCI or a SATA 2.5 disk?
Be more precise on info provided… a 120GB Kingston??? Washing machine type drive???

Resuming, your system board only supports PCIe AHCI M.2 disks.

The original is the one from Asus directly. It’s a MZ-NLF1280. (M.2)
The second is a Samsung Evo 970. (M.2)
I try with classic SSD Kingston 480Gb / 960Gb with the same bad result.

Kingston are classics SSD. The only one who work with this board is a 120Gb Kington… It’s incredible.

The Kingston are classic 2.5 disk from A400 serie.
I understand but why the original disk isn’t supported ? I try on a USB case and i can access to data so the M.2 is ok.
If the board support only AHCI, the original disk must be detected, no ?

Well if theres a incompatibility from the disk (Belonging to the old motherboard model)… ask Asus why…what else can we say to you?
This is usually not in the “classic” category mods…here on the forum.
If the disk is not seen in bios then is incompatibility, if seen then its user error on OS install/bios config.

I misspoke…
My original motherboard was REV 2.1, Aliexpress seller sent me REV 2.0.
The Bios is not the same if we compare the two, the new one is a ROG, the original not at all.
I think the replacement board’s bios doesn’t have compatibility for the M.2 drives I have (rev 2.0 must be older than 2.1 if I’m following the logic).
I just want to know if someone can help me solve the compatibility issue.
We are in the Mod section and I think that’s what I would like :slight_smile:

I already told, i checked 3 files, 2 dumps (G and N) and the original from the N, none have the AMI NVMe support.
Incompatibility hw of the motherboard models against PCIe AHCI drive models its another issue and usually is OEM blocks/other.
You can wait for another user opinion or even post a new specific [Request]… sry to say but the waiting can be long on this issue.
Good luck.

EDIT: Again… yes you can try it for the EVO solution, not guaranteed due to the motherboard design and M.2 support interface for NVMe.
No if the objective is the use of the old/original motherboard M.2 AHCI drive.
AHCI drives dont use NVMe protocol.

I add the driver but i have a blackscreen on start.
If i can abuse and take few minutes of your precious time, can you check if i make something wrong please? I see the drivers on MMTool and all seems to be ok.
Thank you very much.

Hello @Tiripstruk,

I believe the MZ-NLF1280 is a SATA M.2 . Are you sure this was the original drive?

Hello @68k-dude
The MZ is the original. It was on the old board with a 1To 2.5 drive.

Check seems OK, no PADS but i would recover the machine and do the mod only on bios region from dump and append it back or flashing only the bios region with fpt tool if access to regions unlocked.
MMtool 5.xx and regular DXE not the small, besides the function of both DXEs the same.

EDIT: Im not english native also… but the issue here is that this is not a simple task to explain on a forum for unexperienced users, and i will not and cannot loose my time with this, me or anyone else as its delicate situations that are performed by TI on techshops.

Users who come to search for mods, MUST be aware of the risks in it.

RECOVER the machine by Asus procedures (if available…that i doubt) for that model or will have to buy an SPI Programmer, with the previous dump files made, it CANNOT be programmed from Asus files as they are not complete SPI images, no ME region and so on.

After recovering i will explain how extract and mod only the bios region.

1 Like

I will try to understand and fix this.
I admit that it’s complicated knowing that English is not my native language at all, the tutorials don’t speak to me and I have to translate etc.
There, on the pc, I only have the white light on the Power key and nothing on the screen, the fans start spinning after a while.

If I understood correctly, I must find how to make the mod only on part of the Bios?

Thank you very much for your precious time, I know it’s painful to talk to a beginner and I’m infinitely grateful for your patience.

The PC left with the original file.
It only boots on the Bios or on a Windows key as before.
I totally understand the situation and I imagine that you have more to do… It’s really nice to take the time to help.
Thanks again.

PS : I have a programmer.

If the system boot and its bios accessible is not a case for SPI programming, do the bios mod again as i explained.
You said only a white ligth and black screen… that was not like “before”… damm it.

Bios region extraction from your dump, (names, ext as you wish, ex bios_reg.rom)

MMtool 5.xx

Inserted DXE

Merge back mod bios_region

FPT tool method, from ME 9 tools package

Dump biso region: fpt -bios -d bios_reg.bin

Test access: fpt -bios -f bios_reg.bin

If success, then flash mod bios_reg.rom(bin)
Flashing: fpt -bios -f bios bios_reg.rom(bin) the bios region you mod from the dump.

EDIT: Not a mistake, an option for not corrupt other SPI areas and for evading MMtool security warnings to Asus bios header from modifications.

I said MMtoll 5.xx not 4.xx, i just made and test…why do you think im giving such instructions…look at the damm captures…its the full DXE.

1 Like

Sorry, I expressed myself very badly:

With the bios file dumped from the new motherboard, I have a boot but only on Bios or installation key.
If I launch the installation, I can see the M.2 Samsung disk or the Kingston 2.5 but once the installation files have been copied by the Windows installer, the PC reboots normally and continues the installation, but there it starts on the Bios and cannot find the hard drives.
So I dumped the file to add disk support as you advised me (at least for the Samsung) except that the file I generated (and posted here) only gives a black screen, white light on the power and that’s it.
If I flash the base file again, I get the image back.