Asus GX502GW bios unlock request


Please if someone can unlock all of the advanced features on my BIOS, that would be much appreciated. I have uploaded the file in onedrive, it contains intel Fpt backup and Afuwin, and the orignal bios from asus.!AvvucQQ6b3IOlkp3FrPtR3JXWwC8?e=ppnMNE


@ferasalloush - Please reflash STOCK BIOS using Stock BIOS flash method, preferably EZ Flash from within BIOS if your BIOS has this, if not follow the standard BIOS Update procedure for your system

Then do the following ONLY - And when you upload this file for me please upload to or
Please also include images of your BIOS, one of each main page (like main, advanced, boot, ext etc) You can probably use F12 to screenshot to USB

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C.2” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

I reflashed stock BIOS using ASUS EZ flash from within the BIOS as told. I have ME V12 fyi, so I used FPTw as you told me, i dumped the bios and wrote back the region with no errors. Also images requested as attached with the dump.

@ferasalloush - nice to see you can write back with FPT without issue, saves you some hassle later that you’d normally have to do before you could flash back mod BIOS
Wait! Please redo step #2 in spoiler above and pay close attention to the command, you didn’t write back BIOS region in your image, you only dumped it twice and no write back attempt

@Lost_N_BIOS Sorry about that yes your right, i corrected the command and now i got an error : Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.

@ferasalloush - please follow this guide, starting at step #6 because I will give you info from 1-5 below
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file to >> Shell.efi

FPRR variable to change >> 0x1205

So, at grub prompt you will type the following (Case sensitive) >> setup_var 0x1205 0x0

And show me image of this grub screen after you do it, so I can see entire output screen, I want to see if it’s already 0x0 (Disabled) or 0x1 (enabled)
Then once done, dump BIOS region again with FPT (delete previous first, or move it), then try to write it back again and see if you still get 167 or not.
Sometimes this just needs disabled, other times it’s not actually controlled by the setting, but rather in a module you can only change by direct edit of dumped BIOS (using programmer to program back)

If we cannot disable, then the only way you can flash mod BIOS on this system is with flash programmer, or 1 of 2 risky AFU methods (one not as risky, but not ideal)

@Lost_N_BIOS Still have error 167, and below is an attached screenshot of the grub.


One Of: Flash Protection Range Registers (FPRR), VarStoreInfo (VarOffset/VarName): 0x1205, VarStore: 0x1, QuestionId: 0x6ED, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 D5 10 D6 10 ED 06 01 00 05 12 10 10 00 01 00}
0x401AF One Of Option: Disabled, Value (8 bit): 0x0 (default) {09 07 04 00 30 00 00}
0x401B6 One Of Option: Enabled, Value (8 bit): 0x1 {09 07 03 00 00 00 01}

@ferasalloush - Thanks for grub image, as suspected from what I already see in BIOS, it’s already set to 0x0 in NVRAM/BIOS settings
So, this means it’s not FPRR set by setting, but rather a BIOS module itself holds the lock and the only way around that is you to dump the BIOS with flash programmer, edit it, then program it back in.
And for that, I have to be able to find the correct edit too, which I looked and cannot see in this BIOS It’s not something I’m great at finding if it’s not similar or exact to the one I know

So, the only way you can flash mod BIOS on this system is with hardware flash programmer like CH341A or similar + SOIC8 test clip with cable.
Let me know if you need linked examples to those items on ebay, it’s cheap, less than $7 shipped. I suggest this highly over trying the risky methods I mentioned, one may be OK to try though if you want, let me know if you want to check it out

@Lost_N_BIOS UPDATE ! i reflashed the bios region successfully as attached in the picture in this link :…652105932887639

@ferasalloush - so what did you have to do, or did BIOS I sent you remove the lock but you did something wrong first time you tested that BIOS?
So, what now, we unlock BIOS?? If you changed something in grub, make a new dump and send to me, so it’s unlocked from the base get-go, and then I will edit that.

@Lost_N_BIOS I went to the shell.efi again, then I disabled the BIOS lock and FPPR both at the same time and restarted, then I used FPTw64 and it worked, that simple. here is the link for the BIOS dump :…564819322221376

@ferasalloush - Nice, so it can be disabled as we initially thought, you must have maybe missed something first go around (FPRR, this is what causes 167 usually)
So, the above dump is after you unlocked it right, you were able to dump the above file and write it back right then too, correct? If yes, OK, we unlock now (out of time tonight, but will get to it this weekend )

@ferasalloush - Here, quick test needed before I do full unlock - Please let me know which of these BIOS show a new second advanced? Test in order below, stop once you see it and let me know which.
1. SetO
2. SetAMIT

Ohh! Wait!! Please toss out all biosreg.bin files you’ve made up to now. Sorry, I didn’t see the mess until now
Then reflash stock BIOS using stock method (EZ Flash I assume), then redo the unlock BIOS Lock/FPRR and dump again after that with FPT using new name, then send me that new BIOSregnew.bin
I cannot use this dump you sent, WAY TOO MANY Failed/pointless changes in there!

@Lost_N_BIOS Ok I will re flash stock bios, and will do the bios unlock and will upload it for you.

but I don’t understand what do you mean by this ???

“quick test needed before I do full unlock - Please let me know which of these BIOS show a new second advanced?
Test in order below, stop once you see it and let me know which.
1. SetO
2. SetAMIT

@ferasalloush - Please flash stock, then redo unlock, then dump BIOS with FPT again and send to me (after you’ve unlocked it, and successfully flashed back, then makeFPT BIOS region dump and send to me)

Then I will make you BIOS files to go with above thing you asked about, it was going to be a set of three BIOS I need you to test as mentioned, but I did not upload because I then noticed all the mess in BIOS with previously unnecessary edits
So, those BIOS are not done yet, once you send me new clean dump I will make that set for you to test

@Lost_N_BIOS ok will do it now

@Lost_N_BIOS Done as requested :…635881387362359

@ferasalloush - OK here is the quick test needed before I do full unlock - Please let me know which of these BIOS show a new second advanced?…529396159317624

Test in order below, stop once you see 2nd advanced and let me know which. Flash each one >> FPTw.exe -bios -f filename.bin << Then reboot to BIOS, load optimized defaults and reboot back to BIOS and check to see if you see new advanced or not (2x advanced for this test, just a test)
1. SetO
2. SetAMIT

Also, I need an image of your Exit BIOS page, thanks And, do you use the “Security” page at all?
All settings will be left at default, or I can change them to whatever you wanted, but in order to add 2 x advanced + Chipset I have to replace one main menu (unless you are OK with swap new advance for old advance)

@Lost_N_BIOS The SetAMIT opened up the second advanced tab so i stopped at this step. I attached the EXIT page in this link :…014885838466867
About the security tab I actually don’t use it except to disable secure boot, I don’t mind replacing the advanced tab with the new one. Your awesome man thanks.

Thanks for the test report, and image. Have you used AMIBCP (I will send PM)? If yes, look at your BIOS and compare the original advanced with the hidden one, some stuff in original you want/use may not be in the advanced, that’s why I wanted to replace security possibly.
If you know 100% you will always want Secure boot disabled, I can hard disable that and then swap out the new advanced into original security position and then add chipset too
Plus I believe I can enable the overclock performance menu/tab too, without needing more tab positions, that will be my next test for you tonight

You’re welcome, and thank you too!!

* Edit - @ferasalloush - Please test in order shown below, stop once you see Overclock Performance Menu appear (should be new tab/section by itself)
1. SetAMITOCP.bin
2. SetAMITOCPS.bin…835466878175270

@Lost_N_BIOS Hi, Yes I used AMIBCP and we can replace the security tab and keep secure boot always disabled. The only thing that I modify in the original advanced tab is as follows and the rest is default :

1 intel virtualization technology - disabled
2 VT-d - disabled

I will Test the OC and report back in a few minutes

@Lost_N_BIOS I just tested both, none of them opened up the OC menu. Hey ! do we need the main tab ? its only an information tab ?

Thanks for test report! Hmm, please test these two now, if these don’t work, I will have to add that in other way (if possible)…370025361196391

No, I don’t think you have to have main, why? Are you thinking if we can’t get OC menu to show up in way I’m trying now, to replace main with it? If yes, then yes, we can do that too if you wanted

Secure boot is disabled by default, so no changes needed there, I just hide/replace it.
As for Advanced, Virtualization is in 2nd advanced, but Vt-d is not, however it is located in chipset. SATA/AHCI is in chipset as well.
So, if you want, we can just replace original advanced with hidden one

So, we can do this, if you want, if above doesn’t give you the OC menu/tab
Main >> Overclock Performance Menu
Advanced >> Hidden Advanced
Add Chipset

This will leave you with security page, or we can leave main and replace security with Overclock Performance menu, up to you.