Asus h110 m-k me recovery

hello, my motherboard is Asus h110m-k, after updating the bios to the latest version 4211, it shows me the firmware version in the bios, I can’t install the intel management driver, can it be repaired somehow or the motherboard to be repaired? Thank you in advance for your answer.
Here photo

Yes, the procedure is this guide: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization - Special Topics / Intel Management Engine - Win-Raid Forum (

EDIT: You cant ask that question remotely…to no one, you asked about ME and the symptom presented by you, fits the guide linked, that it.
This is a user task ONLY, the actions cant be made remotely, you dont have the skills ask a friend more competent.
Its not easy for inexperienced users, but anyone can try it with devotion to the guide, thats why TI techs on repair shops need their jobs and get payed… they do still deserve to have a life and payment for their services, right?
Over_n_out, good luck.

thank you meatwar, tell me if something else like tpm or something else besides me version could be damaged after this bios update? I don’t know how to check it because I would like everything to work properly on the motherboard, like from the factory he​:slightly_smiling_face::slightly_smiling_face:

I read now this proffessional guide… For me its like magic… I dont think i can do all this steps properly and repair it​:unamused::unamused:

ok you say the truth, but it would be easier for me if you write me which step for me and my motherboard is exactly so that I don’t get lost and make a mistake? I managed to make a mod bios myself and flash it, which worked, maybe I’ll succeed here, I’ll try, thank you my friend.

Resuming…get the ME11 tools package, make dumps for keep safe and for working, get the ME FW image from the repository, follow the guide and flash it, the guide is very well elaborated and a small detail missed can fail, so its a reading course and learning.

Hi, I will try today, but I wanted to ask you about one more thing so as not to move the topic, so I did a bios mod and discovered all possible board options in amipcb, I couldn’t force myself to discover eist, although I gave it on show but it didn’t show in bios, I did this is to discover hpet c states watchdog timer tco timer and other settings usb pch and usb settings like xhci hand off, usb 2.0 controller mode, ehci and others i wanted to improve input latency pc because i have floaty mouse issue the mouse has input lag i read that it could be Intel® USB 3.0 eXtensible Host Controller Driver xhci, but i tried to make usb 3.0 ports work as 2.0 but device manager shows usb 3.0 all the time, can’t be changed on this board do you know any suggestions or xhci controller usb mod for all usb ports as 2.0? the board has xhci hand off options but no xhci mode usb 3.0<2.0 option, i try off all single usb ports 3.0 in bios, device manager still show usb 3.0, and ports usb 2.0 works on xhci 3.0 controller its bad input for mouse and keyboard and give huge input latency.