Asus TUF Gaming FX506LI BIOS 310

I would like to request your help in unlocking BIOS menu for this laptop.
CPU: i5-10300h GPU: GTX1650ti mobile bios ver: latest 310
The dump.rom file is in the link:

Thank you for your help.

Hi, please take some pictures of the menu currently visible in the BIOS

Thanks for the reply.
I uploaded them here:

I hope these are enough. If not please tell me what else to send.

to you, report the results

I tried to flash it but “Error 167: Protected Range Registers are currently set by BIOS” happened so I’m trying to follow this guide:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing
and followed it to where it says “At the EFI Shell, run “setup_var 0x*** 0x^^” command”
but an error happens saying it can’t find the value I found in this file:
File_DXE_driver_Setup_Setup_body IFR.txt - Google Drive

It seems I’m stuck here.
Can you help me out?

BIOS lock appears to be disabled in the BIOS you sent.
BIOS lock, located at position 0x17 in PchSetup.
Check this location with ru.exe, 01→00. If it is already 00 then you may need a sop8 programmer to refresh.

I tried with GRUB first:
5.jpeg - Google Drive
This is RU.efi:
6.jpeg - Google Drive” it seems neither PchSetup or cpuSetup exit or I’m doing something wrong.
Edit: I updated GRUB to latest version and tried setting “Me FW Image Re-Flash” from the guide to 0x01. This is the result:
7.jpeg - Google Drive
The first command gave an error but the second one seemed to change it but it got reset to the original value?

Blockquote GRUB:
5.jpeg - Google Drive

Maybe it’s 0x1 (not 0x01?)

Blockquote This is RU.efi:
6.jpeg - Google Drive” it seems neither PchSetup or cpuSetup exit or I’m doing something wrong.

yes it goes into the wrong place 。Sorry for so long, I have forgotten.
So I found one
, the lock is at pchsetup (0x17)

It worked!!
The problem with RU.efi was the version I used. I downloaded an older version and the all UEFI variables names showed up. From there I found PchSetup changed the value of 0x17 from 0x1 to 0x0, saved it and then rebooted.
On windows I flashed the rom you sent me successfully.
Lastly I went to BIOS and all the settings showed up.
Thank you very much for your help.
Result.jpeg - Google Drive

Can you tell me how you modified the BIOS?
I want to try and learn these stuffs :grin:

Hello, in the Modifications and Guides category. Lost_N shares his vast experience and approach. Where is where your learning begins.

Hi… The link seems to be expired… Can you share the modded BIOS again? Also, will it work on another Laptop with the same version of BIOS??