Bios upgrade failure - black screen after flash


Last month when the 3002 bios release came out for the Asus Z170-WS came out after I flashed from the 902 version I was greeted with a black screen at post.
I couldn’t even get into the bios setup. As my Z170-WS does not have an onboard video dvi or hdmi port or anything I could not test if the igpu was being
initialized instead which was my theory. I tried unplugging the cmos battery and clearing cmos and nothing worked until my second 780 GTX video card was
removed did the Z170-WS finally put out a picture and was able to get into the bios. To make matters worse the bios was falsely identifying my 6700K Skylake
as a Kaby Lake cpu. So in anycase this time I manually selected PCI-E as primary GPU and plugged my second 780 GTX back into the board. This time because
I had corrected the boot settings I was able to boot into windows which configured the display but not during the first 10 seconds when the bios was posting I still
had a completely black screen.

Only fix was to roll back to 902 and later noticed that as consequence of flashing the 3002 my ME firmware had been upgraded from 11.0 to 11.6 and thank god
not having issues on 902. Nor did I have any issues with any previous bios release going back last year. So I emailed Asus a couple times warning them about
how buggy this release is and that they should pull it from their web site and got lip service. Finally they emailed me that my 6700K is not an approved CPU for that
motherboard which was very funny because its on the list. So anyone know what probably went wrong?