Bricked ASUS Z68-VGEN3 UBU microcode update

He linked stock edited BIOS, so no your serial, UUID and Ethernet LAN MAC ID all would be missing since you programmed that in with flash programmer.
It’s all OK to not have, since you can’t RMA now, except for Ethernet MAC ID, if that is stored in BIOS and not on Ethernet chip FW, then your Ethernet will not work until you fix it.
We can fix this stuff with FPT software now, so you wont have to use programmer again, unless using programmer would be easier for you than learning how to use FPT, if you don’t already know how to use it.

If you mean you dumped your “badFlash.bin” as in the file at post #1, this is not a dump, that is a stock edited BIOS (That you may have later dumped, if you programmed that in with programmer).
When I mentioned dump, I meant dump with programmer now, after the bad flash and BEFORE you did anything with programmer. << This is the only file that will have your serial, UUID, MAC ID all in place and original. Or, any previous BIOS backup you made with any tool, BEFORE this happened.


I dumped my original bios with the programmer program before I erased the chip.

I assume it has all my information on there.
Let me know if it looks good and we can transfer the data to the stock modded bios.

If not, I can learn the software you mentioned. (4.44 MB)

Really good news, even better that the BIOS is much newer now. Don’t forget to upgrade ME to latest as per the instructions.

@PhatAgent @Iken

I would really appreciate your help.

1. I have a similar problem to what @PhatAgent was facing, with some nuances.
2. I was running Bios version 9903 modded with nvme with no problems.
3. I’m not sure exactly when, but at a certain point, possibly after i flashed that modded bios, i updated the Intel ME to latest supported/recommended version in @Fernando 's guide.
4. Inspired by @Iken 's offered bios i wanted to update my own modded bios with the newer OROMs but without the microcode update (to my understanding the MC is spectre/meltdown related and i didn’t want to risk reduced performance). I did not dump the bios that’s currently live and running, but instead used the modded 9903 bios file i had saved on my computer.
5. I made changes to that file with UBU (Intel Sata and JMICRON), put the patched file on a usb stick and flashed through EZ-Flash.
6. All seemed ok but when the pc rebooted it couldn’t post.
7. No Beeps, No signal on the screen, and CPU ERROR is lit SOLID (@PhatAgent 's was blinking).
8. Mobo responded to 7 second press on power, Mem OK! button was responsive too. Clear CMOS seemed to be working but not helping, same for battery removal, CPU reinsertion, running one with of memory, with/without the PCIE GPU, basically nothing works.
9. The BIOS chip can be pulled out. Very hard to see the writing. Seems to be something like Winbond 25Q648VAIG
10. I would deeply appreciate a guide on how to repair the motherboard, what tools i need in order to fix this without frying the chip and how to do this properly
11. In the meantime i ordered a pre programmed bios chip for this exact motherboard with the latest official firmware, which would probably be version 3306. plan was to flash it to my old modded 9903 (the file i used before i made the recent updates with UBU. I currently don’t have access to those files (my old modded 9903, and the new one that failed).
12. Since the CPU ERROR led is solid, I’m worried the new chip would not work either, or that flashing to my old modded 9903 bios would fail too. Perhaps there’s some Intel ME involvement which is preventing POST?
13. Would it be better if i ask the ebay seller of the new chip to pre program it to @Iken 's bios, and downgrade the MC afterwards? is that a better alternative?

Thank you

@cookie Order a CH341A programmer and possibly U Type Flat IC extractor, see #2

Looks like your got a socketed bios chip, so there’s not too much danger for read errors, but more for bent legs- be careful. Dump your old bios chip (backup it), it may contain board specific information (UUID, mac- address, serial…) Read it twice with different programs and compare the result, should be 100% identical.

Attach the file here or give a link to it.

Your pre- programmed chip is a stock bios on a chip, you could’ve easily done that yourself with a new chip and a programmer.

Chip is probably Winbond 25Q64BV AIG, most programs will work with that chip.

Hi, Thank you.
Do i need to mod the programmer? i saw some conflicting information regarding 3.3V and 5V, unsure what i should do with my chip.
and regarding the chip model, what you wrote sure makes sense :slight_smile:

Should i use the black/gold one or something else? I saw that one has a jumper but couldn’t find information which voltage is on which position. There are quite a few programmers. A link to Aliexpress/eBay would be mush appreciated. I’d like to order sooner than later because of shipping times.

I’m getting a HDD enclosure later today, I’ll upload my old modded 9903 bios then.

And again, thank you.

@cookie Those are low quailty items, so there might be always one in betweeen that’s not OK. I bought one that got warm, didn’t write first tries but afterwards worked perfectly fine. There’s always some extra attention with being 100% sure that you read/ wrote what you intended to.

If you need a soic 8 clip or a 1.8V adaptor depends on your hardware/ plans for the future…

Something like:…r/dp/B07SHSL9X9…r/dp/B07V2M5MVH…e/dp/B08KG7YM45

And maybe something like

There’s a lot of talking about 5V on the signal lines, I flashed quite a lot of the normal 3V chips with those programmers, worked without problems. Look at picture in first link, jumper is in corerct position there (TTL or SPI), it’s written on the downside of the circuit board somtimes, too.

Sorry for this “The following contents have been linked to this post:”, it came up automatically…


Apologies for the late response, I did not get notified for some reason.
I can’t really add anything stated by @lfb6 (thank you for your help here) as I don’t have a programmer and have never needed one (I have been fortunate!)

I can’t comment on the version of 9903 you used but the performance effect to my system by the Spectre/Meltdown patches was negligible, especially as I disabled Meltdown via the registry “switch” and of course full PCIe 3.0 x4 NVMe SSD performance.

With reference to Intel ME, just using the file I attached should have worked regardless of the BIOS used; any subsequent BIOS update would not override the newer ME version. However, I previously found it would take quite a bit longer to complete the process (I assume having to bypass the ME section), hence my replacing the ME region directly.
Also, I have always updated directly from the installed HDD/SSD, not a USB stick.

Sorry I can’t really be of more help here but I’d be happy to answer queries if I can.

@Iken This is a late response, but my previous post on the last page was never resolved.

Was supposed to merge my motherboard data(serial numbers and such) with the new flash but never was able to figure it out.
Any ideas?

@PhatAgent - Sorry I never replied back, it’s hard to keep up here and stuff is lost to me very easily!
I have your dump from #15, what stock or mod BIOS do you want this inserted into?
Since this model does not have flashback, it would be ideal for you to dump GbE region and BIOS region w/ FPT and send to me to edit, but first we need to see what error you get if any, when trying to write back BIOS region with FPT
Then we disable anything stopping it, then you dump BIOS region & GBE region and send to me for edit. Or, you can simply dump current working BIOS from chip with programmer if you have it, then I can edit that and you program it back.
Which way do you want to proceed?


What is FPT?

As for the bios version, I used Iken’s modded 9903 bios.
Which works perfectly for me. Not sure If it’s using the latest MCU etc at this point but it should be fine.

Is it not as simple as merging the data from the bad modded bios with the correctly modded bios?
What benefit is there to dump the bios that I am using now; it should be the same as what’s already posted in Iken’s link correct?

And no worries on the late response, It is working fine regardless.
I appreciate your response.

Since I don’t have flashback, it’s not a big deal to pull out the programmer if it does fail.
I’ll have a fallback with that tool.

@PhatAgent - FPT is Intel Flash Programming Tool. But, reading post #15 again, I see you have programmer, so we can use that if you want, or I can show you how to do via FPT?
How did you flash in 9903 mod BIOS? I only mentioned dumping now, so you could easily and safely flash mod back via FPT, but if you’ve already flashed 9903 some other way and it was all OK, then I can mod that and you can flash it again same way.
Do you want updated microcodes? Yes, I will extract the system specific info from a few places and insert into the modded BIOS

I just updated the bios from within the bios itself.

Pretty sure anything below Z77 does not have the bios security checks so there is no problem flashing a modded bios.

That modded 9903 bios might already have the latest updates, but you can check if it isn’t a problem.

Thank you

@lfb6 @Lost_N_BIOS , Hi,

Would appreciate your assitance.
See my post #17

Attached is a full dump of my bad flash. Could you instruct me how to properly reflash it with the Ch341a programmer and AsProgrammer without losing my serial, uuid etc info?

What i’m trying to achieve is to have a bios which is like the modded 9903 posted by Iken, but without the microcode updates. In other words, to have the microcode data from the bad flash i had (or the modded 9903 i used to flash, which i will attach shortly), with his version of oroms and intel ME (should be v8.1.70.1590 unsure what ME version the bad flash has).

[Edit - removed links. Please contact on PM]

Many thanks

Any help would be greatly appreciated

Use FD44Editor for extracting / transfering you board specific data, use UBU to exchange µcodes (edit MCUpdate.txt and put µcodes in corresponding directory)


AsProgrammer v. 1.4.1 was able to properly read, backup and clear the Winbond 25Q64BV chip, but not able to write properly. Any attempt resulted in error (windows 10). Eventually i was able to write the chip and verify it successfully via flashroom v.0.9.9-97-g29333a0 included in the CH341A Tools.

1. In attempt to preserve my system information i first tried replacing the ME section of my bad flash with the original ME binary (verified identical against @Iken 's modded bios), via UEFITool_v0.28.0. sadly that DIDN’T WORK. Cpu error lit solid. Panic ensued.

2. I then tried flashing Iken’s bios as it was, and my pc POSTED!

Meaning, the bad flash bios file has some other kind of error that i am unable to identify (would appreciate help on analysis). As it currently stands i lost the serial info but i’m going to import it with FD44Editor shortly.

@lfb6 , Thank you.

I read that FD44Editor doesn’t import the info to all relevant places. @Lost_N_BIOS . If that is true / still relevant today, I would appreciate help in repairing my own original bios, attached as the bad flash. Also as a learning experience to better understand the BIOS file format.

In the meanwhile, i would play with the current working bios. Could you please direct me for more instructions on how to downgrade the µcodes? If I understand correctly, @PhatAgent 's issue was caused by a bad update of the µcodes.

Many many many thanks.

@lfb6 , I was able to successfully change my microcode to the one i wanted through UBU. I made sure the update was made with mmtool_a4.exe.

I also verified the offsets were linear through UEFITool NE, to make sure, and wrote the image with the programmer and flashrom. Since my issue was caused by an update to just a few OROMs and not the microcode, it’s hard to know what caused the failure and whether it’s related to the one @PhatAgent was facing.

Thank you for all the help.


Any chance you can provide that BIOS we mentioned?
My post 15 bios has my serial and such; it just needs to be merged with the updated 9903 Bios.



Bump! :slight_smile: