Cannot Boot Lenovo M92p TINY after BIOS Update

yesterday I received from eBay a Lenovo M92p TINY model 3238 system with 4GB of RAM and a 500GB mechanical HDD.
I tested it and it worked fine, it booted to a fresh Win10 x64 French OS .
The plan was to replace the mechanical HDD with an SDD one and upgrade RAM to the max 16GB since I had 2x 8GB SODIMM modules.

I noticed that there was an update on the Lenovo support site so I thought I’d do that first and then proceed with the upgrades and installation of new OS.
The windows BIOS update completed successfully and the system booted to a bios-like screen and continued the update. On 100% the system tried to reboot but this was not successful, it just looked frozen. After 10mins I power-cycled the system. But I have lost the ability to boot any kind of media. I have done several CMOS resets, BIOS defaults, tried various combos of secure boot options but nothing helped.

With the previously working HDD the system freezes on the LENOVO boot screen.
With a UEFI bootable USB stick the system just black screens and I can see mouse pointer that I can move at 10fps or something.
With a MBR bootable USB or a win10 DVD install disk stick I get a blinking underscore without any media access.
Same blinking underscore with the Lenovo “Bootable CD for BIOS flashing” , the emergency recovery procedure explained in the hardware manual also does not work.

What I can do it enter BIOS, call up boot selection menu or even enter the Intel ME “bios” with CTRL+P. But other than that nothing can boot on the system be it windows or dos or even linux.
The system does not even try to access the drives to boot from.

I am all out of ideas so I just desoldered the 3 bios chips on the mobo in hopes some kind soul can provide me with fixed binaries or some solution… as-is the system is a paper weight :frowning:

thanks in advance for any help/tips!!!

Edit by Fernando: Thread title shortened (6.02 MB)

Please read again, try a different program, maybe, but that’s a rather large mess. Seems that the machine specific data is still there, but there are blocks of ME in bios region, in the DXE volume there’s a systematic read error, it’s not uderstandable, what happened here. Bios region might be taken from update, but one does need at least FD, GbE(?), ME…

Well I did removed the flashes from the board with hot air and used my programmer to make the dumps… I did it 3 times for each and CRC was always the same. I cannot use another program other than the TL866 one…
It is not surprising it’s a mess, something went wrong with the update… Is there something to be done? Something more I need to provide?

Never seen that after a bios update before, that’s not the way these programs do work. They erase a block, write it and so on to the next block. But here are parts of GbE and ME copied in bios region. And this Lenovo update is just an update for the bios region, it doesn’t have anything to do in the other firmware regions. Same time there are a lot of moves, 4 dwords inserted or left out, that’s not a thing a bios update could create. I’d prefer to have the chips read out with a CH341 and ASprogrammer or Neoprogrammer

Anyway- if you don’t have the possibility:
1.) Find a known good dump from another M92p
2.) Clean the ME according to [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
3.) Find your MAC address, write it in GbE (machine specific data)
4.) Replace the bios region with the bios region from the Lenovo update file
4.) Replace the second last volume in bios region with the one of your bricked bios (machine specific data)

hey lfb6 thanks for the help!
I do not have these programmers - I’ve been using the TL866 for many years now it’s been nothing but solid. I have no idea why the update failed in such a way, all I did was get the “windows update” , run the flash.cmd as specified in the instructions, did not update s/n or model and it did it’s own thing automatically. When the windows portion finished the flasher asked for a reboot, I rebooted and the process continued automatically to some text/bios looking screen. When the bar reached 100% the screen went black and what was it.

Do you think the dump posted here can be used? (had to attach a txt with the link)

“lenovo thinkcentre m92p” and “motherboard : IQ77T ver 1.0” matches mine and my “mfg date” is 1210
that bios dump is for machine type 3237 , mine is 3238
the MAC address is luckily on a sticker on the ethernet port: 00:23:24:3D:75:F9

I have no knowledge for these operations, I can follow the cleaning guide but the rest I have no idea how to do…

dump link.txt (64 Bytes)

Well, same thread, used the file with cleaned ME from #6, replaced MAC address in GbE, and replaced first parts of bios region with empty NVRAM and first corresponding part of stock bios region to get the 8MB chip content, see attachement.

Your 2MB chip is perfectly fine, it contains the machine specific data and the last part of the updated bios region without any errors, so just leave it as it is! But I’d recommend to replace the 8MB chip with a known good one, otherwise you should be very careful when rewriting it. Read it back at least twice in a separate read process, compare the results.

Should work (clear CMOS, should need som reboots, maybe, load std. defaults)

I’s recommend to update ME, too, when everything is working again (First item on this Lenovo page). (4.68 MB)

oh wow lfb6 , AWESOME
thanks for that
I will try in a while and report back! mega thanks!!!

first of all MEGA THANKS lfb6 !!! the bios fix was a success! system came back to life!

I tried the ME FW update you linked and I get the error message you see on the screen. This is an administrator command prompt.
I will actually wait for your recommendation before I try another version of it
thanks again!

You’re welcome. Please check for S/N, MAC, service tag and so on.

ME update: There’s possibly no driver installed, you can either install a driver from the second post of Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (or Lenovo):

OR (and I’d prefer this solution)

Try the DOS or UEFI version of the updater taken from ME tools found in the first post of Intel (Converged Security) Management Engine: Drivers, Firmware and Tools
(command syntax would be the same despite name of the program itself):

thanks again lfb6 , ME updated successfully!
I will now proceed to install my OS
thanks to you this machine turned from brick to a usable system again! :slight_smile:

Thanks for the feedback

Hello! help me with a similar problem on my ideapad gaming 3 i5. I wanted to return the factory bios after unlocked, but after reboot, just a black screen, no backlight.
I tried to flash a dump that was posted by other people on the forum for repair specialists, but it even turned out byte to byte the same as my dump from an already broken laptop.
sorry for using the translator.

That’s a completely different machine and cause. Open your own thread or maybe you might continue where you wrote already about your machine: [Request] Unlocked Lenovo Ideapad Gaming 3 15IMH05