Clevo laptop: ME FW

Hello all!

I am not sure if anyone can help me, but I’ve seen some other similar threads here so I’ll take a shot. I have a laptop, it’s a Clevo PB71EF-G that is currently showing ME FW in the BIOS. I haven’t experienced anything too strange with the laptop, everything seems correct in the Device Manager, but I am sort of eager to fix this, if possible.

I’ve tried installing the MEI drivers from the manufacturer for my specific model but they only result in error message ‘platform not supported’, no matter which drivers I try to use.

I’m sorry I can’t give anymore information on this, but I simply have a very small amount of experience with this type of issue in particular. Does anyone have any suggestions on what I could try and do to fix this? :slight_smile:

Any help at all is appreciated!

Follow the guide, this is a user task from his side: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Alright! I’ll start reading, thank you so much for the direction!

OK, so, this has been quite a bit of hefty reading. I’ve come a fair bit on the way, but I’ve hit my first roadblock.

So let’s see if I can remember all of this. I started here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools, and used Intel Flash Programming Tool to dump the SPI, which was successful without any errors, in which case I assume that the FD is unlocked. I checked the dumped .bin with ME Analyzer and noted down the Chipset Platform, Chipset Type, Chipset Stepping.

I proceeded with downloading the CSME v12 firmware and it’s corresponding IUP firmware. I used FIT to combine them. At this point I strayed a bit from the guides, because I was feeling brave, and I followed the section labelled ‘How to use FWUpdate Tool at CSME v12’, but ran into my first error as seen below:

So I reverted back to this guide here: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization, to proceed with the cleaning of the DATA section of the dumped .bin. Mind you, I have no idea what I am doing at this point.

And this is where I am right now, at the section labelled ‘D4. CSME 11 - 15 & CSTXE 3 - 4’. I’ve checked the dumped .bin and verified that File System State is reported as Initialized. I’ve extracted the same version CSME firmware from the repository pack and renamed it accordingly (ME Sub Partition.bin). I’ve loaded the dumped .bin into FIT, and… not quite sure where to move on from here. Step 7, under section D4 seems a bit confusing and contradictory.

Could you/someone else please be a guiding light again on how to proceed from here? :slight_smile:

[Edit] False alarm. I found how I should proceed like a couple of seconds after I wrote this out. Stay tuned for more of my monologues :rofl:

[Edit #2] OK, so I’ve got the cleaned and configured outimage.bin, and now I’m stuck for real this time. Not sure where to proceed from here.

The monologue continues.

I was scouring the contents of a BIOS package for my specific laptop, and I saw that in one of the files they used the following to flash the ME.

FPTW64 -f %BIOSROM% -a 0 -l 0x600000 -y

I tried running that and it clearly gave me an error message saying that host system did not have access to the FD, which was kind of demoralizing since the full dump worked earlier. So, I was assuming that my FD indeed is locked, or something was seriously broken.

I then remembered a tool I used a long time ago to open the hidden options of the BIOS so I could search for a way to unlock it, and I did actually find it the option, however I didn’t quite understand the order to do this, since enabling it, and then choosing save and exit it would just reboot and the thing was disabled again. I played around a little bit with booting into EFI Shell and running some of the files from the same BIOS package, one of them just gave the same error message as above and then it continued with flashing the BIOS.

After rebooting I checked the FD and it was still unlocked so I rebooted into Windows and I was about to ask for help again but decided to run the above command once more, and lo and behold, it actually flashed. I have no idea whatsoever how I managed this but this is a beautiful sight to behold:


So, I hereby solemnly swear to never touch any of these things again…
…until the next time I tinker with things and break something else :slight_smile:

Thank you so much for the incredibly well-written guides on here. I can’t imagine the amount of time, energy and hardwork that has gone into creating them.