Dell 7810 BIOS Problems

so my file for flashing checked the vcc volage im getting 3.1v but my chip can go 2.7v to 3.6


C:\Intel ME System Tools v9.1 r7\me_cleaner>me_cleaner 7810.bin
Full image detected
Found FPT header at 0x15010
Found 1 partition(s)
Found FTPR header: FTPR partition spans from 0x160000 to 0x210000
ME/TXE firmware version 9.1.45.3000 (generation 2)
Public key match: Intel ME, firmware versions 9.0.x.x, 9.1.x.x
The AltMeDisable bit is SET
Reading partitions list…
FTPR (0x00160000 - 0x000210000, 0x000b0000 total bytes): NOT removed
Removing partition entries in FPT…
Removing EFFS presence flag…
Correcting checksum (0xf9)…
Reading FTPR modules list…
UPDATE (LZMA , 0x1c6487 - 0x1c66b1 ): removed
ROMP (Huffman, fragmented data, ~1 KiB ): NOT removed, essential
BUP (Huffman, fragmented data, ~70 KiB ): NOT removed, essential
KERNEL (Huffman, fragmented data, ~226 KiB ): removed
POLICY (Huffman, fragmented data, ~99 KiB ): removed
ClsPriv (LZMA , 0x1c66b1 - 0x1c6a8a ): removed
SESSMGR (LZMA , 0x1c6a8a - 0x1d2413 ): removed
SESSMGR_PRIV (LZMA , 0x1d2413 - 0x1d7d03 ): removed
HOSTCOMM (LZMA , 0x1d7d03 - 0x1e0035 ): removed
TDT (LZMA , 0x1e0035 - 0x1e53fa ): removed
FPF (LZMA , 0x1e53fa - 0x1e6ef9 ): removed
The ME minimum size should be 1560576 bytes (0x17d000 bytes)
The ME region can be reduced up to:
00015000:00191fff me
Checking the FTPR RSA signature… VALID
Done! Good luck!

7810.rar (3.7 MB)
nope still didnt work with verifed flash im out of ideas bios part flashed

ME cleaner removes afaik as much as possible of the ME, that’s completely different to what is described here:
https://winraid.level1techs.com/t/guide-clean-dumped-intel-engine-cs-me-cs-txe-regions-with-data-initialization/

Dude as soon as I read that I knew I messed up but just home now and I’ll try again.
That will teach me to try bios modding while smoking blame Canada haha

this was the back up of my bios from the pi after verification it doesnt look right to me
pc booted back up but no change

Fixed: Yes

Base: 0h

Address: FF000000h

Offset: 0h

ReservedVector:

FF FF FF FF FF FF FF FF

FF FF FF FF FF FF FF FF

Full size: 1000h (4096)

PDR region offset: 1000h

GbE region offset: 11000h

ME region offset: 15000h

BIOS region offset: 800000h

Region access settings:

BIOS: FFh FFh ME: FFh FFh

GbE: FFh FFh

BIOS access table:

Read Write

Desc Yes Yes

BIOS Yes Yes

ME Yes Yes

GbE Yes Yes

PDR Yes Yes

Flash chips in VSCC table:

1F4700 (Atmel AT25DF321)

1F4701 (Atmel AT25DF321A)

1C3016 (EON EN25Q32)

1C7016 (EON EN25QH32)

207116 (Micron M25PX32)

C22016 (Macronix MX25U16)

C25E16 (Macronix MX25L32)

20BA16 (Micron N25Q032)

BF254A (Microchip SST25VF032B)

EF4016 (Winbond W25Q32)

EF6016 (Winbond W25Q32)

EF3016 (Winbond W25X32)

C84016 (GigaDevice GD25x32)

1F4800 (Atmel AT25DF641)

1C3017 (EON EN25Q64)

1C7017 (EON EN25QH64)

207117 (Micron M25PX64)

C22017 (Macronix MX25L64)

20BA17 (Micron N25Q064)

EF4017 (Winbond W25Q64)

EF6017 (Winbond W25Q64)

EF3017 (Winbond W25X64)

C84017 (GigaDevice GD25x64)

C22018 (Macronix MX25L128)

EF4018 (Winbond W25Q128)

EF6018 (Winbond W25Q128)

C84018 (GigaDevice GD25x128)

It’s not meaningful to write in two parallel threads and to post dumps in both threads, that does make it impossible to follow what you did and what the original state was.

see:

https://winraid.level1techs.com/t/dell-bios-modding/91130

Seems in addition that you have changed ME configuration several times. It’s not possible to follow what you did and what the original state was.

In case of problems with ME: Use your first ever dump, follow that guide to the letter:
https://winraid.level1techs.com/t/guide-clean-dumped-intel-engine-cs-me-cs-txe-regions-with-data-initialization/

So went back to the first ever dump and got the me onto new bios and it worked me info was showing and meb showed up in boot select.
Turned it on today and it’s back to locked.


Yer my bad I tried to close it but not sure how.

thanks for the help man im not at the stage where i get past post and into boot select then dell loading screen crashes, automatic fix doesnt work either

so load the efi shell
run me info the as above i did see the gbr config lock is enabled still would that stop a complete write and stop boot
also oem id and system id are different would that matter


with alot of trial and error and reading this HMRFPO_ENABLE mesage is what i need to enable service mode i tested it on my pc (posting old config) service mode jumper on me disable and full read write permissions one issues im getting is error 7 hardware missmatch but i can flash same image back and all regions i think one of my other setting may be incompatable.
1205.rar (3.7 MB)
at the moment i flashed the original dell a34 bios back and im going to get a full spi dump from the pi and keep on usb incase!

for anyone intrested the service mode setting works now jumper on

hi after a bit of help so im goin throw my UEFI and came across this
PchBiosWriteProtect_PchBiosWriteProtect
Section_PE32_image_PchBiosWriteProtect_PchBiosWriteProtect.rar (1.5 KB)

i cant seam to extract it anyone give me a hand thanks

I should be able to see it in the ifr extracted platform but all i get is Intel Ref.code setup hide

edit
this is for the AMI AptioV UEFI EDITOR i get my bios lock sorted but trying to see if it possible to remove the FPRR from my bios

i have 5 7810 all with dual xeons and 2 5810. 3 of them i salved from going to a skip and the others i have aquired when my client upgrade there workstations

@Windius
Please stop starting several threads about the same topic. This is absolutely confusing for the Forum Staff and the Forum members, who are trying to help.
Today I have tried to find and merge all threads you had started since October 2022 regarding your Dell 7810 BIOS and Management Engine problems. If I missed any thread, please let me know it.

@MeatWar @lfb6

1 Like

Thanks I will keep all my questions and post related to dell 7810 in this thread sorry for extra work

So what I did and have tried
I updated bios to one with the correct version I have installed latest dell A34 that didn’t clear the ME FW version error either
In windows fptw all regions unlocked so did full spi backup followed the clean me guide.
Flashed from pi did full erase all passed
Pc turns on error is gone but windows won’t load it crashes on dell logo but I can get into safe mode windows but crashes trying to load normal windows or dell automatic recovery
So getting backup redoing me and going to try flash again
I was hoping that getting in safe mode I could see what’s wrong but that didn’t happen

Any other suggestions or tips to try
Thanks

Edit:
So the worst think happened halfway through flashing and my upstairs neighbour drops something and I here the clip ping off at 38% fudge
Now as it flew off it bent the plastic that holds it on so it won’t stay connected
Went to the local electronics shop they have no more soic clips till after the new year but he gave me these to try tiny little clips that’s all he had till new year.
Got a Paloma clip on order with Amazon but not here for another week

Edit:
Somehow those clips worked and it managed to get the computer to boot got dell flash update and went to stock bios for now

so in windows on stock dell bios i checked fptw -i all regions were unlocked so did full Spi backup
A34spi.rar (7.0 MB)
i think its good but im scared to restart haha

No time to dig into it, but with a quick lock you messed with FIT and the bios isn’t a stock A34!

H thanks for looking you were right i had ran that through ubu.
so to start from fresh i installed T7810A34 dell official update loaded up windows and all regions are unlocked just not able to flash back.
i looked in HWINFO and found im in manufacturing mode and
Host ME Region Flash Protection Override (HMRFPO) Status: Disabled


im gonna wait till my soic clip turns up before i try a flash again or if i figure out the spi pin header

this is just bios dump untouched from stock A34
jan02bios.rar (3.7 MB)

For anyone with x99 chipset after a lot of trial and error I have done it


Now for the fun part

I did get the multiplier to x35 on the locked Xeon
image

1 Like


Picked up an arc she looks good

So got the arc working with rebar above 4g and csm disabled in bios
Added the rebar dxe into bios and bingo

She is a bit slow to boot

So oc locked 2x Xeon 2630 v3 x35 multiplier and core full turbo more powers setting a to play with yet

Rebar and v3x4 dxe inserted into bios

Now I think I need the 1350 psu and some water coolers

But shout out to the greenpcgamers who together we opened the back doors of the dell and slid in.

frankr2994

Thanks all