Dell Optiplex 7010 Micro 13Th Gen (2024) Intel AMT enable


I purchased two machines which has the Intel AMT disabled (3 - disabled sticker on the chasis)

After reading a few posts, its clear that I need to re-flash the bios. However since this system doesn’t have the service jumper, I will need to do it the hard way.

I am new to all this and so any help would be appreciated.

I have included images of the motherboard, to help identify which chip(s) are the bios ones.

Then I need to know what programmer to purchase and go from there.

If any more pictures are needed please let me know.

Sorry since I am new, I have to upload one pic at a time.

This is the last picture.

I am hoping one of the above are the bios chip otherwise, I would need to take the fan and heatsink off maybe.

2nd image, both Gigadevice IC’s (WSON and SOIC)read both before any attempts of flashing, re-read them and compare.

The WSON package IC is not clear on the model by foto, too much light on it.

The 2nd (Bottom one) GD25B128E SOP)

Correctly identify the ICS and look for PDF’s specs.

EDIT: And read the guides…
[Guide] Using CH341A-based programmer to flash SPI EEPROM - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

[GUIDE] Flash BIOS with CH341A programmer - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

[Guide] How to Use a CH341A SPI Programmer/Flasher (with Pictures!) - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (


Make dumps for safe keep, using the programmer and also with Intel FPT tool
DO NOT RUSH these operations or you’ll get a death system.
Read guides and CSME tools guidance

Here is another pic of the chip

How do I go about reading the chips?

Should I boot off a USB with FreeDOS and download the CSME System Tools?

I have created the FreeDos USB using Rufus USB imager. Downloaded the CSME tools and extracted them to the USB.

Is there a link/doc I can read to understand what I need to do etc…

Ok, so my bios doesnt allow legacy boot mode, so I need to figure out how to boot from USB in UEFI mode and allow Freedos to work

So I found an old version of Intel CSME which has linux commands

I ran the command

./FTP -d spi.bin

Got the following output.

033]0[root@p02 LINUX64]# ./FPT -d spi.bin
Intel (R) Flash Programming Tool Version:
Copyright (C) 2005 - 2020, Intel Corporation. All rights reserved.

Error 621: Unsupported hardware platform. HW: Alder Lake Platform. Supported HW: Intel(R) CometLake V Series Chipset.

So I am guessing I needed a new version of the tool.

Thats correct…you used v14 and your platform is Alder Lake v16

What you need is to know, is your own hardware… and not engage wrong tools/actions.
Tools like HWinfo and Aida64 can be used, providing almost every information of the platform.

So, I gave up on trying to get the tools to work on Linux - You can create a Windows Live boot USB using WinToUSB ([Official] Best Free Windows To Go Creator Wizard Helps Create Portable Windows 11/10/8/7!)

Then I just used the windows version of the tools.


I managed to get HWInfo output see screenshot below:

I also created a report which provides all the details (see HTML/PDF (zip file) ) - Link provided as I am a new user I cannot upload a zip file :frowning_face:

Lastly, I ran the FPT command again, the output this time was:

Its not surprise at all… this is a branded OEM system and a lot of them have SPI access locked for preventing firmware modifications/security.

So this forces lot of users to try the CH341A programmer or similar.
Some ICs, even have to be de-soldered for reading/programming.
Your not the first with this situation and definitely not the last one…

Here’s an identical situation like yours on a Dell 7080

EDIT: I don’t need any dumps as i do not intend to lose my time with these or any other similar issue. I helped you and pointed you the way/tools, that’s it.
I did not offer myself to solve your issue.

Just came across that link - as I was searching the forums.

So I ran the commands described in that link:

Here are the screenshot outputs

fptw64.exe -i

and then I ran the command

fptw64.exe -DESC -d FD.bin

That gave me the following output

The bin file is located: FD.bin - Google Drive

I should also ask, would this kit be the correct one to purchase?

along with this:

Just out of curiousity- which chip would you want to read with the 16 pin SOIC clip?

I read on a different post that the system bios was a 16pin.

However based on the images above, that doesn’t seem the case.

So could I get away with the 8pin only?

Which chips do you want to dump?

I was told these two are the bios

Have a look into this other thread:

ok, so it seems I need to get teh programmer (cheapest one being the CH341A) and use that to dump the bios. Then work from there.

My Programmer arrived today.

I have found the chips data online:


This second one I am not sure about, the actual chip has the numbe 25B128ESIG (No R at the end). I have included a picture of both chips.

Need to figure what software to use to get a dump.

You need to read all the links i posted in order to LEARN FORM IT, then you wont need to repeat yourself and posting the same info you already did.

The CH341A device works with many available apps out there. Some do have the ICs on their database, some don’t, some likes to work with some boards/ics, others don’t.

I posted the guides links, the original IC manufacturer links and what kind of ICS you have in order to purchase the correct interface clips for each IC, WSON8 and SOP8.

Had to install drivers for CH341A programmer:

Download the latest version of ASProgrammer here:

I have taken two extrackts from ONE chip: 25B128ESIG

I can’t seem to extract from the top CHIP: GD25B256EYIGR