Dell Precision Tower 7810 BIOS Problems

Like I said I have got to the point of repacking back into the exe file with the modified bios with the microcodes removed just can’t replace it

I’m not sure what you mean about all the different versions I went from 01-30 ran rough downgraded back to 01 using 12 then 11 and finally 01

hi all i have got a dump from my dell 7810 from a spi flasher im trying to work out what is best to do with the bios can i remove region setting and is there any extra menus i can enable im going to be removing the microcode 06F2 for my xeons turbo
i cant share the file but if someone wants to have a look i will put on dropbox

thanks (7.3 MB)

just realised all my bios mod tools are on the 7810 and i have none on my laptop lol

So to update I managed to remove the microcode 062f and reflagged the bios chip no issues computer boots up I see v3 turbo all cores pop up.
Now can’t boot into windows can select boot options and now trying the win 10 cd to recover

If anyone wants how I did it I’ll take pictures
But in essence
Bought a 8 pin ic clip and jumper leads
Used raspberry pi spi gpio pins
And a lot of praying to the silicon gods

So now I can’t get past bios says invalid config time date wrong
So I enter setup change time and date then reboot and black screen
Clear cmos using rtsjumper and I get video back and setup screen

Going to try and flash original bios back and see if that fixes it

Any advice seam to be going round in circles here

After restored bios, look for ME service jumper, put in service mode and use the Intel FPT tool from the correct ME package tools and make a full spi dump and a bios region, restore the ME jumper, work the mods on the bios region, flash again with FPT tool the mod, if it fails you need to set the jumper back to service mode, this jumper must be set to default setting for a normal working state of the system after flashing ONLY the mod bios region.

EDIT: The steps i provide still can be done when you have the machine back as original function.
No ME jumper but still can work, all depends if the tool can read/write the spi regions.

Dell system/and or specific Dell motherboards has it own way of recover the system bios, its your task to search for it on Dell documentation, the SPI programmer is the last resource when everything else fails or to froce a mod flash.

hi thanks for your reply
unfortunately i don’t have service mode jumpers on the motherboard its a dell 7810
do i still need to do the ME if im flashing the chip?

im now stuck in the dell automatic repair tried win 10 usb but it crashed before it loaded.

thanks for the help bud.

hey so i couldn’t get past dell loading screen on custom bios so flashed to original dell a34 its boots into windows and then i just found this im assuming thats what you meant

Yes, thats the FPT tool operation, reading ONLY… a simple write method to test:

Dumping: ftp -bios -d biosreg.bin then testing the write access: fpt -bios -f biosreg.bin

If successful, you know that you can write the in the spi.
Carefull, this tool doesnt care what we told it to flash…it doesnt care if its a correct/mod/corrupted image.
Learn the tool cmds/options.
Note that this tool is not the proper tool to update ME FWs, just to clarify that all i referred was due to a mod request and flash, not ME related.

EDIT: What i verified is an updated mcode and you had removed an old mcode revison 38 and also removed the 06F2…now my friend, from this on, im not here to assure you nothing more concerning the success or failure of the system, these are user choice only and their own risks… after all, this mod world.
Good luck.

Error 280: Failed to disable write protection for the BIOS space! damm

can you check this file to make sure i have done it right please
dellmod.rar (3.8 MB)

thanks im gonna try it again

So I flashed the bios chip via my raspberry pi all went ok.
It took a few attempts to boot but made into windows did a dump via ftpw in windows checked with mmtools micro code 06f2 has been removed.
Patched the efi with the turbo unlocked mod
Booted into windows all 32 cores turbo.

Thanks for your help

Glad you made it, cheers.

Only managed it on one processor now to figure the second one out

hi so i did something on my first flash with the intel me and now i cant get it to work tried flashing back to oem bios and reflashing but i must be doing something wrong

Fixed: Yes

Base: 0h

Address: FF000000h

Offset: 0h




Full size: 1000h (4096)

PDR region offset: 1000h

GbE region offset: 11000h

ME region offset: 15000h

BIOS region offset: 800000h

Region access settings:

BIOS: 1Bh 1Ah ME: 0Dh 0Ch

GbE: 08h 08h

BIOS access table:

Read Write

Desc Yes No

BIOS Yes Yes

ME No No

GbE Yes Yes

PDR Yes Yes

Flash chips in VSCC table:

1F4700 (Atmel AT25DF321)

1F4701 (Atmel AT25DF321A)

1C3016 (EON EN25Q32)

1C7016 (EON EN25QH32)

207116 (Micron M25PX32)

C22016 (Macronix MX25U16)

C25E16 (Macronix MX25L32)

20BA16 (Micron N25Q032)

BF254A (Microchip SST25VF032B)

EF4016 (Winbond W25Q32)

EF6016 (Winbond W25Q32)

EF3016 (Winbond W25X32)

C84016 (GigaDevice GD25x32)

1F4800 (Atmel AT25DF641)

1C3017 (EON EN25Q64)

1C7017 (EON EN25QH64)

207117 (Micron M25PX64)

C22017 (Macronix MX25L64)

20BA17 (Micron N25Q064)

EF4017 (Winbond W25Q64)

EF6017 (Winbond W25Q64)

EF3017 (Winbond W25X64)

C84017 (GigaDevice GD25x64)

C22018 (Macronix MX25L128)

EF4018 (Winbond W25Q128)

EF6018 (Winbond W25Q128)

C84018 (GigaDevice GD25x128)

im tring to unlock the bios lock with local FW and a few other offsets i have found but in order to do that i have to have Manageability Application Configuration enabled but with me disabled i cant do anything
been reading [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
but im getting lost and my file size is messed up now can anyone help
i have pi spi flasher

backup1.rar (3.7 MB)

now i cant get the soic clip to stay in place i think this is ready to be flashed if someone wants to have a look
7810.rar (6.5 MB)

hi all after lots of reading and help from people on here i managed to dump bios with pi and soci clip i have no problem getting my fd unlocked or any other locks off now i have modded the mb to make the service pins usable.

my issue is every time i flash bios back even with minimal changes - remove microcode for the Haswell, enable overclocking feature/overclock lock, i tried to enable a few bios features but that never works even after changing to user,
i cant get past dell recovery logo just hanges and crashes but i can get into bios and f12 boot menu

the procedure i use is

  1. power off pc
    2.unplug pc attach soci clip
    3.conect soci to pi
    4.power pi up
    5.flash chip now errors
    6.turn pi off before removing soci clip
    7.clear cmos
    8.plug pc back in

am i missing something in my procedures.

i reverted to the latest dell bios A34 and want to try again.
i few places i have read the smbios version 2.8 has been leaving user with the same boot loop problem can anyone shed some light on this if possible.

thanks for help

How are you “touching” those features? AMIBCP tool?
Are you modding an original dell bios update file, a full spi backup or a bios region?

AMIBCP wont work on all modern Aptio V bioses as it was in Aptio IV, thats why you can see a lot of users that must use RU/IFR extract tool and hex edit the variables/strings.
This is due NVRAM DEFAULTS and other modelas besides the SETUP, this must be done with RU/IFR extract tool and edited. The strange part is only modding the mcodes, your issue still persists…

Its better to work on a bios region and use the FPT tool to flash only the bios region, not touching other regions.

EDIT: I said Bios_region only, not the full spi dump. This dump has ACM/RSA…this is not welcome in modding.
Try just the mcodes with AMI MMtool or UEFItool besides UBU, on the region.

According to the ME of your system:
Dumping: FPT -bios -d biosreg.bin
Flashing: FPT -bios -f biosreg_mod.bin

This is not an easy bios to mod…too much Dell in it, in structure/modules/NVRams…

EDIT: Ok then you understood it… but here it gives 8 388 kb not 8 192…
HEX edit was not ment to mcodes, that was used in older 1/2/4Mb bioses.
I opened the file with MMTool and UEFI…too much of Dell DXE/PEI in it, not a bios to touch myself, sry.

1 Like