Dell Wyse 5070 - BIOS update not working - need help!

Hi there! As stated in the title of the thread, one of our problematic Dell Wyse 5070 does not update its BIOS. It’s restarting (after preparing the BIOS update) and reboots straight into ThinOS, as if there was no BIOS update initiated.

Is anyone here able to help me by cleaning the BIOS regions and possibly updating the BIOS to ver. 1.20.0?

The service tag is FMWF5P2.

I got a dump of its original BIOS with version 1.1.3.

Thanks!! (6.3 MB)

Have you tried the incremental update to 1.16 then 1.18 and finally the 1.22?
Also did you tried the F12 method by file on USB drive, described by Dell installation description?
Independent OS updates is always the best choice… not OS environment.

EDIT: F12 with the 1.3.1 also fails?

Im not pointing an ME FW image corruption at this point, from your dump.
Clear/take out the CMOS battery, leave it without power 15m, boot to a USB with Intel CSTXE from package tools v4r6, EFI boot version tool of the FPT and run fpt -greset, this will re-initiailize the CSTXE engine FW, then try again the flash.

1 Like

Hi there, thanks for the reply!

I did try that all but unfortunately, it does not work :frowning:

I usually update the machines through the F12 method, but this one sadly does not wanna update.

Failed again :frowning:

Tried that but I can not boot FPT, it’s rebooting instantly after showing a long text…

Shows error 365 and then reboots.

Thats not a great info for debug… “long text…”
Disable all bios security, tpm, secure boot, clr keys etc…

EDIT: Try this bootx64.efi
Or try a bootable USB and the non-EFI version of the tool.

1 Like

I’ve managed to get some information about it.

Error 365: Invalid parameter value specified by user. Use -? to see help

This is the error code. I put the efi file into “/efi/boot/bootx64.efi” (on a USB drive)

It is booting GRUB for some reason. xD

I assume it’ll be

Unfortunately, I can’t handle at this point as it tells me that the SKU is not found.

Well, that was hard… :roll_eyes:

Have a look at this now please
Dell Wyse 5070 Thin Client (V_1.22.0).rar (8.0 MB)
. I tried it and this is the result.

Different bios region (NVRAM), newer bios region and txe version, doesn’t look like you followed the mentioned guide.

1 Like

Well, tbh I am pretty new to this BIOS related stuff and sadly, I can’t do that precisely. Simply lack of experience. :frowning:

PC is actually not booting with that BIOS… xD

Those guides are ‘follow to the letter’, especially if it’s TXE 3 or TXE4 and “even more” if the “OEM Public Key Hash” is popupated.

1 Like

I guess that I have no luck in this case, I’m simply not able to understand it. Sorry for taking your time.

Well, I managed to do it after all. It’s now updating the BIOS without any issues.

EDIT: Worked perfectly fine. Thanks to everyone who helped and big thanks for the guide!

1 Like

Yeah… we know that a user has to loose his time with this…its a lot faster when some one do task for us, but that’s why the author of the guides lost his time to make it as much as possible “Lazy/Unexperienced” proof.

Glad you made it, spared a couple of $ and not having throw away a system…
We have all kind of “costumers”… noob IT Admins, noob TI workshops, the ones “appearing to be” etc etc, anyway congrats all the best.

Yup, you’re absolutely right. I was actually having no time in the first place but I told myself that I’m gonna try till it’s fixed. Didn’t give up and solved the issue on a lot of Wyse 5070 ThinClients from the company I work for. They had all the same issue, where users did interrupt the update process while it was updating BIOS. Saved 28 ThinClients, worth around 16500€. But ofc for free, no one’s gonna pay for that extra.