[Discussion] UBU Tool related Questions, Reports and Suggestions

Tried to use this thingy on an Aptio 5 (AM5 B650-E Gigabyte Aorus Master f22b bios).
mcodes seem all to up to date with f22b.
i225 (3) does not seem to get recognized correctly.
so far, so well :+1:

Poor respect for such a useful tool… :frowning_face:
i225 must be updated/replaced in UEFItool

I’m sorry. I didn’t want to be disrespectful. Happy about it

@/Maghook sorry my be my mistake?

@plutomaniac you rights We knows with @Fernando many-many times. And with You. low bow for You.

@Fernando @MeatWar @Michael_Code A new meme will undoubtedly start “Learn to _Code” :wink: :joy: :rofl:
Cheers :beers:

Tried it out on my modded Asus Zenith Extreme BIOS/UEFI.
Seemed to work without hiccup. Will flash later this evening.
Used it with Python version 3.11.8

Updated UBU worked fine, I just updated the OROM for network, otherwise very straightforward update. :partying_face: :fireworks: :sparkler:

Used the Annex method to flash & it went very smoothly.

Cheers :beers: :innocent:

1 Like


Any particular issue with the EFI Intel PRO1000 UNDI - 9.8.40 (E9840X3.EFI)?

EDIT: Noticed also the use the Realtek EFI x64 2.060 corrected, here
RtkUndiDxe.2.062_corr.rar (60.2 KB) and RtkUndiDxe.2.063_corr.rar (57.7 KB)
corrected, please verify and confirm for your UBU package.

Got a little experience working with ubu, uefipatch, uefitool, flashrom by almost bricking my board while attempting to mod the bios to support resizable bar on RTX 2000 series cards.
I have an ASRock x470 Taichi.
I noticed that the drivers for the integrated nic can be updated via ubu. This asrock board comes with an intel I211AT wich crashes badly any windows host os when disabling/enabling the adapter. (freeze, sometimes for minutes, then adapter shows as “Device cannot start. Device does not exist” in device manager. )

I tried to let ubu do it’s magic with the network driver but it can’t do it :

        [Current version]
     EFI Intel Gigabit UNDI      - 0.1.02
     OROM Intel Boot Agent GE    - 1.5.50
     EFI Broadcom UNDI Driver    - 20.8.4
     OROM Broadcom Boot Agent    - 17.2.0

        [Available version]
 -\ for i82579/i217/i218/i219 chips
     EFI Intel Gigabit UNDI      - 0.1.02
     OROM Intel Boot Agent CL    - 0.1.16
 -\ for i210/i211/i350 chips
     EFI Intel PRO1000 UNDI      - 9.8.24
     OROM Intel Boot Agent GE    - 0.4.09

     EFI Broadcom UNDI Driver    - 20.14.24
     OROM Broadcom Boot Agent    - 20.14.2

1 - Replace Intel
4 - Replace Broadcom
S - Share files
0 - Exit to Main Menu

then I select 1 :


For compatibility of the DevID,
it is possible to install up to versions 6.6.04 and/or 1.5.62

EFI Intel Gigabit GUID 9006872D-3A86-4BAE-A2F0-E527B9D7119E
 parseSection: GUID defined section with unknown processing method
parseSection: GUID defined section can not be processed
No replacements can be applied to input file
The system cannot find the file Files\Intel\lan\orom\o1562GE.txt.

     EFI Intel Gigabit UNDI      - 0.1.02
     OROM Intel Boot Agent GE    - 1.5.50
Press any key to continue . . .

I’ve been though this thread EFI LAN BIOS + Intel GopDriver modules - #189 by clackersx and got what seems to be the right efi files for my I211-AT card copied to UBU_1_79_17\Files\intel\LAN\EFI but still it does not work.
It should install 9.8.24 since this nic is i211
Am i missing something ?

Thanks for your great work!

@superpower, I think, you need version PRO1000_6.6.04.efi and insert it manualy with UEFItool.

The modules that can be exchanged by UBU are relevant for the pre-boot network environment and aren’t a device firmware. Those modules aren’t any longer relevant when the os driver is loaded. So I doubt that updating these modules will help you with your I211 crashing…


searched this forum for it, where is it ?

I understand. So this is a board problem then, nothing to do with drivers ? the most stable seem to be those that come with the OS. if i try to install intel network drivers from intel, they crash even worse.
I think disabling onboard lan then installing a pcie dedicated nic is a better solution

thx guys

@superpower, in new UBU. It only for network boot.
I’m aware of hardware problems with the 1218 chip, I haven’t heard of the 1211.

Well, drivers and drivers- the modules in a firmware are EFI drivers but are part of pretty much hardware related firmware.
For Intel NIC there’s some ‘settings / registers’ in GbE (for Intel firmware) and the NIC itself does have a non volatile memory which can be updated (if you find the correct package/ tools!). I really don’t know too much about this!

For example (nothing there for your I211 though)

(Those firmware packages might again contain the UNDI/ PXE modules both for EFI/ legacy since they are might be meant a standalone- NIC)

allright, thank you guys

Hi there! I really love this project and I’m finding it incredibly useful and fun to play around with. But I’ve found a slight issue involving 2.5Gib network cards. The PRO2500.efi files go completely ignored by UBU and are not, in any way, referenced in the UBU.bat file. This means that attempted updates and even checks on the EFI result in the EFI being removed from the UEFI completely. There exists checks for 1Gib and 10Gib at least.
I would add the code to the batch file myself, but the complexity of the code is a little beyond my expertise. With newer boards coming with 2.5G chips onboard, I think it would benefit the project to at least add in checks for the files.


The issue is not new and it’s not an issue, it’s the result of a project not fully developed anymore, the author is aging, doesn’t have time for it and has more respect for the time left of his life.
The DXE driver can be updated with the UEFI tool.

No need to be sorry about anything, i’m just exposing the facts and yes, an updated branch was picked up from the original but not new code developed, only small adjustments and updated modules. For example, the drvver.c needs a revision on its code, the new releases of the Realtek PXE EFI are not correctly identified… etc.

I’m sorry, I had been of the impression that the project was picked up by Michael_Code.
Is it not official?

@D337z, no, only minor adjustments and updates of drivers and microcodes.

Hi Michael Code…

Is there a reason why you removed the UBU update?