[Discussion] UBU Tool related Questions, Reports and Suggestions

Before you criticize something, you should inform yourself. Someone who doesn’t know much about the subject would be better off keeping quiet.
As MeatWar already has stated, the main reason for having replaced the MCE.exe by the slimmed MCE.py was the false malware detection of the *.exe by some antivirus tools.
For the UBU users it is much better to have the latest complete MCE.exe within the UBU package, because this way the Microcode update will be done without the need of any extra work.


I don’t know what problem you have now, I didn’t criticize, but rather suggested that it might be better to continue working with Python.

I’ve been using the UPU tool from the beginning, and I’ve known you for over 12 years now.
Back then on a German platform.
The UBU tool doesn’t have much to do with expertise, as it was written to make it easier to keep your motherboard BIOS up to date. But rest assured, I also know how to update a BIOS without UBU.


As I already wrote, I’m not criticizing, but rather making an observation!
But of course, I will comply with your request to end this discussion.


I think you’re the only one who understood me. :wink:

Thank you very much for the updated UBU tool.
I have tested it with the latest BIOS X570P45.61 for my ASRock X570 Pro4 mainboard and it worked flawlessly. You have done a very good job! :+1: :+1: :+1:
To avoid any misunderstandings regarding the UBU version it may be a good idea to start with a new numbering (e.g. UBU v1.80.01).

@Fernando, nothing new. But, I will think… :grinning: May be, you right.

It is great that work still continues! Has anyone actually been able to use UBU to update and flash UEFI on Z690/Z790 motherboards? Do companies like ASUS and MSI still function with modified UEFI via Flashback feature?

The UBU tool is able to update some modules of an UEFI BIOS, but not to flash any BIOS.

Questions regarding the flashing of a modded UEFI BIOS should better been asked within >this< thread.

I think the best thing to do is start a separate topic and keep a list of changes.

1 Like

To All
AMDGopDriver_2. (37.3 KB)


To ALL and @Fernando
I sent all data to @Sonix
Next time, ONLY Sonix accompanies UBU.
Thanks ALL.


Thanks for having offered the updated UBU v1.80.01.
It worked flawlessly with the latest BIOS v5.61for my ASRock X570 Pro4 mainboard, but I got a mysterious “User GOP Driver file” message while trying to update the “Video OnBoard” AMD modules.
Here is the screenshot:

Do you know the reason?
Note: I haven’t touched the UBU\Files folder of the UBU tool v1.80.01.

1 Like


  1. About “User GOP Driver file”
    We can place ANY GOP Driver file (include AMD) in path
    but with name IntelGopDriver.efi
    Read \Files\intel\GOP\Usr_GOP_Readme.txt by SoniX
    For example
  2. Unknow - Unknow
    First, code name CPU (now was AlderLake-P). UBU and drvver.exe dont know about newest CPU.
    Second, version number. After change method numeration, we heve problem with drvver.exe. Also with network UNDI.

Hello Michael,
thank you for your quick reply.

This is the content of SoniX’s _Readme.txt file:
“In this folder you can place the Intel GOP Driver you need.”
If you should be right regarding the location, where the desired AMD GOP Driver has to be inserted (as file named “IntelGopDriver.efi” into the sub-folder named “intel”), this would be absolutely irritating for the UBU users and should be corrected with the next UBU version.

By the way - why is the Intel GOP Driver v1.0.4.6 within the Files\intel\GOP\Usr_GOP sub-folder of the UBU tool v1.80.01 you have delivered? There should only be the _readme.txt file and no GOP Driver in it.
This is the picture I get after having deleted the file named IntelGopDriver.efi and redone the UBU work:

This means, that my reported tiny problem while using your offered UBU_1_80_01 can easily been solved by deleting the file named IntelGopDriver.efi, which is within the Files\intel\GOP\Usr_GOP sub-folder.
Now your updated UBU tool runs perfectly for me (without any issue).
Well done! :+1:

1 Like

@Fernando, my best friend. now I busy with business. Answer later Low bow. for You.

Thank you for your continued support of UBU. I wanted to ask you, maybe you know why UBU does not see Intel UEFI x64 PCI-E gigabit driver v9.8.40.efi in bios?

@Dagal, yes, we know about this problem. drvver.exe old version. I ask our friend SoniX , source last version 0.29.0
Waiting… I chang only with my hands, by UEFItool. Sorry for my pingving English, this my second language, after Russian. I princile dont use any translaters.

1 Like

That would be great Michael… the last i know that is public is 0.19.0 based.
Keep us updated on his good will (SoniX).


@MeatWar, You have mistake :smile:
drvver.zip (52.3 KB)

1 Like

No Michael, not the assembled exe 0.29.0… this one we know it, i mean the C code file “drvver.c” base file.

I tried to update microcode in HP Z620 Workstation BIOS, and it seems a lot of stuff gets shifted around if I diff the original/updated BIOS files in WinMerge.

Is there a way to minimize the changes to the absolute minimum - to make diff easy?

If the µcodes have the same size- just replace with a HexEditor?