[Discussion] UBU Tool related Questions, Reports and Suggestions

the problem is not a real problem but cannot update example rst-e because after put an option rom in the rst-e specific folder of UBU, the program don’t find that option rom.
what I wrong?

EDIT: Unneeded parts of the fully quoted post removed (to save space)

DrvVer v0.27.1 in Cloud


I do not know why it is so. They sent an archive of a folder with files that you can’t get. And BIOS file.

I PM’d kevindd992002 but got no response.
Since i saw our member honeybadger just replacing the microcode directly with his ASrock j4205 and a Hex editor i tried one myself.
I use UEFItool and extracted the padding area. Inside that at offset 7B040 starts the microcode. Its length is 1200h. The new microcode 32 for my CPU 706A1 has the exact same 1200h length.
I replaced this area inside the padding file and reinsered it into the original rom using UEFItool again.
Do i understand it right there are no checksums in the padding file to correct? I used the recent 1.40 version https://www.asrock.com/mb/Intel/J5005-ITX/index.asp#BIOS
Can anyone check what i did with that one here? https://www
Thanks in advance!

Edit: lol, the UEFItool out and in results in the same file as if i replace it directly with the editor. At least that way i double checked. Guess i will flash it later.
Edit 2: It worked (Link removed)


This link from the UBU main page is down -
Download the latest version of the 7z-archive named “Intel_RST (e)” from >here< (developer’s hoster) and unzip it somewhere outside the UBU tool folder.
Where can i download?

I’ve got my Video OnBoard, Network, Other Sata Controller & CPU Microcodes updated using the UBU Tool but i can’t figure out how to update the Disk Controller - EFI/OROM Intel RST for sata.
I’ve manually updated the EFI one using the mmtool with file satadriver90.ffs but then couldnt figure out how to manually update the Orom one. Just stuck at this point now.
p8z77-v premium.
bios 2104.



You do not have access to the page on this link?

@KiLLz420 :
Where did you try to download the latest UBUTool version?
>This< is the UBU Guide of our Forum and this is the text within the guide where to get the tool:

Both links work without any problem. I just have checked it.

I tried to create a Cloud on Google, but unfortunately I am offered to create a Storage as a Business.
Resuos Mega is not available for me.

I recognized Windows 18363.449 loaded µC 2C on bootup while the 1.40 BIOS only had µC 26. So MS meanwhile did some things to the OS that needs a newer µC. Most likely CVE mitigations.
I expect a motherboard manufacturer at least for products still on the shelves should regulary update their files and don’t only count the OS doing it for them.
Today i complained at ASRock about the very outdated TXE. There were serious updates and a motherboard still on sale should absolutely have it https://www.intel.com/content/www/us/en/…l-sa-00213.html
They recommend 4.0.15.xxxx while my newly bought J5005 is at
Unfortunately the TXE 4 update process is hard for me to understand even when it is well explained here with very detailed threads.

I used another Internet provider.
Created an account on Mega. That’s what happened


Folders are still confusing, but if users see the folders “Modding” -\ “Files” and “Tools”, then I will fill them out.

I can see them with a german IP.


@SoniX @Fernando

I have the newest UBU. Those links work fine. I should have been more specific. The link that’s dead is for the latest version of the 7z-archive named “Intel_RST (e)” I’m assuming this is an archive of all the RSTE Drivers & Orom bios files for UBU? The newest UBU doesnt have any drivers in the Files/Intel/RST. I’m not sure where to find or how to add them for my bios to update my OROM intel RST for sata. I added some pics to show what pops up in the beginning and then the original drivers and then after i updated everything. The only one i havent been able to update is OROM intel RST for sata. This is my first attempt at bios mod so im just trying to figure it all out

Another question that i had was… Before the update of my Network - I have 2x intel gigabit ports on my board - it shows OROM INTEL BOOT AGENT GE for both of them. Then after the update is shows GE on one and CL on the other. i dont use the network boot anyways just curious to why it changed like that

EDIT: I found the files! In the link that Sonix posted. DUH! i just didn’t dig deep enough! I thought FILES was part of the UBU

EDIT by Fernando: Fully quoted posts replaced by directly addressing (to save space)



After update.JPG

Ok so i think i have it finished!

I’ve uploaded the original bios and the updated as well as a pic of before and after. I updated everything plus the microcodes. Could anyone confirm this is good please? Also are these the newest/best updates available? I’m running raid on the Intel and Marvell controllers. I’ve got the RSTe DRIVERS v13.1.0.1058 and RSTe Software v13.1.0.1058 to go with the update. What is the recommended Drivers for the Marvell controller on windows 10?

All the guides are excellent! You guys are awesome! Without this i’d have never been able mod a bios! Thank you!


UPDATED Z77VPR.zip (4.69 MB)



Hallo guys!

Well, I am playing with an old intel DG31PR motherboard with sc775 and I use UBU_v1.76.0.1 with MMTool as mmtool_a4.exe to add/inject the microcode for old Xeon E5430 (https://ark.intel.com/content/www/us/en/…33-mhz-fsb.html) into the bios.

Now I really wonder why the option 5 regarding microcodes ONLY allows to “Find and Replace” the micorcode via either MCUpdate.txt or USR_list.txt instead of, lets say, “Find and Add”. The “Find and Replace” option deletes all other microcodes. Why? Because of final bios file size? I dont want to lose the option to use all the sc775 CPUs that are natively supported, I just wish to add some more microcodes for more CPUs, including HW+SW mode for sc771 CPUs.

I remember couple years ago, I just added microcode in to my ASUS P5P43TD bios using MMTool and the option “Insert…” in the CPU Patch tab, with no need to remove other microcodes. The P5P43TD now runs Xeon X5472.

Here is the original bios file: https://downloadcenter.intel.com/downloa…-?product=50375 It contains microcodes for 57 CPUs.

Here is my modded bios file: with only 13 micorcodes/CPUs support:

1. Is there a way to inject the new/additional microcodes in the bios, while keeping the other microcodes, using the UBU tool…at all?
2. If not then what tool shall I use to do so?

Thank you in advance!!

Regards, George

1) Add ALL the microcodes you need in the folder "USR_mCode"
2) Make a list.
3) Then, in the list, replace the ‘CPUID’ that are not in your BIOS with those that are.

It is necessary to add 306С2. In BIOS, there is only 306C3.



For 306C2 use as 306C3 ‘CPUID’.

@sonix ubu 1.76 is it supported for phoenix bios?thanks

If Phoenix UEFI - partial.

@pokuly - glad you were able to do the mod yourself. Yes, either way is OK/same, especially since new/old microcode is same size in this case, I just wanted to be sure since that user didn’t reply back originally.
Sometimes this breaks the BIOS so hoped we could be sure from him before you did anything.

@Sober :
I have moved your recent post into the "UBU Discussion" thread, which is designed for questions like yours:

Why did you post your question into >this< thread, which is reserved for SoniX, the developer of the UBU tool? It is mentioned very often.

No answer???