Dumped Bios DX79SR - Question regarding Ivy Bridge

@Spectral - OK, good Send me dump of your BIOS and tell me what you need updated, changed etc.

Dump from first post is identical, you may use it.
I need e5 v2 support (Mictrocode\ME\etc). Also can you find and remove write protection bit\module for future flashing with intel fpt software?

Kind time of day. I have dx79sr too, and also is necessary fashion for ivy bridge E.

Dump is not identical, dumps are specific to each motherboard, that is why I said send your dump @Spectral
Microcode I can add, what ME do you want?, what is etc? Yes, I can unlock FD so you can flash with FPT

Both of you guys, I have no clue if Ivy-E can work on this board, it’s not only about ME and microcodes, the hardware (power delivery, power scheme/design also has to support it)
Have you read anyone else mod BIOS for that on this model with success? If yes, then it works, if not then probably not. Some X79 you can do this easy, others do not work no matter what you try due to the motherboard itself cannot support it by design

etc=Maybe some addition actions required, unsure.
Intel BIOS is encrypted. No one can do it for now. You say able to mod, then i ask.
I able to mod many mobos, but no Intel.
Can you try dump from first post? Lot or action required for dumping image. I can remove chip and make dump if you confirm that you succefully mod this mobo.

Yes, I can mod many Intel BIOS, but you must send me a dumped BIOS from programmer, or you can send universal BIOS toolkit dump, or other full AFU DUMP etc, but you cannot flash it back without programmer so waste of time to mod if you do not have programmer.
You can mod BIOS? If yes, then you can mod this BIOS too, dump it and mod away. I’ve modified plenty of Intel BIOS, and seen many others do it as well, you just have to dump directly from the board and program directly back with programmer, that’s the only issue, sometimes you can’t modify or view certain things, but not always.
As for the BIOS in post #1, you can see he modified it too and is running it modified, but that’s his BIOS dump, you don’t want that, you want your own dump modified.

But as I mentioned, I doubt you can modify this for Ivy-E, it’s not as simple as updating microcodes and ME, many other modules need edited/added etc, and that needs to be done by manufacturer.
If you want to edit microcodes or ME in general on this board, yes you can, I checked the BIOS from post #1. Microcodes do directly via hex, ME use UEFITool (or hex too if you wanted)

Dump sent. Thanks

@Spectral @Lost_N_BIOS

I don’t have this board anymore, unfortunately. I gave up trying to get Ivy Bridge to work on it.

Modding this bios is not super easy but it is not impossible. It is possible to unlock FD, update to the latest ME7, and update microcodes. All my experiments with ME8 failed. All my experiments with ivy bridge CPUs failed.

I did not try to add NVME support to the bios. However, the compressed section with the bios DXEs that causes UEFITOOL to fail out with “decompression failed”, is available in uncompressed form by loading the raw .bio files on Intel’s website into UEFITOOL.

If you find and then transplant this section from the BIO file to your dump you can change the DXE modules as you wish with UEFITOOL. The bios will function normally with the transplanted section (this is where my testing ended).

Thanks @IntelModder - I sent him a BIOS to test, but only with ME8 and added microcode for Ivy-E, I doubt it will work but still waiting to hear back. I put in ME8 using FITc so settings did get transferred from the original ME7, but I still think other modules need modified.
How did you do the ME8 attempts, did you use FITc or just insert it? If just inserted I assume that may fail, but really I think it will all fail due to major ME change overs need to be done by manufacturer because of all the other module changes that need done at same time too.
Thanks for your tip on the volume swap, that would help with NVME insertion if he needs that. I think too many other internal modules need updated to also allow ME8 to work, aside from just putting it in there, and this usually needs done by manufacturer.

I can’t find it now but at the time I followed a guide that was posted on another forum about manually updating ASUS boards with ME7 to ME8. This guide required you to transfer each individual setting in FITC. It didn’t work.

I also found some examples where ivy bridge cpus were working on platforms with ME7 (from memory, although i could be wrong, the mac pro was one such platform).

Thanks, yes, that’s probably similar as the guide we have now for cleaning/transferring stuff to new ME, although there may be some stuff FITc does that you can’t see or manually transfer?
You are correct, some chipsets can run Ivy on ME7, unsure about Ivy-E on ME7 though.

Checked, thanks.
V1 work. V2 post 00, do not start. Postcode display blinking, maybe some power issue.

Thanks @Spectral - When using V1 CPU does the ME look healthy now, check with MEInfoWin - verbose (From V8 system tools)
If it does, then maybe CPUDXE/MemInit/PCHInit etc need updated to be compatible with the CPU and to properly run all ME8 functions (probably many other modules too), which only manufacturer can do

Did you get post 00 before when trying with original BIOS, or no codes at all?

00 - first post code, when BIOS loaded\failed. Generic post saying that BIOS unable to start.

When using V1 CPU does the ME look healthy now, check with MEInfoWin - verbose (From V8 system tools)

Already byu fast v1 cpu for this mobo and left it as-is. Thanks fo help.

@Lost_N_BIOS did you ever get the Ivy Bridge working on your DX79SR? I have one and bought a CPU without checking compatibility and now I’m stuck with a CPU I can’t return and from what I’ve read on many forums all I need is a microcode update? how much truth is to this? @IntelModder


Unfortunately you are out of luck. It is not just a microcode update. ME also needs updated (which we can do), but the board will not post with an ivy bridge cpu without updating a number of bios modules (which we likely can’t do without manufacturer support).

I was not able to get this to work on mine, and @Lost_N_BIOS has tried multiple times with this series of motherboards (DX79 - SR / TO /SI).

Unlike the third party manufacturers (ASUS, ASROCK etc) Intel abandoned their consumers on this series of boards.

Your best option is to try and on-sell either the motherboard or cpu.

thank you for replying, I’m gutted, I knew MSI would have treated me better, I got sucked into marketing extreme this skull logo and all

@Lost_N_BIOS did you ever get the Ivy Bridge working on your DX79SR? I have one and bought a CPU without checking compatibility and now I’m stuck with a CPU I can’t return and from what I’ve read on many forums all I need is a microcode update? how much truth is to this? @IntelModder

Thanks @IntelModder - I wouldn’t have remembered trying Do you know where I tried previously so I can look at what was discussed?
Did you remember if you ever tried microcode removed (ie none added I guess)? Or ME Disabled by itself, and or ME Disabled + Microcode removed? Or the ME8 BIOS I posted minus microcode?

@newguy2intel - I never had any of the Intel X79 variants, I assume he is correct solely based on what he mentioned above.
This is due to updating ME FW Major version is not a simple task end user/BIOS Modders can do generally due to many other BIOS modules need updates at same time too, by manufacturer as he mentioned
I assume you mean Ivy-E CPU, not Ivy, correct?

Probably best to sell that board, and get a different X58 board from better brand (MSI, Asrock, Gigabyte, Asus etc) if you want to keep that CPU and stay on X58