Easy TRIM test methods



Well certain programs which would touch a system disk.
All system services which influence are disconnected.
And without TRIM of cleaning it is possible to use the drive, just I see that record speed (in tests) doesn’t correspond declared by the vendor.
Thanks for an involvement.

Hello,
For some reasons I’m still using XP on ssd with fat 32 on a laptop with sata1, now the sata seems to be nothing else but a bridge IDE-sata. The laptop is old (2006, a dell inspiron 6400). I found out that I can be trimmed with Solid state doctor 3 demo version, or in real dos mode with boot it bare metal. I did it (I have a dual partition with pure dos partion), it seems to work, but how to verify if it works? Some say that Trim should tell the OS what cells can be used. How could XP know what I’ve done in pure dos mode only? I know, strange question, but if you can help.
Muzungu.

@muzungu :
Welcome at Win-RAID Forum!

Windows XP doesn’t support TRIM and doesn’t send any TRIM command to your SSD.
So it will be wasted time trying to verify, whether TRIM is active within your SSD or not.

Regards
Dieter (alias Fernando)

Thank you. I understand well that natively xp doesn’t send any trim command. It’s a well know truth for many years. My question is : is trimming from dos could be efficient, and even with a tool as the one that I mention? For example, Ssd tools as samsung’s and intel’s do that with their ssds, even from xp, so it’s theorically possible. THe only thing is that these tools work with branded ssds only, and with ntfs only.
My question is : how could I check if the xp fat32 partition (D:) has been properly trimmed, if I did it from Solid State Doctor 3 in Xp (D:), or from dos (from C:)
Thank you

It is not easy to verify, whether such method is efficient, because the TRIM test mothods, which I have presented within the start post of this thread, will only work while TRIM commands are sent to the SSD by the OS.
By the way:
1. Many SSD models have a very good “Garbage Collection”, which takes more time to make the garbage containing SSD cells usable again, but works similar to the TRIM command.
2. The tool named “Anvil’s Storage Utilities” is able to trigger TRIM on all sorts of SSDs and may work while running Windows XP as well. You can find this tool >here<.

thank you,
It seems to work while using xp! Actually, it took about 10mn to do the trimming, but I’m so happy! Tools from dos, it takes 10 seconds. And Solid state doctor 3 with xp, 10 seconds also. But I’m not sure they really do the work. They may try to issue a command that remain undone… Sooooo happy with your advice! Great! Thanks again! Have a nice day.

Dear Fernando, after days spent reading all the existing … I have to give up.

I’m trying desperately to run the TRIM on a RAID 0 array of 2 SSDs and I can not. TRIM is enabled by the operating system (Win 10) as verified by “fsutil behavior query DisableDeleteNotify” but both Trimcheck and the empirical test with HxD give me that the TRIM does not work.

Obviously the RAID works perfectly and I installed Intel RST (I tried the recommended version of you 13.2.x.x and others).

Can I ask you a huge help?


Configuration
Intel i7 4790k
Asus Maximus VII Impact (z97 express)
Bios 3003 (the last one)
Intel Orom 13.0.0.2075

PS
On the system there is a Samsung 960 EVO as a boot disk, so the array is secondary hard drive. Finally, RST says that everything works correctly and I have also enabled write through

@gauss :
Welcome to the Win-RAID Forum!

Only Intel Chipset RAID systems from 7-Series up natively do support the TRIM in RAID0 feature.
Since the X79 Chipsets belong to the 6-Series (C600), you may ave to repace the Intel RAID ROM module of your mainboard BIOS by a TRIM in RAID0 modded one.
Questions:
1. Which sort of SSDs (Manufacturer and model name) are members of the RAID0 array?
2. Has the currently in-use Intel RAID ROM been modified to get TRIM in RAID0 support or is it the original module as part of an original BIOS?

Regards
Dieter (alias Fernando)

@Fernando thank you so much for your reply.

1. SSDs are both Kingston HyperX SSD SH103S3/120G
2. Original one in the last original bios 3003 (last one of Asus Maximus VII Impact)

Uhmm, is there already a modified version of this bios or do I have to rebuild it myself? Maybe it’s harder than my ability

A little other question: in your opinion, in my configuration is correct to try an array like this (for video and photo editing) or a 3x array (I’ve got another one Kingston) or single ssd?

These SSD models have a SandForce Controller, whose TRIM activity is not easy to be detected by the TrimCheck tool.

If you want, that the TRIM command passes through your on-board Intel RAID Controller, I recommend to update the Intel RAID ROM to the attached TRIM in RAID0 modded Intel RAID ROM v13.2.2.2224 by using the UBU tool. It is easier than you may think.

I have never tried to combine more than 2 SSDs to a RAID0 array, because
a) the performance boost is not as big as between a single SSD and a RAID0 array with 2 SSDs and
b) the risks of a total data loss by the failure of one of the RAID0 members is much higher.

Intel-RSTe_RAID-ROM_v13.2.2.2224_TRIM-mod-acc-CPL0.rar (62.6 KB)

Ok @Fernando I’ve just tried with UBU tool.

I do all according to this guide
[Tool Guide+News] “UEFI BIOS Updater” (UBU)
(So, screenshots in this guide don’t appear, only thumbnail) and I tried to follow especially this part:


only a little issue, UBU don’t allow me to put your modded Intel RAID ROM v13.2.2.2224 'cause UBU only list me “standard” rom (that I assume are NOT a trim modded, or not?). I tried to enter “T” and don’t appear anything. “U” anything as well.
I put attached module in E:\UBU\Modules\IRST\User (it’s right position?)

So, now I’ve got a new bios but I don’t know if is TRIM modded or ony updated from my 13.0.0.2075 to listed 13.2.2.2224/13.2.0.2134 (but is TRIM modified?)

PS: I used MMTOOL 5.0.0.7

@gauss :
If you want to get the TRIM-in-RAID modded Option ROM v13.2.2.2224 inserted into your mainboard BIOS by using the UBU tool, do the following:
1. Rename the file named “8086-2822_v13222224_TRIM-mod.bin” to “SataOrom.bin” and copy it into the UBU\Modules\IRST\User subfolder.
2. Run the UBU tool, let it open your latest mainboard BIOS, choose the option 1 (Intel RAID modules) and then the option “U”.
Good luck!
Since these UBU questions have nothing to do with this thread, you should post your next UBU related questions within >this< thread.
By the way: The inserted pictures should be visable now (I just have changed the related settings).

@Fernando ,

Hi,

I am confused about wether trim command is passed through the onboard raid controller on a Z170 motherboard with version 15.5 raid efi driver to a m.2 raid array of two SM961 drives in Win 10?

Thanks

@davidm71 :
According to Intel the TRIM command should pass through the on-board Intel RAID Controller into the RAID0 array, if you use a modern Intel RST driver (from v11 platform up).
You can test it by using the TrimCheck tool.

Hello!
I want to show how to boot the system from an NVMe disk on AWARD Bios without using Clover and other means.
I have an old GIGABYTE EP45DS3P motherboard and want to boot from an NVMe drive. After installing an NVMe drive, through an adapter, it will work in an environment such as Windows.
And if you go to Bios Advanced BIOS Features - Hard Disk Boot Priority, Award bios does not see our disk. In order for bios to see our disk, OpROM from Samsung 950 Pro SSD comes to our aid.
https://gofile.io/d/JAKARO
First you need to find out the VEN and DEV of our disk. For example, my Adata legend 750 has VEN_1CC1&DEV_612A. 950 Pro.bin configurable for individual NVMe.
Open 950Pro.bin in the editor and edit the line at offset 00000020.
It looks like this for me, C1 1C 2A 61, after which you need to edit the last byte so that the checksum is “00”.
Next, we make changes to our Bios using cbrom195.exe with the command, cbrom195.exe EP45DS3P.F9c /pci 950Pro.bin

After flashing the BIOS, an NVMe disk appears in the Advanced BIOS Features - Hard Disk Boot Priority section.
You can install the system.

Fernando, please correct my post if something is not clear.

@Dagal
Thanks for your short guide about how to make a mainboard with a Legacy (non-UEFI) BIOS bootable off an NVMe SSD.
Here is a tiny correction:
1. The HardwareIDs you have posted are the ones of your SSD’s NVMe Controller (and not of the SSD itself).
2. The correct HardwareIDs of your ADATA Legend 750 SSD’s NVMe Controller are VEN_1CC1&DEV_612A.

@Fernando
All right.
1. 950 Pro.bin configurable for individual NVMe.
2. ADATA Legend 750 has VEN_1CC1&DEV_612A.
Thanks to Fernando for the corrections