Elitedesk 800 G2 mini corrupt ME


I have an HP Elitedesk 800 G2 35W with the following error on boot:
(A7) Me FW Downgrade - Request MeSpiLock Failed
After 10 seconds, it boots past this error, but I would like to fix this.

I found this thread on the forum with the exact same problem:

But it never realy got fixed AFAIK.

I can’t find any hidden BIOS menu to unlock ME flashing. There is an FDO jumper available, but as said in the thread above, shorting these 2 FDO pins makes the system power on and power offf after 2 seconds.

I’m about to order a SOIC8 + CH341a set to flash my chip.
Is there any guide available on how to do is?

Tnx in advance!

Please try to install the latest ME update from HP- might be SP139882 on

(But double check if this is the right page for your system!)

Post the result.

I already tried that and it ran without errors, but I think it didn’t do anything.

This is MEInfowin64 output:

So I guess a corrupt ME?
What’s best practice? Clean this corrupt ME or “copy” a working ME from a same identical machine (where I have access to)? @plutomaniac

Don’t copy an already initialized ME from another machine. Dump you firmware and follow this guide:

Your board should have a FDO jumper, but unfortunately in most descriptions people didn’t have any success in using it.
Otherwise it’s the other options to unlock the FD:

1 Like

The MB indeed has an FDO jumper, but when shorting these 2 jumper pins, the MB powers on only for 2 seconds and powers off again. Would be great if HP made it do what it was supposed to do ;-). I’ve ordered a CH341a + SOIC8 to read+flash the chip by hardware. It will arrive in 2 days. I’ll dump the full image, clean it (CSME v11.8 so guide part D4?), flash it back and I’ll report back!

Might expect another jumper in addition or maybe one should set the jumper after post- no idea, didn’t find someone who had success with this jumper on a HM machine.

Did you try a fpt(w(64)) -d spi.bin ?

If it works you’d get a proper dump. Even on a well prtected ME 12 Lenovo this works so it might be woth a try…

Try a fpt(w(64)) -i that might give you the chip type.

1 Like

I received my ch341a + soic8 today.
I dumped my W25Q128FV bios.bin 3 times with AsProgrammer v.2.0.3a, verified MD5 and they were all the same!
I then followed the ME cleaning guide and flashed the outimage.bin back to the chip. First time didn’t work (I programmed the image, but not unprotect + erase + program + verify like it should have been done). 2nd time I did the unprotect + erase + program + verify and BAM, my HP Elitedesk’s ME is al good again! Tnx to this great forum with excellent guides!

1 Like

Thanks for the feedback, good to hear that it worked out for you, too. :+1:

Keep those dumps, they’re a nice backup of ME configuration and machine specific data in bios region…