[Experimental] NVMe Option ROM

wow I can’t get it to boot from the USB… I have done everything in this tutorial: AWDTurboFlash an easy way to flash your bios - EVGA Forums but nothing, I don’t know what is happening, I don’t know if it is because of the pen drive, although I have tried several and this last one I have looked for a 4 GB one in FAT16 and nothing

Are you not able to flash the BIOS by using the standard EVGA tool from within the BIOS? In this case there is no bootable USB flash drive required.
Since I never had an EVGA mainboard, I cannot really help you regarding the BIOS flashing procedure.

Exactly, there is no option in the bios to update… the official EVGA website says that it must be done using a USB drive. My goodness, the easiest thing is impossible… I’ll keep trying later, I have to get it to boot from the USB in DOS mode or something like that… if I succeed, I’ll let you know.

The creation of a bootable USB drive in DOS mode is very easy with a tool like Rufus.

Ok, I have already managed to create a usb that boots in freedos and I have copied awdflash.exe version 789 to the usb drive, now I want to be sure that I do the right thing once I am in two commands, I have read in some forum that the commands that are used These are: awdflash.exe newbios.bin /cc/cd/cp/sn/py/wb/r

Could you tell me if I am correct? Do you know a little about awdflash.exe?

I know nothing about this sort of BIOS flashing.

Ok, I have managed to update the bios, everything went well with rufus and awdflash.exe but now I go into the bios and it still does not detect the Nvme disk. I can’t boot from the disk to install win10, I don’t know what could have gone wrong


It may not be shown, but this does not automaticly mean, that the SSD has not been detected by the BIOS.
Which OS are you currently running with your PC?
Has the adapter with the NVMe SSD been correctly inserted?
Does the Windows Explorer and the Disk Management show the NVMe SSD? If yes, which information about the SSD do you get?
How did you try to get Win10 installed onto the NVMe SSD?

I have a sata ssd installed with windows 10
yes, the adapter and the m2 hard drive are correctly installed, within Windows it detects them as secondary but in the bios it does not detect it, so that it cant boot from it.
windows explorere detects secondary nvme disk .

I have also tried to install Windows but during the installation it tells me that this disk cannot be booted because the bios does not detect it.

so the bios what i modificated dont work for me.

I repeat my until now unanswered question: Which information (name/size/file system etc.) about the NVMe SSD is given by the Win10 Disk Management?

i send you a pic

Thanks for the picture.
Provided, that the BIOS has been customized correctly, you should succeed by doing the following:

  1. Make a Backup of your Disk 0 (drive C: and MBR partition) and store it somewhere outside.
  2. Create a bootable USB Flash Drive with the desired Win10/11 Image on it by using Rufus 4.4.
    It should look like this picture shows:
  3. Let the Disk Management do a quick NTFS formatting of your current drive D:.
  4. Shut down the PC and unplug the data cable to the SATA SSD.
  5. Insert the just prepared USB Flash Drive with the OS Image on it. (point 2).
  6. Start the PC and let it boot off the USB Flash Drive.
  7. If the Win10/11 Setup should show the NVMe SSD as target destination, let it do the OS installation.

Good luck!

That’s exactly what I’ve done. and when the window to choose the disk appears… it does appear but it tells me that this disk cannot boot because the bios does not recognize it. and it won’t let me continue with the installation

It is a pity, that you didn’t succeed.
Since I am not able to help you further on, I have moved our discussion into this thread, which had been started by our Forum Guru Ethaniel. Since he is the creator of the NVMe Option ROM module you had used, he or any other Option ROM expert may have an idea about what went wrong in your case.

Please have a look into the already existing reports and support posts. Maybe there is already a solution available.

Good luck!

Would you be able to create one for me please? My BIOS is Phoenix

There is also a guide on how to add NVMe ROM to the BIOS.

1 Like


That is not much info. For which purpose do you want a link?
If you should mean a guide about how to add an Option ROM to a specific mainboard BIOS, you should
a) check the architecture of your mainboard’s BIOS (AMI UEFI/non-UEFI, Phoenix, Award, InsydeH2O etc.) and
b) search for the appropriate guide by using the Forum’s “Search” box.

1 Like

hello,i have an asus rampage iii gene ,ami bios ,having problem opening the file with mmtool ,i get : error loading firmware image ,have tried mmtool 4.5 and 5 ver.

Try it mmtool 3

1 Like