[Experimental] Resizable BAR DXE driver

@Adiel235 try this (do not update as dual bios, just flash using intelfpt or qflash)

B365MAEMOD.rar (6.0 MB)

Also, which 3060Ti model are yours?

1 Like

So your board does have Above 4G Decode (withouut any bios mods) but no Resizable Bar?

Exactly. Asrock and MSI seem to have enabled it on the X399 boards with a Bios Update… I did contact Gigabyte on this, maybe they will be able to help.

So rebar is not working? The 8192mb doesn’t work? I force enable via nvidia profile inspector and at 1080P extrme preset before 92fps to 101fps. 3Dmark sores also got better by 6-10%.
Of course i need to use igpu for initial boot.

@Adiel235 if you’re seeing 8192mb and fps increase then it’s working. i’d say just leave it as it is for now since you’ve got it all working with a workaround using the igpu

1 Like

Zotac RTX 3060Ti Twin Edge OC
This is from mi sources? Or did you download the bios from gigabyte?
https://drive.google.com/drive/folders/1BFgkvBQQgsnfTgN83dg-KZ0nXtOM3BtP
Mi CPU is not officially support by the stock bios, it needs to manually add the CPU microcodes and disable Intel ME.
The BIOS above has this changes.
If you can do the same but with the bios from above i will appreciate it. If not thank you for help anyway! :smile:

Okay, understood, thank you so much! :sunglasses:

This drive link is your stock bios that works with your board (no rebar mod, just pure stock bios for your board)?

so I was able to get the rebar working on two setups:
m8ha + 9900k + 6900xt
m8i + 9900k + 3070
on both of them I added the dxe driver AND “Don’t downgrade 64-bit BARs to 32-bit (by @Mak3rde)” patch.
they work great however there is a problem with both of these setups, the pc cant wake from sleep.
when you try to wake the pc from sleep fans start spinning but there is no image, then you have to press the reset button after which pc boots up to the previous state (ie it resumes where you left off).

@crashpb if you set the BAR size to 256MB in ReBarState does it still happen ?

well I have not tried doing that, right now rebar is set to max and this sleep behavior is a minor issue for me that I can live with.(as long as I can put pc to sleep and resume I`m happy)
I will try to test 256mb rebar the next time I happened to reboot my pc.(which might be a while)

also do note that bios on both boards was already modded before adding the rebar dxe driver. (coffeetime mod to run coffeelake on z170)

I’m having the hardest time using UEFITool for my Z170 board, anyone able to assist?
ASUS MAXIMUS VIII HERO

Hello @selco13 ,

What seems to be the problem?

I guess I am just not clear on the steps needed, new to bios modding.

Apologies for the delay in replying, I fell asleep. :sleeping:

Do you have an eeprom programmer? Another machine / laptop?

The firmware chip on the Maximus VIII Hero is removable. If anything goes wrong you can always flash a known good image to it.

The ROM image is contained inside a CAP file. Use the UEFITool to extract the ROM from the CAP file.

ACTION>CAPSULE>EXTRACT BODY. Name it M8H.rom . The file will be 16,384kB.

Open this new file with UEFITool and perform the modification you want.

I have an Asus Maximux VIII Gene and after applying the ReBAR mod I had to apply one of the patches to enable over 512MB BAR

PciBus | Don’t downgrade 64-bit BARs to 32-bit (by @Mak3rde)

Try to Update using bios flashback, just make a Fat32 format flashdrive, extract the zip file, copy paste M8H.CAP to the Fat32 flashdrive directly, put usb to the desingated USB Flashback port, make sure pc is completely off, then push bios flashback button till it flashes some light

More info on asus bios flashback here: How you can update your Asus Bios with or without a CPU using USB Bios Flashback - YouTube

Here is the bios file:
M8H.rar (6.9 MB)

if flash succeed, you must turn off CSM Support and anything related to legacy except Legacy USB Support, save and exit, then enable the Above 4G Decoding using the grub method on ReBarDXE Github, your Variable is at 0x7B9:

Maybe you could try this, if regular flash cant do, try to use flashrom to flash it. Then if flash successful, go to bios and disable CSM, just make everything UEFI. after that, enable Above 4G Decode, then save and exit. Make sure your GPU does support resizable bar, or if the gpu does but need vbios update, then update the vbios first to support resizable bar, then update to this bios, make everything UEFI (Pure UEFI, CSM must be disabled) except legacy usb support, then enable Above 4G Decode, then save and exit.
X399AOXTMOD.rar (5.4 MB)

1 Like

HI,

wow, thank you. Is that a hand-modded Bios ? Thanx for supplying it, I will test it when I come back to where the PC is :slight_smile:

I also reached out to Gigabyte Support, the provided me with a F5 Version of the Bios with added ReBar Support, I will test this as well and will get back with feedback.

Thank you !

1 Like

Kindly Share the latest vbios with rebar support from gigabyte here, might be useful for someone who needs it :relieved:

I have tried this process multiple times with two different flash drives and it does not seem to work. I have successfully used this process for stock bios files previously.