Flashing Gigabyte while avoiding "Invalid BIOS image"


Would it be possible to mod the latest 0.65 efiflash, to let flash mod bios’s in Gigabyte mobos???

Thanks in advance.

try this

modded_0.65.zip (45.4 KB)

I can try it for GA-Z370-HD3P but it cann’t help.
I flash new bios but it’s backup to old bios after restarting

Try to use this command
efiflash.exe nameofbios.FX /C /R

hey guys,

I have a bit of a problem here and I think this could solve it:

I recently purchased a Gigabyte x370 Gaming K7 and when I booted up and looked into the BIOS I saw that the model number was saying B350 gaming 3 which is a different mobo of course. I then tried to flash the correct current BIOS of the x370 K7 but I always got the Error: ID mismatch

Now I think this error could be avoided by using a modded efiflash.exe like shown above - however it should be a newly modded one with RYZEN support etc.

So my question is if someone could please mod the attached efiflash.exe so I can try it to fix my mobo

Efiflash.exe.zip (45.9 KB)

@nikezzz Before you force flash anything and potentially brick the board - Have you looked at the model of the motherboard printed on the PCB?

I’d make 100% sure it says Gigabyte x370 Gaming K7.

Yes, 100% sure it’s a Gigabyte x370 Gaming K7 rev 1.0

They somehow must have applied the wrong BIOS chips in manufacturing as even the B_BIOS is also B350 Gaming 3

Wow, that is so bizarre.

Yes I also could not believe it in the first place.
I’ve built at least over 30 PCs in my life and never seen something like this.
But I’ve read online that this happened in the past with some Z87 boards from Gigabyte before.

So I bought this K7 refurbished so maybe this could also be a possibility but I can’t see any manual soldering marks on the bios chips so I don’t think this was done with an SPI Flasher.
I have a 14 day return window but I would like to fix it this way so I don’t need to disassemble everything and ship it back.

Did you try flashing from DOS with Intel Flash Programming Tool (FPT)?
Or from DOS with AFU and use /X switch (= Don’t Check ROM ID)

SPI flasher can be used with cheap cable, no soldering marks. So if you have $2.50-3.00 for CH341A and another $2.50 for cable you’ll be set too if the above doesn’t help.

Yes I‘ve tried Afudos and also /X but I always get:

46 - Error: Problem getting flash information.

I didn’t tri FPT as I don’t know if it’s compatible with AMD boards and I don’t know where I can find a recent version

Thx for the tip on the adapter - I didn’t know these existed. I’ve already ordered one. I hope this works with my MiniPro

@nikezzz - Did you try all three version of AFU that has /GAN option (ES Versions)? Try /x /GAN together w/ these in the ES folder only (BIOS8 folder if for much older) - http://www.filedropper.com/afu

I don’t know if Intel FPT would work on AMD BIOS, I was thinking so from DOS, it’s a straight flasher/programmer like Uniflash which could be another options to try.
I think in DOS it would see only flash chip, and AMI BIOS which it can certainly flash. It could check for Intel ME or something maybe, but it seems like it doesn’t. I’ll have to test sometime if you don’t end up trying this go around.
Here is Intel FPT DOS - http://www.filedropper.com/flashprogrammingtool Worth a shot!

You’re welcome on the CH341A flashers! Always make a few backups once you get it and then verify they are the same and valid, before you start any programming.
Sometimes you need to find the right software tool, or software version for your board and flasher at the time. More info, and tons of software types and versions here throughout the thread
[Guide] Using CH341A-based programmer to flash SPI EEPROM

@Lost-N-BIOS thx for the files but unfortunately no luck :frowning: still getting the error Problem getting flash information - I don’t know exactly why - it seems that AFU is not compatible with the X370/B350 boards? I’ve tried all 3 ES versions but the errors seem to be all relating to not getting information from the BIOS chip

I didn’t try the FPT tool yet as I’m not quite familiar with the correct flags and I read somewhere that it’s killing the MAC address somehow without the correct flags?

The C341A, 1.8V adapter and the adapter cable are coming tomorrow. I hope I will have more luck in trying this.

Sorry I forgot to mention, for FPT if you try use -savemac flag, that will preserve your MAC. Ideally before flashing with anything you want to get something to give you a good valid backup.

Does backup.rom /O let you make a backup? If not, install Gigabyte’s app center from your motherboards download page, then install @BIOS, and use it to make a backup. Then you should be OK to proceed trying to fix, someone will be able to get your board info from backup later if needed.
You can try crossflashing with @BIOS too if you wanted, sometimes it works, and sometimes that is how this happens to boards like your issue. Be sure all apps are closed, so less chance @BIOS will mess up.

Good you will have flasher and cable tomorrow, all will be solved! Get a backup now with @BIOS, so you can get out your LAN MAC, gigabyte doesn’t usually put board serial into BIOS, but you can look around in AIDA64 and see if you can find one in windows (Other than 1234567890123456 etc)

Ok so I tried FPT but I got an unexpected error occurred so also no luck there.

The /O function of afudos also doesn’t work - gets the same error when trying to flash

I made a backup using Q-Flash and uploaded it if you want to take a look at it: https://mega.nz/#!1UdV0I6C!ILK74i6Vm1_Tw…xqqKnpSH0j0rHLM

Thanks for trying FPT, I’m surprised and not surprised it didn’t work. I expected it might, but then assumed maybe like you said it somehow checks for AMD/Intel.

You can fix quick tomorrow once you have flash programmer, make some backups and verify they are OK, if not try other software until you find one that does make backups that are OK. Then program in correct BIOS for your board and you’ll be good to go.

I forgot AMD not like Intel for MAC. Please check your LAN MAC address now via command line using ipconfig /all. Make sure LAN is connected, and you get info from LAN not wireless MAC.
Confirm LAN MAC with HWINfo or AIDA64 in the network areas. Once you find and verify, send me the MAC Address (via PM if you want) and then I can locate in this BIOS, so I can then show you how to correct in your BIOS before you program to correct the board ID

Never mind! Sleeping I think You can get LAN MAC values right on the board, there should be a sticker on or near the LAN ports that will have the MAC Addy, confirm this with above tools though so you are sure which is LAN MAC 1/2 and not 1394 MAC etc.
Then send to me, so I can locate in BIOS to show you how to correct/edit in BIOS you will program later to correct the board ID

@nikezzz - While you wait on your flash programmer to arrive, here is test BIOS to try, please test and see if it will flash for you!

Invalid ID Tag ------- 8A06BG08 (38 41 30 36 42 47 30 38) (Current board ID is this ID/Wrong ID)
Valid BIOS ID Tag – 8A06BG0I (38 41 30 36 42 47 30 49) (Correct BIOS ID for your board/Original K7 ID/This BIOS does not have this ID anymore)

I changed GA-AX379-Gaming K7 BIOS F23f to have that same matching incorrect ID (8A06BG08) that your board currently has, it shouldn’t give ID mismatch now.

I searched through each BIOS for each the ID string several ways by ID value and by “ID String”. Each search I did several ways via Unicode, string, regular expression, hex etc.
A clean stock BIOS from Gigabyte has 7 x instances of the correct BIOS ID, your saved backup has x16 instances of invalid.
I assume copied into saved data etc, some in recovery, Qflashhandler etc not all relevant since stock not that many and valid ID for stock BIOS does not appear in those locations on clean BIOS either.

If this works, it will only fix the issue temporarily, as in you may be able to flash this if these changes get around the ID check, but next BIOS update for K7 will have it’s original ID so you’d be in this same situation still even with correct BIOS already in there.
So you can test if this method works or not, and if so it’s great to know, but you will still need to reprogram correct unedited (Aside from LAN MAC ID) BIOS to your board with programmer and unedited BIOS ID

If this still fails to flash in Qflash, try EFIFlash from DOS (If fails, try again with /x switch, then if still fails again with /y, and one final with /z)

Once it flashes, if that happens either way (Qflash, EFIFlash) it will reboot and then proceed to update the backup BIOS as well most likely.
That you can correct once your programmer arrives and you program in the correct BIOS onto main by using ALT + F11 at startup (Where you’d hit Del to go to BIOS).
Or with your programmer, program backup first. Then start board and enter BIOS, if it’s OK and doesn’t recover from backup BIOS, reboot and hit ALT+F12 at startup a bunch until it says "recovering BIOS from backup"
Or you can simply reprogram both at once with proper BIOS using your programmer, whatever seems easiest to you.

Success! @Lost_N_BIOS you’re the man!

Q-Flash didn’t work with your modded BIOS but efiflash with /x did!

Thx so much man! The UEFI now looks great and has all the features. Great idea on changing the IDs in the BIOS file

Now DHL just needs to deliver the flasher and adapters

EDIT: So I checked the MAC Adress of the NICs and the Intel one is: E0:D5:5E:25:6B:1A - there’s another NIC on the board which MAC Address isn’t mentioned in the BIOS - I’ll fire up a new Windows Installation to check it later today

Nice!!! Glad you were able to get it flashed in there. I figured you’d probably like to try out the newer BIOS while you waited, and of course delivery is never on time when you need it most so just in case I had to try to fix it for you

If you can’t find the other MAC, you’ll have to get the board out of the case, or at least see if you can look at the stickers, usually they are on the LAN ports housing, but not always.
Sometimes sticker is under/on bottom of the audio block too, on the bottom part right there by PCIE slot. If you can’t see both, yes you should be able to get it from in windows, with IPConfig /all, or AIDA64, or HWInfo etc.

Did it end up rebooting and flashing the backup BIOS too, or did it leave that alone? Sometimes it does both automatically, other times only if you use one of the xyz switches I think, and sometimes those don’t do it either so it may depend on BIOS version too.
Every time I’ve cross-flashed it did though, automatically usually, but maybe since “BIOS ID” was the same this time it tricked the board into seeing backup as same BIOS on main chip too

Like you said delivery is never on time when you need it … I got the adapter cable but the 1.8V converter wasn’t delivered today - I hope it’s here by tomorrow.
I checked the board but there wasn’t a sticker with MAC addresses - I’ll check them later with ipconfig in win 10

There are 2 switches on the mainboard: One is for switching between the main and B BIOS and the other one is for enabling Dualbios function - I disabled the second to have more control in case the mainboard flashes back the B350 BIOS

Thx so much again for taking the time and modding the BIOS! If you are ever in the south of Germany hit me up and I’ll buy you beer :wink: