GA-P67A-D3-B3 rev. 1.0 Bios MOD / ME upgrade

I read there was some successful upgrades ME7->ME8 on P67 boards to support Ivy Bridge but I cannot find if it also unlocked the multiplier on K-CPUs. I’ve got Gigabyte GA-P67A-D3-B3 rev. 1.0 and Ivy i7 3770K, the latest official BIOS is F7 with ME Ivy boots fine on this MB but CPU O’C i stucked at 39x max. multi. Would be upgrading to ME 8.x enough to unlock higher multi? I know it can be upgraded to ME 8 but don’t know if it needs further BIOS code mods.

Usually there’s no issue updating it to ME v8, the r2.0 of this model already comes with ME
Regarding OC features/unlocks, it may improve something or nothing at all, cpu mcode revision also have impact on this, i do not have this working mb model to share any info about it.

Upgrading it, its a single operation based on ME System Tools v8 r3 and latest ME 8 1.5MB v8.1.70.1590 fw file.

I do suggest having the Backup bios also updated with the official F7, in case you want to recover the Main bios.

Keep in mind that the best chipset for this CPU and OC features was the Z77…

All this is a user choice only, good luck.

I doubt that microcode affects O’C features. There are allready Ivy micodes in official F7 BIOS. I did full SPI flash backup and I plan to try ME8 update and also I found some unknown UEFI beta BIOS P67AD3B3.U1D with ME8 but I don’t know if it is for my HW rev. 1.0 and not 2.0. As I have backup and SPI programmer I can safely experiment.

Well, you then should investigate a bit more… cause they do.
Version 19 Date 13-06-2013 is considered to be the best for 306A9 (IB) regarding OC values. Latest one released by Intel is 21.
The r2 had a beta UEFI bios transition. You want to “play” a bit with it, then cross flash on your r1, if you’re willing to take the risks.

EDIT: @RayeR [OFFER] Intel CPU Microcode Archives - Special Topics / CPU Microcodes - Win-Raid Forum (

Yes, I did some experiments. 1st I tried to flash F7 image with upgraded ME module from to or and it did the trick. When power on after the flash I got in power on/off loop but holding reset button during power on brought it up. Also I once seen a message “Fix ME firmware data 0-100%” before OS boot. Now in SETUP I can select multiplier up to 59x. I just tried 45x as on my Sandy and it works…

CPU vendor name: GenuineIntel
CPU name: Intel(R) Core™ i7-3770K CPU @ 3.50GHz
CPU ID: 306A9 - type: 0 (primary), family: 6 (P6), model: A, stepping: 9
CPU cores: 4/8, turbo speed: 4500MHz = 45.0100MHz; L1 cache = 64kB, 8-way
TSC measured CPU core speed: 3492MHz = 34.9
100MHz; L2 cache = 256kB, 8-way

So it seems that some code in ME controls the multiplier and pass the allowed values to SETUP. Maybe ME would have ability to set higher mul. even on non-K CPUs but I doubt… Anyway it proved that Ivy O’C fix can be done just updating ME and not UEFI is need as I could read in many many articles on the Internet…

Then just for a fun and curiosity I couraged to flash the unknown UEFI image P67AD3B3.U1D that I DL from P67AD3B3.U1d It was mentioned on some forum but without any details for what HW ver. it is purposed. I run FLASHEFI.EXE from DOS and it flashed both Main and Backup BIOS without any complain of version/ID mismatch or so…
But after power off/on I have several problem to boot. I got just black screen or sometimes I got UEFI splashscreen:
but it just hanged there. It didn’t respond to any key except Num/Caps… locks and CTRL+ALT+DEL that performed reboot but then hanged the same. Also holding reset at power on didn’t help and DualBIOS key combos didn’t work too. So I cannot enter SETUP neither reflash and got a brick. So I had to desolder flashchip and reprogrammed it with backup. I’ll see if it will be enough to reprogram Main BIOS only to reflash Backup BIOS normal way, I guess it should work. As I don’t need the UEFI I can just stay with my modded F7 BIOS…

1 Like

I soldered back the reprogrammed Main BIOS flashrom to restore the old BIOS from UEFI, then used ALT+F12 to copy Main to Backup…

>MeatWar, could you point me to mentioned microcode v19h? The closest I have is 17h and 1Ch (original BIOS contained 0Ch). I don’t want to use the latest with spectre&meltdown workaround as it may have a performance hit… From this point the 1Ch from 2015 should be still OK.

Well, found it in archive here: [OFFER] Intel CPU Microcode Archives

1 Like

In a case that someone else would dig up that old MB from a trash and wanted to run Ivy, I uploaded my modded BIOS image here (based on F7, ME and newer microcodes but from pre-Meltdown workaround era):

1 Like

@RayeR Thank you for uploading your modified BIOS for others.

I have mirrored the upload here as a forum attachment as private URL’s tend to disappear on this forum. (1.9 MB)