Gigabyte EP45-DS5 AHCI/RAID ROM update problem

Thanks Bugger Vance, I would like to use the most stable F12 version but I know the F13 version is ok even though it has gone from beta. No matter what version F12 or F13 would be, what I’m interested in is to have bios with the latest updates said as much as possible. Can you put the microcodes for F12 to make a comparison with F13? Thanks for everything and I’m waiting for mods with the latest with Intel RAID Rom.

There is no more “beta” BIOS for this board really, F13A (2009) and F13d (2010) are the last two final BIOS made for this board, both 8+ years old so not really a “Beta” anymore simply never updated to be called a final since they stopped working on these boards BIOS.
F12 BIOS is 2008 (Now 10 years old) & 2 years+ older than the F13d (2010) I modified for you above, I highly suggest using the F13d it would be most stable and up-to-date by Gigabyte, especially since you are already having issues with modern operating systems.

I am not sure about the windows issue, you may need to have drivers additionally on a USB drive?
See this guide and step #11-12 and see if it offers you any help or something you haven’t thought of or tried yet…ndows-10-a.html

One other thing I can think maybe cause issue is which SATA port you have the main OS hard drive connected to on the motherboard.
Purple ports may not work for a windows 10 install, I’d advise against using them for any OS anyway, only for additional storage or other SATA device like CD etc
Be sure it’s connected to one of the yellow ports, preferably the bottom yellow one on the two ports on top that are pointing off to the right side of the motherboard.
If you can’t use those two top “off to the side” ports, use one of the two yellow directly under it (ie not the last/bottom two yellows)

I do not know which RAID rom is best for this chipset, or which will best fit into this BIOS. You’ll have to find someone discussing that and choose, then let us know here and we can add in for you.
Fernando mentioned some above, but he wasn’t specific so I’m not sure which would be best to use. Once you have decided I can do the edit for you.

Here is F12 modified same way as above F13d

This may help with the Win10 CPU install error -
First, always load “optimized defaults” then reboot back to the BIOS to make any other changes you want.
Then, for the CPU error issue, be sure “No Execute Memory Protect” is enabled in the BIOS
This setting is in the “Advanced BIOS Features” page…1-8-error.html

@ Bugger Vance

Hi, I installed both versions with @BIOS utillity
(update bios from file manual and I selected the versions you sent me one by one)
but every time my bios is doing recovery after the default version on dual bios backup.

I attach the pictures.

Where am I wrong ?

P.S. The bios version is F12 or F13a not F13d and does not appear 2015 only 2008 F12 and 2009 F13a




I posted F13d above in post #19, first mod I posted, it’s BIOS creation date is 2010. The 2015 is the date of the microcodes I inserted for you.
I did not post F13a, it’s too old, same as F12, I suggest F13d for best luck on this windows 10 issue

Flash from within the BIOS itself with Qflash, not from @BIOS sometimes that can easily brick a motherboard. Best to do from DOS or within BIOS with Qflash (F8 while in BIOS)

If it still does that recovery, then let me know and I will do another mod. If Qflash gives you a checksum error before flashing we’ll know the BIOS is a problem, need mod different way.

* unrelated to the BIOS stuff, regarding Win10 install issue - Did you check your operating system hard drive to make sure it’s connected to correct Intel ports as mentioned above (Yellow)

** Just in case, while I’m here, here is another F13d modified slightly differently (and named different so you can keep track)

I made the bios flash with the ep45ds5196 version, my SATA cable is in Sata 0 yellow and windows 10 started to install with the IDE and HPET Enabled x64 setting, I knew I had to activate the AHCI setting for windows 10 but it finally started the installation.

What I Wanted to Ask: If I install a SATA3 PCIE controller (theoretically 6Gbps) I can install a ssd that works better than SATA 2 (theoretical speed 1.5Gbps) on this motherboard?

I will do some tests and say if it’s ok, thank you for the moment. I appreciate your effort.


You’re welcome, and it’s good you got it flashed and windows install working! Yes, AHCI would be better than IDE, always! You’ll have to do the regedit to enable AHCI post install and then you can change to AHCI, unless you already did that.

SATA 2 is theoretical 3Gb/s, not 1.5Gb/s despite wiki saying that, only SATA 1 is that slow, so SATA 2 not as bad as 1.5Gb/s. I think max actual I’ve seen on single SATA 2 port was 288-295Mb/s
I am not sure how fast you can get with a PCIE controller on this chipset, but way back when P45 was first being used I ran a RAID 6Gb/s PCIE card and with 2 drives could easily get over 700MB/s and that’s with old early SSD’s too.
So yes, you can definitely use PCIE 6Gb/s controller cards and 6Gb/s SSD’s, and it will be much faster than SATA2 speeds, but I am not sure where the upper limits of PCIE bandwidth tops out on P45

Here is new mod, with both CPUID’s >> 1067A + 10676, in case anyone needs later

- Removed 1067A Rev. A07 (4/9/2008) (platform 0,4)
- Inserted 1067A x 2 Rev A0E (Platform 44 (2,6) & B1 (0,4,5,7)) 7/29/2015

- Removed 10676 x 2 Rev 60C (1/19/2008)(platform 0,4)
- Inserted 10676 x 3 Rev 612 (8/2/2015) (Platform 0,2,4,6,7)

Links not work. please download the firmware.

@navodri :
Welcome to the Win-RAID Forum!

Which links do not work? Why should anybody download any firmware? Which one do you mean?
Dieter (alias Fernando)

following links not work;

i need firmware under Gigabyte EP45-DS5 fo XEON

@navodri :
We cannot help you, because only the former Forum member named “Bugger Vance” has the related original files and the filedropper links are meanwhile expired. That is the big disadvantage of using an extern hoster instead of attaching the files directly by using the Forum software.
Bad consequence for you: You have to modify the BIOS yourself.

That was me @Fernando
@navodri -…416343045050850

That was what I already suspected, but I didn’t want to betray you.

no betrayal, it would be OK. I only used that while I was too lazy to join

thank you very much!