Gigabyte GA-H61M-DS2 (rev. 5.0 - 4.0) Nvme support check

Hi guys,
I tried to mod my old Gigabyte motherboard GA-H61M-DS2 (rev. 5.0) for PCIE Nvme support, I have not flashed it yet, I followed the guide, downloaded the BIOS file from Gigabyte, deleted all language other than English as I was getting error, then I managed to insert NvmExpressDxe_5, kept the original file name (.F7 extension!), please check the attachment. I am totally new to this, no knowledge at all, do not even know many terms!! :smiley: I am just wondering if anyone can check whether I have done this correctly. I will be in trouble if I brick this motherboard. :smiling_face: (2.8 MB)

Hello and welcome,
I’m sorry but an additional pad file emerged (Before mcode) upon doing the mod, it’s not OK, try UEFI tool or MMtool method and/or different versions of such tools 4.50 or 5.007.
Can try also the small DXE5. Just check it with UEFI tool for pads upon doing several attempts.
Read careful the guide/notes.

1 Like

Hi MeatWar,
thank you for taking time to check it, I followed just as the Guide said, Used MMtool (mm_aptio_tool_v5.0.exe). I actually didn’t understand what you are referring to, sorry, can you please clarify a little? How would I make sure it has been done correctly? Thank you.

@MeatWar ,
Can you please check again? I inserted small DXE5, no pad file this time! :man_dancing: (2.8 MB)

Seems ok, but that’s it, neither i or anyone else in the forum, can’t assure you of nothing regarding mods/flash, the rest it’s up to the user.
Still, you have Dual-Bios if anything fails.
Good luck.

Top of volume, original pad present:

End of the volume, no new pad:

EDIT: Use Q-Flash method, NOT on OS environment or @Bios

1 Like

@MeatWar Yes, Top of volume, original pad present and no new pad at the end, just like the original. Thank you for taking time to check it, I will flash later with Q-Flash as you suggested, let’s see how it goes.

Hi guys, a newbie here. I have a GA-H61M-DS2 rev 3.0, I have the latest f4d bios from the GA website. Can I use this bios with my MB? Appreciate the response.

This is F7 bios for the 5.0 revision, not for the 3.0 revision motherboard, its is not recommended to use it.

EDIT: It would but why don’t you try it, the guide is very well elaborated, all here on this thread applies to any revision.

EDIT: You can post it here, ill modify the thread tittle to the 2 revisions.

Got it, thank you for the response. Would it be appropriate to submit a request for the rev 3.0 model? I’d really like to have my MB running NVME “natively” (well, almost) through bios.

Yeah, tried it :slight_smile: Can I post the file here to verify or use another topic? (2.8 MB) (BAD)
Uploaded, thank you.

The module seems correctly inserted, you may check for missing original/added pads according the guide, if so don’t flash it and try alternative method also in the guide.
God luck.

Hi, thank you for checking. This is where it gets complicated. My BIOS looks totally different from the one in the example, but I think I did manage to find the difference, and the Pad file
1st screen is the original BIOS

2nd screen is the modded BIOS

Am I looking at the correct block? Can I just remove the PAD somehow?
I can’t follow the second method, I tried. My BIOS file looks very different from what I see on the screenshots, so I would appreciate the assistance.

I tried with UEFI tool again, but I don’t have the option to insert files

Or here

Indeed a new PAD non-original was generated, no can do.
You shouldn’t remove PADs manually.

The UEFI tools has 2 versions, the “regular” 0.25/0.28 and the “NE” alpha xx
The first variation for insertion and the second for extracting/deep analysis.

I got it, can you please validate it now? I have used the the other version as you suggested and inserted it in the same place where it was inserted by the mmtool, after the CspLibDxe section.

and the BIOS file (2.8 MB)

There’s no “Validation” here on mod files… you take as it is, as we all do.
You already know the correct module insert location and how to check for pad files, that’s it, other than that, no one here will vouch for any rate success of any mod operations.
This is mod world and in modding everyone takes their own risks or NOT, simple as that.
Good luck, over_n_out.

PS: Report back for future user guidance/reference, thank you.

EDIT: Enjoy it and thank you for the feedback, all the best.

Got it, thank you. Now I can report back that it is a success! After flashing the new bios, the system booted up from the SSD and it runs perfectly. I already had Windows installed. Thanks for the assistance. I think it’s “safe” to update the topic to include two versions of the BIOS in case anyone needs v3 or v5. Cheers!

P.S. I’m super thankful that such communities exist! :heart: