Gigabyte X470/ X570 Aorus BIOS mod thread

@ket if you want i can test a modded bios on my b450 aorus elite

EDIT: i was so confused, sorry, my motherboard is a b450 aorus pro!!!

@Redox199 that would be very useful I’ll put something together.

@ket really thank you. If you need some information here I am, you can ask what you need.

I’m also willing to test, I have a " B450 AORUS PRO WIFI "

Hello! I came across this topic in the hope of getting rid of nervous exhaustion.
The fact is that I am the owner of the motherboard Gigabyte Aorus x470 Gaming 5 Wi-Fi. Overclocking on it does not add performance, but only brings pain and suffering.
To begin with, here you can’t do a simple overclocking of the processor through the multiplier and setting the voltage. My Ryzen 7 2700 processor has a lower voltage, and the board does not allow increasing Dynamic VCORE higher than +0.300. What is not enough for 4.0 Ghz. It is necessary to make "overclocking" through P-states. Same thing with SoC voltage.
But at least these problems can be solved. The main problem is overclocking RAM. We can say that it is not at all. The maximum that can be obtained is 3066 Mhz.
Higher values do not pass stress tests. At first I thought that the matter was in my RAM, they have Hynix MFR chips. However, there are no problems on other boards.
I recently changed the kit to Samsung B-die, (ADATA AX4U320038G16-DT41), but I still can’t increase the frequency above 3066 Mhz. I tried almost all the settings that are available to me in the Ryzen DRAM calculator. I think there are similar problems on Aorus Ultra Gaming.
My board behaves the same with overclocked processor or without him.
I also noticed that I do not have some settings in bios, for example, BGS / BGS alt, LLC is missing. And during voltage tests, they behave unstably. BCLK jumps so much that the memory frequency of 3200 Mhz can increase to 3360 Mhz.
I tried increasing the timings, adding or decreasing the voltage, but this does not affect the result. So I would like to know if there is a way to fix this?

@Redox199 & @Zippy3435@gmail.com ok I’ll get something together soonish, very busy atm. @Messier26 I can probably do something to remedy at least some of those problems.

@Messier26 very quick edits but here is something you can try. PBO is disabled which should help with getting stable manual OCs. Also try swapping the DIMM banks your memory is in. Clicky.

I want to change the name in UEFI "Manufacturer" & "Product"?

For example, the Geekbench to show something other than…
i.postimg.cc/qB2dC6YQ/Geekbench-5-2020-08-13-14-42-16.png

How to do it?

Looking for some help or some answers…

I can’t run any of the newer gigabyte bios and have windows 7 boot. F14 is the oldest bios that I can boot windows 7 in.

I’ve done the plethora of troubleshooting and then saw someone on another board with similar problems who also fixed the windows 7 issue with using an older bios.

I’m curious about the new Ryzen 5000 series, is there a way to put the new chips microcode inside the F14 bios? Is it as easy as the intel chips? I have no experience with the amd side, but a while ago I did play around with UBU utility for intel. Someone please guide me, I’m curious if I will be able to use ryzen 5000 if this method is possible. Thanks in advance

Is there a mod to get back the removed pcie4 on X470? I’ve updated to the latest BIOS, and don’t think it’s possible to revert to pre pcie4 removal update…



@diman82 Best option is to mod the latest firmware that had PCI-E 4.0 support.



@johndoe0004 There are hidden options in the GB firmware that should overcome this issue. I can’t be certain it will as I don’t have any GB X470/570 boards to test on but there is a very good chance a modded firmware with these unlocked options will cure what ails you

1 Like

Looking for help to enable ReBAR on X470 AORUS GAMING 5 WiFi F63c (for an Intel Arc GPU, which requires ReBAR for running properly):

For some reason Gigabyte does not enable ReBAR option with Ryzen 2700X CPU, although all other brands do. How and why did Gigabyte get so messed up ?

I tried using IRFExtractor to find the offset to ReBAR option in the “Setup” EFI variable, and updated it manually using setup_var.efi. But nothing has changed, ReBAR is still not enabled.

I tried changing Access for ReBAR from “Default” to “USER” using AMIBCP, but I can not flash the modified UEFI. I tried:

  • using a modded Efiflash.exe 0.74, but it reboots after 2 seconds, presumably successfully if I watch the command output, but then my current UEFI is not modified.
  • using AfuEfix64.efi found above in this thread. But it says “Loading capsule…” and then “18 - Error: secure rom flash verification failed”

I looked at my modified UEFI image in UEFITool and there is no “Aptio V capsule”. Although the word capsule does appear later in the tree multiple times. Is there a way to remove the capsule in this case ?

I tried loading and saving my modified UEFI with UBU, but it has no option regarding the capsule and it just saves (dumps) the input file unmodified.

Is there a way please to flash a Gigabyte UEFI image ? Is there a modified AfuEfix64.efi for this ?

Thank you,
Timothy Madden

ReBAR is just SAM on AMD boards (Smart Access Memory), thats the option you need to enable. AFAIK 2000 series CPUs don’t support SAM only 3000 series CPUs onwards.

I hear other motherboards support ReBAR for 2700X CPU, only Gigabyte hides the option. So I figure 2700X must be an exception and support ReBAR. I believe it needs AGESA 1.2.0.1, which Gigabyte has in their UEFI for a while now.

I see no SAM or Smart in IFR output, only “Re-Size BAR support”, listed at offset 0x275, see here:

0x272F7 		Gray Out If {19 82}
0x272F9 			QuestionId: 0x262 equals value 0x1 {12 06 62 02 01 00}
0x272FF 			One Of: HD Audio Controller, VarStoreInfo (VarOffset/VarName): 0x273, VarStore: 0x1, QuestionId: 0xFB, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 70 0C 71 0C FB 00 01 00 73 02 10 10 00 01 00}
0x27310 				One Of Option: Disabled, Value (8 bit): 0x0 {09 07 04 00 00 00 00}
0x27317 				One Of Option: Enabled, Value (8 bit): 0x1 (default) {09 07 03 00 30 00 01}
0x2731E 			End One Of {29 02}
0x27320 			One Of: Above 4G Decoding, VarStoreInfo (VarOffset/VarName): 0x274, VarStore: 0x1, QuestionId: 0xFC, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 76 0C 77 0C FC 00 01 00 74 02 10 10 00 01 00}
0x27331 				Default: DefaultId: 0x0, Value (8 bit): 0x0 {5B 06 00 00 00 00}
0x27337 				One Of Option: Disabled, Value (8 bit): 0x0 (default MFG) {09 07 04 00 20 00 00}
0x2733E 				One Of Option: Enabled, Value (8 bit): 0x1 {09 07 03 00 00 00 01}
0x27345 			End One Of {29 02}
0x27347 			Suppress If {0A 82}
0x27349 				QuestionId: 0x267 equals value in list (0x8, 0x9) {14 8A 67 02 02 00 08 00 09 00}
0x27353 					Not {17 02}
0x27355 				End {29 02}
0x27357 				Gray Out If {19 82}
0x27359 					QuestionId: 0x262 equals value 0x1 {12 06 62 02 01 00}
0x2735F 					One Of: Re-Size BAR Support, VarStoreInfo (VarOffset/VarName): 0x275, VarStore: 0x1, QuestionId: 0x2A2D, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 B4 08 B5 08 2D 2A 01 00 75 02 14 10 00 01 00}
0x27370 						One Of Option: Disabled, Value (8 bit): 0x0 (default MFG) {09 07 04 00 20 00 00}
0x27377 						One Of Option: Auto, Value (8 bit): 0x1 {09 07 05 00 00 00 01}
0x2737E 						Default: DefaultId: 0x0, Value (8 bit): 0x0 {5B 06 00 00 00 00}
0x27384 						Default: DefaultId: 0x1, Value (8 bit): 0x0 {5B 06 01 00 00 00}
0x2738A 					End One Of {29 02}
0x2738C 				End If {29 02}
0x2738E 			End If {29 02}
0x27390 		End If {29 02}

Is this the right option ?

I have been struggling with this for days. Can I bypass the capsule if I buy the cheap SPI flash hardware ? I don’t like it, because I dislike thermal paste, but if this is what it takes …

But if my firmware does not match the signature, will my unverified UEFI still bring up the motherboard ?

Looks like GB are even too lazy to rename the feature to its proper naming convention on AMD boards, Re-Size BAR is the option you want but as I said you have a 2000 series CPU SAM/BAR is not supported on that series so enabling it would do nothing anyway. Try enabling Above 4G Decoding instead, it might give you a performance improvement but in short buying an intel GPU while having a 2000 series Ryzen was not a smart buying decision. You don’t need an SPI programmer to flash the firmware you just need to make a couple changes with a Hex editor to override the built-in check Q-Flash does, any changes you make to a firmware image there is inherent risk so you absolutely should not be making such changes without not knowing what you are doing so as to avoid bricking the motherboard.

I used the hex dump instructions from lordkag and now I was able to flash my modified UEFI image. Thank you.

But the ReBAR option is still not visible. I changed “Access” column in AMIBCP from “Default” to “USER”, but it looks it does not automatically enable the option. Is there anything else I can do ?

Some people say they got ReBAR working with a 2700X CPU:

https://twitter.com/CapFrameX/status/1339921701241536513/photo/1

Should I try to add the Resizable BAR DXE driver from here:

Thank you,
Timothy Madden

The Resizable BAR DXE driver worked as intended.

Still not as pretty as having the option from Gigabyte unlocked in UEFI, but it does the job.

So my Intel Arc GPU is not stuttering like crazy any more (I mean it still has micro-stutters left, but this is what I get with Intel Arc I suppose).

Just move the option above the suppress if function, simples. And again, you never needed to enable ReBAR, Above 4G Decoding does exactly the same thing - allows the CPU to have full access to the GPU memory in addressable space. If enabling 4G Decoding didn’t do much for you then that would be a GB issue, most likely where they broke the option.

Hello , been a couple years since I’ve been here, got my hands on a 7900 XTx and was wondering if adding PCIe gen 4 to the f63c bios on gigabyte would be possible, let me know if possible and about the donation required for having it done. Thanks in advance :+1:t2:

X470 gaming 7 wifi rev 1.0 with Ryzen 5800x

@Jman only certain boards can support Gen4 its not just a software thing. Some boards that could support it got a beta firmware but they were quite swiftly removed and the option ripped out again so if your board got a firmware supporting Gen4 it would need to be tracked down first and I’d mod that as AFAIK the Gen4 option isn’t something that can be just copy/pasted in it’s part of the AGESA itself.

1 Like