[Guide] How to flash a modded AMI UEFI BIOS

I am modifying the bios of the original motherboard. :slight_smile:
It works fine, but there is one problem.
Non-existent hardware appears in Device Manager.
It is a device called GDIX1001, and this board is a board that has converted the hardware originally used in a tablet PC into a mini PC. (The model of the board is unknown, but it says U35FL002)
I modified the ACPITable in bios to try to remove this.
The fix is using ACPICA and UEFITool and flashing with AFUWIN (I tried this, but an error occurred: 18 - error secure flash rom verify fail. So I dumped the entire BIOS, modified it with UEFITool, and flashed it with a ROM programmer.)

The result is like this:

  1. Something like a recovery tab and ROM Image update denied has appeared in the BIOS.
  2. Does not automatically boot into Windows. The BIOS menu appears first. Internal drive (EMMC) is gone. (= This problem was resolved by reformatting the eMMC and reinstalling the OS.) Other than that, USB or EFI Shell is possible in the BIOS. (Menu appears)
  3. Booting from BIOS is a bit slow.

How can this problem be solved? :0 (Or is it not editable?)

Welcome to the Win-RAID Forum!
Since you obviously had problems to get a modded AMI UEFI BIOS properly flashed, I have moved your post into this already existing thread. The Guide is within the first post.
By the way - the “device” named GDIX1001 is an ACPI one. You may find a driver [>here<].(ACPI\GDIX1001 download driver for Windows 10 x64 | DriverPack).
Good luck!
Dieter (alias Fernando)

1 Like

At least you can get rid of the following.

Just delete ReFlash dxe.

1 Like

Thank you for solving it. (Booting is still slow, but it doesn’t matter) :slight_smile:

I have a modern motherboard ASUS B760M-A D4 without flashback usb port.
I can’t use flashrom’s -p internal since it can’t detect any eeprom.
So wonder what my options are?

Is it Intel FPT tool or ch341? Looks like the board have 2 bios chips so which one should i flash?
Where can I find Intel FPT tool for alderlake/raptorlake mb’s? Do not seem to find any download links.


Can be mistaken but i can only identify a GigaDevice SPI ic

This model should use Intel ME v16, usually the tool reads/dumps, writing is another issue… to read and understand the operations:

Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (16+) - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

[GUIDE] [UPDATE] Usage of AMI’s AptioV UEFI Editor + FPT Flash Method - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

1 Like

Within the start post of this thread you can find 2 other options (AFUWIN and AISuite methods).

You obviously have missed >this< thread.
P.S.: MeatWare was quicker than me. I am sorry for haven’t seen his reply earlier.


Thx for info,
I was wrong on BIOS. Have read through the posts you linked to.

Do I understand correctly that I need the exact CSME version to work on BIOS region with fptw? So if MB has I need to find this version of CSME to use fptw tool to modify bios region? Or will any 16.x version work when only modifying bios? Only part I really do not get. = Major.Minor.Hotfix.Build

The tool needs to be the Major.Minor. version
This is the preferable general rule for all SKU’s.

Careful with ME tools, they don’t care for wrong choice of cmds/syntax given, they write what is told too… correct or incorrect data.
Do several backups of the full SPI and separate regions, for safe keeping and store MB original data.

Macronix - MX25L12872F (mxic.com.tw)

1 Like

Hello again,
had a look at the chip which you marked and it’s a MXIC 25li2872f. Also found a soic8 chip abit above to the right of ram slot and it’s a MXIC 25v5126f.

Don’t know which of them is for BIOS :slight_smile:

Wanted to make sure that I would be able to flashback using ch341 if software fails. Seems Asprogrammer has support for 25LI2873F which should work with 25LI2872F

I’m running an ASRock Z790 Nova and I’m trying to flash a modified bios to it. I’ve tried following the instructions for using Flashrom but I get an error of “no eeprom/flash detected” whenever I run it. Am I doing something wrong?

Maybe Flashrom cant identify (due to Outdated DB) such new mb and her SPI IC…
Have you at least identified it yourself?

EDIT: Dont know, maybe an CH341 SPI programmer or the SPI_TPM header, your mb is too new but you don’t seem to have enough knowledge of these things… do you?

What do you mean by identify? Is there anything else I can do here to flash this bios? I don’t have flashback (thanks for removing that, ASRock), scewin doesn’t work because of protected variables and instant flash doesn’t work for it.

I’m starting out in this space, just doing this for the sake of modifying bios to optimize my install for gaming and accessing hidden settings. SCEWIN had failed me because ASRock write protects runtime variables, I’m unable to just use instant flash, there’s no bios flashback, and I had the detection issue with flashrom running from a flash drive.

What were you saying regarding the SPI_TPM header? Is there some kind of method using that? I’m not at my house ATM but I’ll look for the bios chip and that when I get back

What did you expected??? Modern motherboards containing revised AMI Aptio V bios files and AMI Core bios security, prevents almost all bios mods (modified…) from being flashed by regular know/specific MB methods… welcome to mod world my friend…
Take a walk and read on the forum other users posts and you’ll find out that you’re not alone on this…

SPI_TPM header?
If even possible on this MB model…search…read, read a lot.

Could something like afuefi work
It shouldn’t, as its an AMI official flash tool, so…

Another method to try if you have any experience with the Intel ME tools package…and dont ask how, i dont have time for such background teaching:
[GUIDE] [UPDATE] Usage of AMI’s AptioV UEFI Editor + FPT Flash Method - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

This will only/can work if the access to bios regions is unlocked for writing:
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

Thats it, nothing more to add, good luck.

1 Like

Could something like afuefi work, or is that out of the question?

Edit: There is such a header, does it have any relevance to bios modding?

Ok, by this question… your a bit out of your league and don’t engage on this… we don’t want to see users with a death MB.

1 Like

That’s valid, I’ll probably steer clear of it and just see if there’s anything I can change via scewin and avoid modding and risking any kind of damage lol

Just for reference sake, chip is a Winbond 25Q256JVEQ

Datasheet W25Q256JV

I might actually try building the latest version of flashrom (1.3) on linux for DOS and trying to read again, since the newer version has some updates to it

1 Like

Has anyone else compiled a version of flashrom 1.3 for DOS? I’ve been trying to compile this thing for over an hour but I’m quickly reaching the limits of my linux knowledge lol


Since I don’t want to do anything stupid regarding the procedure for flashing the modified bios, I’m posting here for help.

I have an MSI Big Bang X-Power 2 motherboard.

I followed Fernando’s guide regarding adding the nvme module in bios.

So I have my bios modified with the same extension in .280 compared to the original.

To flash the modified bios if I understood correctly, I need to have a usb key formatted in fat32, which I copy and paste my modified bios onto the usb key (on the usb key there will only be the modified bios file) , I restart the PC, I enter the cm bios, I click on M-Flash, I click on “Select a file to update the BIOS”, I select my USB key, I select the modified bios which is on my USB key and finally I press enter.

Is the procedure good?

Thanking you in advance for your help.