[Guide] How to Flash a Modded BIOS on a ASUS Z97 Motherboard

As you all my already know, i am the creator of the “UEFI Download Tool” so i never miss a BIOS update that is released.
And when the update comes out there is only two choices, flash regular and accept that the modules are not fully up to date, Or mod the bios file and get all the latest modules, which is what most of you want to do probably.

At first when i tried to achieve the goal of modding my ASUS Z97-K BIOS and successfully flashing it, i was completely stuck.
Not anything anyone said worked at the time.

So i was thinking “Am i just screwed, this is it, they finally patched to where we can mod the bios without a SPI Flasher?”.
Well after 4 hours of trying to flash my Motherboard to the modded bios i successfully did it with ALL changes confirmed that they were made.

So here’s how i did it, you can do the first step of getting your BIOS file to mod it one of two ways, find the link to your motherboard yourself and proceed to download, unzip and all that manually.
Or if you have a motherboard with any of these manufacturers “ASUS, ASRock, MSI, Gigabyte, Dell, Alienware” you can use my “UEFI Download Tool” to easily grab your newest BIOS file with automatic extraction of the archive.

Downloading the BIOS File:


Output Folder:


Or if you prefer to do this all manually for me the link to my motherboard would be http://www.asus.com/us/Motherboards/Z97K…pDesk_Download/
And you can download.

Once you obtain the file in whatever method you prefer, you can begin modding it with “UEFI-BIOS-Updater” link to it [Tool Guide+News] “UEFI BIOS Updater” (UBU)

Once you add in the updates modules of your choice, we’ll begin the first step, in the UBU folder that you already have from modding the bios open up “UEFITool”, with your modded bios file and do the following below


Once this is done you’ll notice the file size is now 8,192 KB instead of before it was 8,194 KB, Once this is done you’re good to do with the file.
If you try and flash this in the BIOS regularly it will not work nor will AFU DOS normally either you will get secure flash error.

Next download AFU DOS from here http://www.mediafire.com/download/wzrws2io8cy6268/AFUDOS.EXE because this version has the command /GAN the latest version this command was removed because of we found out about it and we were not supposed to know.
Really stupid that they are trying to take away bios modding from us.
And make a DOS Flash drive, you can lookup on google how to do this there are tutorials.

Once you have your DOS drive put AFU DOS on it with your Modded bios file and give it a small name such as Z97Mod.rom
Make .bat file that contains the following text “AFUDOS Z97Mod.rom /GAN” and save as GAN.bat.

Restart and boot into the USB drive and load DOS, one there type GAN.bat and hit enter, make sure bios settings are at default before you do this to prevent any crash that may occur if you’re overclocked.
Wait for the process to complete and it should look like this


Then hit the power button to turn off the machine, then hit it again to turn the machine back on, and wait around 20 seconds and the screen should come on and say press F1 to enter setup, and if you updated your CPU Microcode in the bios file, in the ASUS Z97 BIOS you can view the microcode patch under CPU Settings Mine says 1C.

To further more completely verify the patches were made, go into windows and open AFU Win program included in the zip we downloaded to get AFU DOS, open it up and save your current BIOS, then open that file up with UBU and see if all changes are there if not there may be hope left, Before i did all of this i tried a technique someone said where you save your BIOS file like you just did to check it, and flash that one without any changes made after saving it, and it supposeably removes some lock, i idid this then tried my method. However i do not know if it matters to do that or not, it my way doesn’t work try to do that then repeat my method.

Thank you and i hope you all can now flash your modded ASUS Z97 BIOS, or any Z97 Motherboard completely.

1 Like

Thank you! This was perfect for me, I have an ASUS H97I-PLUS with an i7-5775C and needed to update the BIOS microcode.

ASUS has an initial Broadwell Microcode, but there is a critical bug with the 5775C and a few other Broadwell chips, fixed if the CPU microcode is updated to 0x12 or higher.
This was reported by intel as Errata BDD86/BDM101 in September 2015

The latest ASUS BIOS as of this posting only had microcode 0x0D, BIOS 2604.

In my case Office 2016 was causing BSOD on Windows 10, the computer was not usable.
Thanks to UBU1.40 I was able to modify the BIOS to 0x12 but it would not flash to the board.

Thanks to this post I used AFUDOS and the flash accepted!!
Office 2016 runs with no problem now :slight_smile:

We’ll see if/when ASUS decides to get their BIOS up to date.

Awesome you got your stuff working correctly now, and it is not very likely that ASUS will update any of the modules, so that sucks.
Took me forever to figure out how to flash my board so that’s why i wrote this tutorial so no one else will need to wonder how.

Doesn’t work on my Rampage IV Formula BIOS 5001. Even after flashing with /GAN, the firmware is unchanged. Checking the firmware still has the original modules. I need to try USB Flashback with a new flash drive (my current one does’t doesn’t seem to work for USB Flashback).

Not sure i just know it worked for me.

Thanks! All worked fine. I can’t understand how to save the bios. Current bios. Updated and modified. I need AFUDOS from where?

@serp202 :
Welcome at Win-RAID Forum!

You can get it >here< directly from AMI.
Dieter (alias Fernando)

You can get it >here< directly from AMI.

New Versions of AFUDOS block /GAN command can only use old one i have

EDIT by Fernando: Unneeded parts of the fully quoted text and blank lines removed (to save space)

Use this link http://www.mediafire.com/download/wzrws2io8cy6268/AFUDOS.EXE

is there a afuefix64 or afuwinx64 that suports /GAN (Aptio V)
Have done all i know of, but can’t get my tablet to boot Dos from USB

First, Thank you guys for all of this info, I’d have no chance at this if it weren’t for you guys. I know this thread is a bit dated now, but i am hoping you can help me.

I have an ASUS P877-v LX Motherboard with BIOS 2501 (latest available from ASUS)

I have purchased an intel NVMe SSD and a PCIe adatpter for it, in hopes to use it as my C:/ drive.

I have since found out that my mobo does not support NVMe outright, which is how I’ve ended up here.

I have followed the instructions on this post, and a few others on this site to download AFUDOS and use it to flash a modified “backup” of my current BIOS, with the “NvmExpressDxe_4.ffs” module inserted using MMtool, but to no avail.

I’ve even tried what the initial post said about flashing the unmodified backup from afuwin first, to “unlock” it, and then flashing the modified one. But I have not had any luck…

AFUDOS.exe modded.rom /GAN works, and appears to successfully flash, but when i reboot, BIOS takes a few seconds to come up, and i’m wondering if it isn’t reverting to the previous unmodified version somehow…

Any guidance for me?

Use this guide I wrote - [GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

If you have problems finding the BIOS Lock AND SMI Lock variables (Unlock both), let me know and I will get it for you, but guide is detailed so you should be able to find yourself easily.

Thank you for your reply!

I have began following the instructions at the link you’ve provided (great guide, by the way), but i have hit a snag. I’ve found the GUID of my setup module, and extracted it “AS-IS”. However, when i try to open it with the IFR extractor, the protocol remains a big red “UNKNOWN”. The file is a .sct extention, just like yours, and i have tried running the extractor in win7 compatability mode, with no change.

any ideas?

@shadowkrazee - You’re welcome, and thank you! Expand your Setup module, extract the PE32 module inside there, and if there is another subGUID with a bunch of 0000000’s at the end in there extract that too, one of those will give you the IFR output.
You can double click on UEIFTool search results if you used that to find BIOS Lock, It will take you right to the exact module to extract. I just checked your BIOS, it’s the one in bold above

I just updated the guide to hopefully make this more clear, thanks for pointing this out!


I’ve managed to get through the rest of “[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash” without any problems. ( thank you! )

However after changing the variables from efi shell ( I disabled bios_lock, smi_lock, bios_interface_lock, and GPIO_lock, since all were set to 0x1 ), fptw claims that it isn’t compatible with my board (P877-v LX) and trying to flash a “fresh” modded ROM with the nvmExpress file inserted using AFUDOS /GAN method is still not working. It claims that the flash was successful, but after rebooting and looking through a fresh “read” in UEFItool or MMtool, it does not include the nvmExpress file i added.

As far as i can find, there isn’t a better way to flash this board. Do you know of any other tools? the ASUS Bupdater is a joke, and probably wouldn’t do a modded.rom anyway.

I’m starting to get a little discouraged, but your help is greatly appreciated.

@shadowkrazee - You’re welcome, and happy to see you made it through the guide, thanks!
Did you install Intel ME drivers, those are required for windows FPTw but not for DOS. You need the 11.0 drivers

Also, be sure you have the correct version of FPT from Intel ME System Tools package that matches your current ME FW version, you can get all versions here in section C2
You need V8 package - Intel Management Engine: Drivers, Firmware & System Tools

Don’t get discouraged, you will get it! Be sure you make that FPT backup first, in case you need to edit in your details (If .cap BIOS, you will need to extract the body from the capsule file using UEFITool to use with FPT, you cannot use .cap file)
And, as mentioned in the guide, to save time fixing things later, it’s best to make a -bios region dump with FPT and then modify that, instead of flashing in a modified stock BIOS file.
So once you get FPTw working for you, make that -bios -d dump and redo your edits, that way you don’t have to mess with putting your system specifics back in later. If you flash stock modified BIOS you can loose UUID, Serial, LAN MAC ID etc

If you see any size errors in FPT, stop and post image of the command entered and error showing all on same screen, do no proceed

@Lost_N_BIOS – I DID IT!

Using flashrom method described in posts 7 & 9 here:


I used the flashrom version from his mediafire link, since the version sourced elsewhere gave me errors about not finding flash chip.

Thank you for your guide on unlocking my bios, It was a great help.

I’m off to enjoy my new NVMe SSD :smiley:

@shadowkrazee - good you were able to find a working method!

@shadowkrazee Probably too late to help you, so I’m posting this in case others have the same problem.

I saw the same problems as you this week with my Asus M5A99X Evo R2.0 when trying to flash modded BIOS. Various methods all failed to flash the BIOS (or maybe flashed to BIOS-2, without making it active).

Solution for me was:

1. Rename the modded BIOS file exactly as per the Asus User Manual for my mobo (in my case, “99XEVOR2.CAP”).
2. Use the USB Flashback method.

This successsfully flashed the BIOS with the NVME mod and made it the active BIOS. I now boot from an M.2 device.

USB Flashaback means:

- put USB stick holding BIOS image file in the exact USB slot specified by Asus User Manual
- find the BIOS flashback button on the MoBo. Push and hold for a ew seconds until light starts flashing.

For this particular problem, I did not need to use the Grub fix guide mentioned earlier in this thread by @Lost_N_BIOS.

A post was merged into an existing topic: [Release] Resizable BAR DXE driver