[Guide] Integration of Intels AHCI/RAID drivers into a Windows XP/W2k3/W2k CD

@fraz :
Users, who want to follow my guide, should have read the chapter "Pre-conditions for s successful integration of the Intel AHCI/RAID drivers" before they start with their work and not thereafter.
To make it as easy as possible to find the matching Controller, I have added the DeviceID to the listed Controller names.

Hi, it went badly and would not boot after install, so, I’ve booted Windows 10 and found out the hardware ID is 8C82 and this has been included in the next attempt along with the IA driver from the MSI CD - Back soon but I’m not that confident it will work.

What I have noticed is the speed of the install has increased by quite a lot so something must have been working (more quickly)__

I’ve had success with XP32 on MSI Z97-G43 - After install it boots in AHCI mode - with SP3 slipstreamed into the nLite build with IAstor from motherboard CD and the text mode driver 8C82. The 64 bit XP has not done the same and SP2 was included.

On 32 bit the DriverPack worked up to a point.
In device manager it can be seen “Fernando 8C82 controller”.
The HDD’s cannot be seen in disk explorer but some of them appear in the device manager - The F5 F7 trick did not do anything on x32 install - I’ll read a bit more to see if I can sort some more out.

btw-I’ve ordered an IDE DVD optical drive with IDE cable and PCI-e x1 card with IDE on to see if X64 can be installed
For the HD4600 the Intel graphics GT2 did install and show in device manager but the computer crashed on boot after re-start

OK- after installing the universal drivers and IRST package the APP opens in XP32 and the system disk is shown as “external system disk” - This is progress for X32 with IRST icon in the taskbar!!!
OK, now I’ve understood a little more - 8C82 is for 8 series & 9C82 is for 9 series - Z87 was the same as Z97 (marketing)
It would be good to install XP 64 in the same way - Is this possible? - I understand that XP64 is harder than X32 -

ok more info later but I’ve imaged to usb external and restored to bootable xp32 & also now have MBR formatted disk restoring an image to sata ssd on sata connection AHCI to bootable OS with Macrium Reflect.
TIP-SSD read write speed is better if SSD is initialized / formatted on WIN 7 or 10 (or 8) - this is for extra SSD (not system disk)__on another sata port
OK this image has been restored - and is working - on XP32 SP3 with Macrium Reflect 7.xx.xx etc…

OK, I’ve got the X32 image now so I’m sure the rest can be worked with to polish the install. Right now I’m trying the x64 again with the 8C82 controller - I see there is also a 9C82 controller - (8 series/9 series)__Z87__Z97 for example.
If the x64 does not boot after install is there anything else that can be done?
Like mentioned I’ve got IDE DVD drive & PCI-e x1 card with IDE connector arriving shortly? - Are there any specific controller cards that are best? so to go from DVD >>> PCI-e slot >>> install >>> onto SATA via PCB of the motherboard? -

EDIT by Fernando: The last 3 posts have been merged by me (to save space within this voluminous thread)

OK Fernando I understand - It seems there is successful install of XP32 with 8C82 controller - The only item in device manager with a yellow “exclamation” is the display adapter for the HD4600 which won’t be supported. I’ve checked another board I have, Asus H81 (Intel 1150)__which has the 8C02 controller ! - So thanks to this whole forum I’ve learned about this - Thanks

I might as well make a thread for this because it is good !!! - I don’t believe it! - Windows XP Professional X64 has installed on an AsRock X99 OC Formula 3.1 motherboard - This is the start of a long install because they take ages !!! - 8D02 for the SATA AHCI controller (text mode)_and V14 of the F6 floppy - Time for a donation maybe - !

The MSM IRST has also been very useful for Vista 64 (off topic sorry)_but this is good news

OK, more good news Fernando and all others trying this out! - I hope you received a donation today - The efforts paid off and due to your work this has enabled this to happen but its not been easy. I found Snappy Driver Update package - which is a big download but has installed all devices on X99 motherboard apart from the Intel I218V LAN. So it is possible to cover all bases for the motherboard devices.

Please suggest how it may be possible to get Intel I218V LAN installed on XP64 = BTW - I had to use the non x64 version because it was the only one that loaded - When you have some time please respond here because it is very good what has happened with this install = Thank you.

Although this question doesn’t belong to the topic of this thread, I found >this<. Maybe it will help you.

OK thank you Fernando I will take a look - And I won’t argue with you about it not belonging to this thread.

I’ve tried really hard - And there has been a troublesome MSI Z97-G43 motherboard that now has XP64 installed - The story is I used the RST floppy driver from OC F 3.1 (X99)_version__14.8.0.1042 - All the others did not work and there was a BSOD just before the first boot of the OS. - Now this has just right now installed XP PRO X64 -


There does not seem to be much activity here! - Maybe some people don’t like XP anymore! - There is now success #3 - There is a motherboard by the name of X79-T - A cheap board from China (but not that cheap)__which is not a true X79 chipset but a Q77 (I think)__the SATA AHCI ID is 1E02 with SATA floppy IRST version - It took me 5 attempts!

@fraz :
The Intel SATA AHCI Controllers’s DeviceID DEV_1E02 indicates, that the mainboard has an Intel 7-Series or C216 Chipset.

@Fernando :
OK, but the socket on the board is LGA_2011 - Which means the CPU’s are Sandy Bridge & Ivy Bridge compatible although I’ve not tried Ivy yet. So 3930 K etc… and Xeon E5 V0__or__V2. The BIOS is American Mega Trends and I don’t know how to update it but am sort of half way there.
And it now has XP64 installed on it ! - I plan to do a Z77 & X79 as well.

At some point an AMD AM3+ install too! - Is this hard to do? - I’ll read the tutorials again but is AMD AM3+ / AMD FM2+ possible?

@fraz :
This thread is only about Intel chipset systems. If you want to get XP installed onto an AMD chipset system, you should post your requests either into >this< or another matching thread of >this< Sub-Forum.


Well I’m looking at another board, this time a true 7 Series - Asus Z77 and all is good on 1E02 again apart from a PCI device in the device manager ? - Will this be USB 3? - or chipset related? - Thanks

EDIT - snappy driver sata 106 wrecked the install (I have an image_!_)__BUT THE asus asmedia sata 106 removed the issue! - The read write performance is a little slow 403/376 MB/s - Any comments. Native chipset read write with SSD is 560/514 MB/s.
I tried a VANTECH PCI-e card with sata 6g (Marvell)_and read write was around 538/503 - So good but ASMEDIA sata x2 ports a bit slow but they can be used!

EDIT again - I’ve read online that AsMedia & Marvell controllers on motherboards are slower so a 6 G rated sata port with one of these controllers will read around 400 MB/s

OK, I’ve checked out one of the X79 boards = 1E02 & IRST floppy = (the same as for 7 series Z77)___just thought I’d share this info to help others find the correct floppy driver for their installs - Thanks

@fraz :
Your post #955 is completely off-topic and your post #956 doesn’t contain any useful information. The Intel RST driver v11.2.0.1006 is better and newer than the v11.1.0.1006 one.

Hello Fernando,

If works then I agree it is better because it is a newer driver - From the point of view of a successful install of XP64 the information of RST floppy is useful !!! - RST drivers from the driver CD/DVD do not always work or the XP installer informs they are corrupted.

One of my installs took 5 attempts to find a driver that works - Thanks to you and your forum posts it has now been possible to install on different platforms Z97 / X99 / Z77 / X79 which is very good news so I post here in case someone cannot get a successful install as it is quite difficult to find a driver that works.

How many platforms have you installed XP64 onto Fernando? - Thanks

I need some help guys. I have an ASRock Rack X299 WS/IPMI with i9-9990XE (yes, the beast), and I cant get XP installed on it. Before anyone starts asking why, and other questions, this is a requirement. I am stuck at 07b error code (inaccessible boot device). I integrated I. Intel AHCI/RAID drivers from the "classical" Intel RST Series driver using nLite but still get the error. The chipset for the motherboard is X299 and am not sure if I am using the right drivers.

Any help would be much appreciated as I have now wasted 2 days trying to get this up and running.


@majkara :
Welcome to the Win-RAID Forum!
I have moved your post into this much better matching thread. There is no need for me to re-customize the Intel AHCI driver v1.2.0.1006, because the already existing mod+signed driver supports all Intel AHCI Controllers from ESB2/ICH7 up (inclusive the one of your X299 chipset system).
Please read the start post of this thread carefully and integrate the "Universal 32bit Intel RST textmode driver v11.2.0.1006 mod+signed by me (done at 01/16/2020)" into the XP image by checking just the Intel SATA AHCI Controller with the correct DeviceID.
Then you will succeed.
Good luck!
Dieter (alias Fernando)

Hello there. I’m trying to integrate the AHCI/SATA drivers for my ICH8 chipset and install Windows XP on my Dell Optiplex 745.

Let me just start by saying that I’m amazed by how far I can backtrack your posts in other forums as well on this single issue.

So, when I try to slipstream the correct drivers, I cannot found a matching one for my hardware. This is inside the device manager on Windows 7:


I believe that the one used is the 2820, since the motherboard have 4 sata ports (0, 1, 4 e 5), and bios “recognizes” 2 e 3, but say that they are not present.

Can you point me in the right direction?

@minervamcdonalds According to the PCI ID repository (pci.ids) the DEV_2820 and DEV_2825 controllers are named “82801H (ICH8 Family) 4 port SATA Controller [IDE mode]” resp. " 82801HR/HO/HH (ICH8R/DO/DH) 2 port SATA Controller [IDE mode]" Notice that both of these controllers are set to IDE mode, so you have to set the mode to AHCI or Normal or whatever it might be called (i’ll take a wild guess based on the manual for the optiplex pc that you have “SATA Operation” currently set to “Legacy”).

@minervamcdonalds :
Welcome to the Win-RAID Forum!
IntiMD is right - your on-board Intel SATA Controller ius currently running in IDE mode. If you don’t want to change this setting, you should not try to integrate any Intel AHCI/RAID driver. Otherwise you may get a BSOD during the OS installation.
My guide is only valid for the integration of an Intel AHCI or RAID driver, but this requires, that the on-board Intel SATA Controller is running in “AHCI” or “RAID” mode. As long as the Intel SATA Controller has been set to “IDE”, it can only be managed by the MS IDE driver named PCIIDE.SYS, which is part of the Windows OS. In this case the integration of any Intel AHC or RAID driver into the XP image would be a big mistake.
Dieter (alias Fernando)