[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)

Hi there,
I have the following question about the CH341A programmer.
If I attach the SOIC8 clip (adapter) to the BIOS chip (soldered chip), can a short circuit occur, e.g. if the clip is not seated correctly, is crooked and PIN 8 and 7 are connected?
I know the red cable at PIN 1.
Thanks very much.

Hi,
does anyone have experience with the SOIC8 clip from the CH341A?
I have a soldered chip and have to use the SOIC8 clip. I bought a loose chip to test it out. However, the PINs of the chip are bent by the SOIC8 clip. The SOIC8 clip is very strong. My question: If I now attach the SOIC8 clip to the motherboard, can the PINs bend or even tear out of the soldered connection?

Gonna Try it

msi b550 MX25U25673G

using latest Asprogrammer, using the search it will list the chip. other older software wont
reading it with battery off it only gives me FFFF and with the battery in I get 0000

where do I go from here? anyone

Brilliant tutorial, thank you for this.

I’m in desperate need for help for someone to guide me how to do it properly and not to fry the chip and not to flash it and loose UUID or motherboard serial.

I’m completely noob and doing this for the first time in my life.

Product detail:
MSI MPG Z490 GAMING CARBON WIFI Mainboard Sockel 1200 (7C73-001R)

Description:
My motherboard stop working. When I turn on the PC it’s just stuck in POST and I can’t get in to BIOS.
I updated my motherboard with bios release asked me to do from official MSI Center (Win10).
After updating the bios (process went all the way to 100%), the PC will not start at all. I can’t even get in to the bios.

Date of failed flashing: DEC/18/2021
Affected board model: MPG Z490 GAMING CARBON WIFI (7C73-001R) V1.A BIOS Release
Flashing method used: MSI Center
Attempted update to BIOS version: from 7C73v19 to 7C73v1A
Result: Stuck at EZ Debug LED “CPU” after update.
BIOS Chip: MACRONIX MX25L25673GM2I-08G (MX25L25673G)

Monitor Black screen
Try reset on JBAT1 - no success.
Try removing battery and wait for 1 hour - no success.

QUESTION:
Do I need to send someone “current state - BIOS backup” for get info about UUID, serial, tag etc. and modify stock BIOS 7C73v1A and than to flash the (MX25L25673G)…???

Thanks in advance

If not backup/dump of SPI, then upon the use of an SPI flasher with a file with no original data, it will be lost. (Some original data in motherboard labels but not entirely.)
So yes, the rule is always a backup of the current SPI bios on the system.
I recommend keep in a eye in the MSI forums about the Z490 issue… the same issue ur facing, but u already know this…

Thank you for the excellent guide!

I got the programmer working & created a backup (uhh, any idea where that might be on my system? :upside_down_face: I can’t find it. Does it save it back to the BIOS chip? :thinking:).

However, when I try to actually flash a file, I get the error, “Image size doesn’t match the flash chip’s size.” I’m trying to flash BIOS downloaded from OEM site, specifcially, Intel Microcode V 1.49

Lost_N_Bios previously helped me identify the chip as W25Q64JV

I’m attaching Windows Sys Info and HWInfo logs too.

Related: I can also try this in Windows, though Linux is so much cleaner. If I go the Windows route, where can I find the latest version of the CH314a programmer software? It’s kind of a wasteland out there trying to track it down without getting malwared to death

Acer Aspire e576g-5762 sys info.zip (208.6 KB)

Dont understand, the error was on a mod file/updated mcode flash or the original and last bios version 1.49?
Flash a mod file bios version, errors is normal as the OEM Acer/InsideH2O system has its own protection against flashing a modified bio files…
Explain yourself better on what your trying to accomplish, since the report shared is based on a working system, using the last version of the bios for that model by the OEM… then maybe users can help you a little better.

The Acer bios files extracted from the update file are not complete bios image for SPI programming, they are just partial update bios files, no ME FW image seems to be attached. Using these files on an SPI programmer will result in a bricked machine.
And never a EXE from the OEM is to be used in any SPI Programmer, the exe is an win_x86x64 app…seems that you need to review your post and help provided back in Sep 2020, by Lost…

EDIT: Yes the Acer bios file is an executable on Windows OS enviroment… most of modern bios update are.
Still dont understand your mess… most bios on laptop will not show advanced options in their gui, the OME locks this, thats way people ask for a mod…if possible on that model/bios version, several locks prevent the use of modified bios files, so if ur assumption of corrupted bios is this, your’re wrong, theres nothing wrong with it, its OEM method.
The txt attached bios dont show nothing corrupted, it has the latest bios and ME in normal state.
I didnt check any bios and dont have time for it or even look for others mess.

[quote=“electricSNICK, post:292, topic:33041”]
Thanks for the reply.

Going back to the top of the thread, I followed @_haru’s guide and got to the last step:
sudo flashrom --programmer ch341a_spi -w

That’s when I get this error:

As you noted – the BIOS (sys info) I sent you are corrupt. The machine (Acer Aspire e576) boots, but no options are available from the BIOS screen.

So, yes, I’m trying to fix that.

I found this, it seems related but, honestly, it’s beyond my technical ability to troubleshoot as suggested:
https://flashrom.flashrom.narkive.com/74qFhzRd/image-size-doesn-t-match-the-flash-chip-s-size

PS: any idea where I can get a safe download of CH314a programmer software?
PPS: a link to the BIOS file that I used to try and flash chip

Quick update, I’ve been advised

"You’ll need to either execute the .exe on a compatible system, or figure out what tool can extract data out of the .exe

ZAA_149.exe: MS-DOS executable, COFF for MS-DOS, DJGPP go32 DOS extender

weird, would have expected something more for Windows

Find your backup or do another one before writing anything to the chip. Post or attach the backup, you’ll need parts of it to cerate a complete firmware image together with a (stock) bios region.

All mentioned tries to write “something” to the chip would’ve bricked your pc.

The Acer ‘exe’ can easily unpacked with 7-zip, but it contains 4 different bios regions (still no complete firmware image!!).

Backup.bin attached – initially I extracted this with flashrom but, now, I can’t recognize the BIOS chip using that.

I’ve ordered a replacement chip and may be to the point where I need to test and program that with the chip module and, then, try to desolder and replace the old chip with the newly formatted one

I had no luck using the Windows tools – neither of the software readers I tried recognized the chip (AsProgrammer, Releases · nofeletru/UsbAsp-flash · GitHub or CH341 programmer, Newest CH341A USB Programmer Software Free DownloadAuto Repair Technician Home)

backup.zip (5.3 MB)

That seems to be a valid backup, thank you. What’s the fault with this firmware- there are some posts of you 2 years ago, but I won’t read them all since this might no longer be the problem.

Look into the file with UEFIToolNE, you’ll recognize the structure and the different regions.

Acer offers just the bios region, open the acer- file in 7-zip, extract the exe, open the exe again in 7 zip, you’ll see 4 files og type “ZAA?.fd” Searching for ZAA in your backup would tell you that it’s ZAAR that you need. But the file in the Acer archive still has the flash program in the beginning and end. So you’d have to cut 0xDE8F0 in the beginning and 0xD980 in the end from ZAAR_multi.fd to get the bios region out of it.

Machine specific data in the start of bios region- 0x218000, WIndows OEM Lic 0x21F000.

Static areas of bios region are identical to stock bios, if there’s a fault it might be in NVRAM 0x540000 to 0x574000

What is it you’re trying to achieve?