Hard-brick and Failed Modding the Asrock H87Pro 4 BIOS

I plan to mod the BIOS of Asrock H87Pro 4 BIOS to add NVMe SSD booting support.
1) I downloaded the official 2.20 BIOS (instant flash format) from the official website.
2) Decapsuled the cap file and saved as rom using UEFITool,
3) Following the instruction and insert the NVMe modules using UEFITool.
4) Then save to a FAT32 formatted USB drive.
5) Then tried to update via Asrock Instant Flash.
But Instant Flash cannot find the file. Tried several USB drive and different USB ports.
6) I tried FPTw v12 and v11 (both 32bit and 64 bit) to backup the BIOS but failed to start (Forgot to take screenshot, something like DLL missing)
7) Tried AFUWin GUI for Aptio 4 to backup the BIOS, it gives a 4M file only. Then tried to load the mod BIOS (8M) but it gives garbage ROM ID. So I think something goes wrong in the modded BIOS and stop.
8) I am thinking the existing BIOS in the motherboard may be too old (1.60), so I downloaded the official 2.20 Windows version
and update under Windows 7 64 bits first.
9) The system reboot and stuck at the boot logo of Asrock (Wait for 10 minutes but not showing any sign of flashing/updating)
10) Reboot again and it gives blank screen
11) Clear CMOS but no help

I think I may hard-brick the motherboard, I will order a CH341A flash programmer.

Questions in mind:
I guess the 4M backup is incomplete
Should I flash the decapsuled ROM or original CAP?
Will I lost the MAC or other info?

Thanks genius

@damon_chan - File may need to be named as stock file and extension for flashing within BIOS via Instant Flash, but not always.

You should never flash stock BIOS with FPT, only dump BIOS region with FPT, modify that, then flash that back with FPT. Otherwise you can loose your serial and UUID if included in BIOS, and depending on how you flash with FPT you can loose your LAN MAC ID too (so no Ethernet)
For your system, you need to use FPT from

AFU never suggested on a system that you can flash mod BIOS from within BIOS (such as Asrock) and never suggested when you have Intel CPU thus you can use FPT instead.

So, sounds like you bricked the system with stock BIOS 1.60 >> To >> 2.20 Flash, correct? If yes, nothing you can do now, except slow way down (ahead of once you get it going again), order recovery tools and wait for them to arrive
Then slow way way down once they arrive, so you don’t loose your serial, UUID, MAC ID etc by erasing the BIOS contents before someone confirms for you that your dumped BIOS is valid and proper so details can be recovered from it.
I repeat again, once you get recovery tools, DO NOT try to erase or write to the chip until someone has confirmed your backups made are valid and OK to proceed.

Yes, you will need CH341A + U Type Flat Chip IC extractor - https://www.ebay.com/itm/123167465408
Clear CMOS isn’t going to help

4MB BIOS backup is probably good, keep this safe in case you accidentally erase chip getting in a hurry
This is BIOS region only backup, it’s proper. Actually, it should have been 3MB, I’d have to see it to tell you what else is there other than the main BIOS region (maybe just padding)

Do not flash/program anything stock. Wait for help once you tools arrive and you’ve made a backup.
Or yes, to your last question ^^

As for your original Instant flash issue, this must have been either due to one of the following.
BIOS was not in root of USB (should not be in any folders, just on root of USB)
BIOS did not have stock name.extension (H87Pro42.20) - This not always necessary, but best to just do it anyway to save time in case it is needed
USB Was not formatted to FAT32, or USB was too new/too large etc. Some USB may not be compatible. Also, always use USB 2.0 port if there is 3.0 etc, and if possible (if there is a port there), use the USB Port under LAN block.
BIOS was broken/corrupted/Bad mod. This less likely, Instant Flash would still see broken BIOS, and hopefully tell you something is bad about it (but that may not always happen)

Thanks for the information.
The modded BIOS file is named as H87Pro42.20 and placed in the root of a 32GB FAT32 formatted USB 2.0 drive. Tried both USB 2.0 and 3.0 ports when trying instant flash. I can’t remember if I tried the port under LAN port. Maybe it works for capsuled ROM only? or I should try an old 1GB drive next time.
AFUWin is the only tools that works on my Windows 7 64 sadly. Not sure why FPTw doesn’t even run.
Yes, I brick it when upgrading from 1.6 -> 2.2 using official Asrock windows flasher
The 4M Backup seems having BIOS region only but not Descriptor, GbE and ME region.
My plan is
1) Pull out the BIOS chip
2) Backup using CH341A flash programmer (FPBackup.BIN)
3) Try opening with UEFITool and check if it looks intact (At least the first 4M)
4) Append the last AFU Backup file to the first 4M of FPBackup.BIN
5) Burn to the chip

The MAC address is stored at 1000h. For UUID and serial, I am not sure their offsets. Correct me if I am wrong, I guess they are not essential.

32GB USB may be the issue, smaller/cheap is often best for BIOS update (128MB-2GB). Sometimes this isn’t an issue, but to avoid hassles always best to start with this.
On the filename.extension, do you have file extensions turned on, so you can see .txt at end of any text file? If yes, good. If not, then file name may be H87Pro42.20.20 if you renamed it. Anyway, I don’t think this is much of an issue on Asrock, probably more-so the large new USB
No, you have to remove the capsule for flashing a mod BIOS, so it’s not that.

FPT works, you have to have the right version as I mentioned, and you must run it from Admin Command prompt.
This is normal about the AFU backup, keep that file handy.

1-3 OK, send me the file. 4-5 not OK, it will need done in a certain way due to file size is not exact because of the way AFU dumps it (actual BIOS region is only 3MB)
Yes, MAC on a full 8MB BIOS is at 1000h, and sometimes at 2000h (copy). This is GbE region of the BIOS.

UUID/Serial is not essential, and may or may not be in your BIOS, sometimes Asrock does not use. I’d have to see a copy and let you know where it’s at.
These are essential for RMA only usually, but sometimes windows activation is tied to these too.

Some updates

Tried clear CMOS again, the system boots again. But still stay at v1.6
Tried more different USB sticks but still cannot update the BIOS to latest v2.2
Maybe god don’t like me to update it, so I backup the existing BIOS. Tried different version of FPTw, finally 9.x works.
Since the backuped v1.6 BIOS does not have enough free space to insert the full NVMe module, inserted the tiny version instead.
Flash with FPTw
System boot and enjoy the speed gain by NVMe SSD

You guys rock!


Here is my mods


@damon_chan - good you finally got it, yes, you have to use FPT version that matches your ME FW Major version (ie 9.1 >> V9, 10.2 >> V10 etc)
No one else should use your FPT Dump, please edit that link out.

You can’t update BIOS to 2.2 using stock (H87Pro42.20) file As-is and Instant Flash? If not, then maybe your USB are just not compatible, or 1.6 >> 2.2 requires some BIOS in between, or need of Other Asrock official method due to Instant Flash update between those two BIOS versions
If that was the case, I’d expect to see some kind of warning/message about this on a BIOS between 1.6 and 2.2. So, I checked just now, and there is a similar message! At BIOS 2.10 >> Update Instant Flash << In these instances usually you can’t update via Instant Flash if Instant Flash is being updated!
So, that is why thre is DOS and windows update packages for 2.2, you could try both of those, surely one will work! Then after you are on 2.2 BIOS, redo your FPT dump, edit, reflash via FPT.

And, maybe in 2.2 FPT dump you can insert normal full size NVME, I was able to in stock BIOS so should be OK in your 2.2 FPT dump too (there is more free space in that volume in 2.2 BIOS vs 1.6BIOS)