[HELP] Attempted mod, hard bricked Samsung NT750XBV-G517A


I attempted to unlock some menus for the Samsung NT750XBV-G517A laptop.

I flashed my attempted version via the CH341A programmer, which did not unlock new
menus, but booted just fine. I then flashed another attempt, which bricked the system - no POST. (it still charges just fine though.)

I then tried to flash my unmodded backups, which led to the same results. Even erasing the chip and starting leads the same results.

Reading back the BIOS chip after flashing results in the exact same file that was flashed, so that seems to be OK.

There seems to be no official bios file and no other dumps out there.
At this point I’m willing to flash anything. :joy:

The backups were made with fptw -d and another made with the CH341A+AsProgrammer. (I verified the integrity by making 2 reads and comparing them).
I’ve also made a separate fptw -bios -d region-only backup a longer time ago.



There’s nothing dramatically wrong with the dumps you presented. Of course one can’t compare them to the stock bios.

Do you have a bios code? Older Samsungs had a bios code together with bios version to recognize them, like AAY in this example:

In your case:
Take the old bios region, combine it with FD and ME, empty NVRAM and clean ME according to

Clear CMOS before restarting, expect a longer boot process and several reboots.

Seems You have a software tpm in ME firmware, that might be a possible reason? If you want to go stepwise:

  • Take a complete image and just clean ME
    If that doesnt work
  • combine the earlier dumped bios region with cleaned ME/FD region
    If that still doesnt work
  • take the firmware of the last try and empty NVRAM (might be that you miss some machine specific data)

Good luck!

Thanks for your guidance.

Unfortunately, I wasn’t able to get the bios version, but I did find a picture of the bios screen online.

BIOS Version: P00RFF

Following the guide, I cleaned the ME of both the fptw and ch341 versions via FIT, version (only EXTR available).

So I tried cleaning with a lower and higher version with a RGN available, e.g.,

Perhaps Samsung included some hardware-level anti tampering feature? This exact scenario happened to another model of a Samsung laptop. Modding a tongfang and a very old Samsung laptop worked just fine.
I think I’ve learned my (very expensive) lesson :rofl:

Also, could you point me to a guide on clearing NVRAM and bios combining?

Thanks again.

This gives you the filename:

Put it in here:

It’s normally unpacking into the temp folder, at least it was for older models. 'Im traveling now, no VMs or redundancy and I don’t want Samsungs software trying anything fancy, especially since this is a Samsung device, too.
(If I remember right, I had to remove ‘delete’ rights from the folder Samsung used?)

Serial, … are here:

Clean ME, empty NVRAM:
nv12_me.zip (7.4 MB)

Thanks for your time.

I flashed the cleaned file which didn’t work.

I then extracted the .cap file from the installer and put it in the cleaned & original file. Those didn’t work either.

Surely I’ve messed something up right before bricking it. Either way, I’m never touching a Samsung bios again.

The laptop’s going to be harvested for some useful stuff and thrown out. :upside_down_face:

Here’s the extracted .cap file for anyone who might need it.
P03RFF.zip (5.7 MB)