Help bios W25Q80BV error verification using CH341A Programmer

this bios came from emaxx motherboard emaxx emx mcp61d3 icafe v2.0. I have 3 motherboard with the same model. the other one I tried to update the bios. because the motherboard sometimes wont boot. the problem is when I verify the bios there is an error “chip main memory with the contents are in disagreement”. I tried different version of AsProgrammer from v1.41 up to v2.1.0.13 and CH341A programmer v1.18 up to v1.34 but all same result error verification. please help almost 1 week I tried to resolve this issue. thanks in advance!


Theres much more soft for this, besides ASp or CH341A sof one will work

[Guide] Using CH341A-based programmer to flash SPI EEPROM - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!) - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

[GUIDE] Flash BIOS with CH341A programmer - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

1 Like

thanks a lot, already tried different version but same problem. but I never tried on 1.8v. because I dont have that module.

even in EZP2019+ v2.0 Programmer has an error on verify.

Here is the two bios. the first one is the original and the 2nd is read after writing and verify.
original: EN61D321.ROM - Google Drive

error verify: ERROR_EN61D321.bin - Google Drive

Never tried with 1.8v module? My friend the SPI is 1.8v range or 3.6v range, there is no tryouts on this.
The socked SOIC spi in question is a 3.6v (2.5-3.6 range) and thats it.
Now the SOIC package on this board (just looking in web images) is really not socked but soldered, try with CMOS battery ON or OFF (the most common).
Is it really an SPI corruption… those AMD generation boards had a lot of VRM/NVidia PCH issues .

1 Like

it is socket
is it possible the bios chip is the problem or corrupted? but how do I repair the chip ic corrupted? thanks in advance!

The image i found is SOIC but soldered, but was a quick web search…

So even more easy and trouble free if your’s socked.
If the SPI (physical) is bad it cannot be fixed get a new one because the operation read/write on it will always fail .
The only thing it can be fixed is the FW image on it…with a programmer as you’re doing.
Some SPIs can be tricky and still appears to be ok…
But you have 3 board with it… you have a wide margin to work with.

EDIT: I just opened your original file, this is old AMI8 bios…try older versions of programming soft.

1 Like

thanks a lot sir. maybe the bios chip was damage that is why when I write rom file it cannot write same as the origin, thanks a lot!

Did you ever compare the two files? If I do that in HxD these files are a 100 % identical?

1 Like

Sorry I uploaded wrong file, I reupload the bin file came from the read data. and edited the link.

Just the last 64 kb- did you ever run a blank check after erasing the chip?

1 Like

Yes, I always did that when I erase the data then blank check. I tried many different version and software of CH341A and also the EZP2019+ Programmer but same result, all the writing data are not match on address 0x000f002.

Same problem, whatever software my winbond 25q128fv reports error location 81 on verify… so suspect its bad… But real problems sourcing a DIP 8 winbond 25q128fv… can I use different SPI chips? Anyone care to tell me which are cheap and plentiful I could use, please? Thankfully DIP 8 so socketted but I can’t find DIP 8 winbond 25q128fv anymore

I wonder, always had problems with this type of chip with the CH341 software 1.29 (and 1.34?), but asprogrammer 1.4 worked just fine for me?
I think other chips should work well, too. Just compare the datasheet and try?
MX25L12833F is mentioned as comparable in this list, so if you go backwards and search for all the chips MX25L12833F is comparable to, you should find some candidates…

I got it sorted… I couldnt find (until this thread) anyone (it was you!) who said you need to erase before writing… did that and bingo, it worked. So now my Z170 motherboard supports CoffeeLake processors :slight_smile: