[HELP] Bricked Alienware 15 R3 after bios rollback

Hello. I’m afraid this forum is probably my only hope at bringing back my AW 15 R3.

I had been having some issues with my laptop, Im not sure if its related but it started with my speakers failing (I suspect the amplifier chip as the mic still functioned).

I tried to update the bios to fix it however when the update finished the laptop did not reboot. It hung at 100% writing EC, I waited about half an hour and powered off the computer.

When I tried to power it back on, the power led would light up but the screen wouldnt come on or it would flash the 2-1 sequence for cpu failure. I could try over and over and eventually it would boot normally, sometimes after 2 or 3 tries, other times it’d take 20 or more attempts to get it to boot, but eventually it would and the system would work normally (except for no sound) until the next reboot.

So I tried rolling back the BIOS from 1.8.0 back to 1.7.0, which also did not reboot after the bios update, I manually rebooted after some time and it was basically the same.

A couple of days ago 1.9.0 was released, and I updated from 1.7.0 to 1.9.0, again it did not reboot as it says it would but it was essentially the same behavior as the previous two BIOS versions maybe a little more difficult to get it to boot, so I booted with CTRL ESC held and chose rollback bios (to go back to 1.7.0), the flashing process looked normal, but this time a dialog box showed at the end stating bios update complete, press any key to reboot. The keyboard didnt respond so i tried plugging a usb kb in, it didnt respond either. I held power button down to shut down the computer (the other times it just took a click on the power to shut it off) and tried to power it back on and absolutely nothing. :frowning: no beeps no lights no fans no sign of life whatsoever!

My system is almost 2 years out of warranty and I cant afford a new computer, I thought a nice quality gaming laptop should last a long time as a daily use pc, I don’t use it for games so I expected it would last a long time without ever being worked hard…

If anyone can help please respond with suggestions! CTRL ESC + PWR doesnt do anything at all, nothing makes it show any signs of life. Thanks to anyone who is willing to share their wisdom in repairing this thing!


This probably belongs in the Off Topic forum, my apologies. Admin may want to move it?

Just a little update… I ordered a CH341A programmer and test clip from Amazon, it is due to arrive tomorrow. Ive been reading everything I can that looks to be related and getting all the knowledge I can before I try to bring it back to life, I definitely feel a little more comfortable now… Ive downloaded all the BIOS versions from Dell and I downloaded UBU and its related files. I do still have some things that Im unsure of…

I should also add some specifics of the system… Its a 7th gen kaby lake i7 7700HQ with GTX1070 and 1080p Gsync display…

I found this thread appears quite similar to my situation - www.win-raid.com/t5859f12-Alienware-r-dead-after-bios-update.html Lost_N_BIOS saved the day for this guy, it gave me a great deal of hope!

1. Which bios version should I try to flash?
2. Which chip is the bios? And is there a seperate chip for ME and EC \ Do i need to reprogram those too if so?
3. How do I inject my systems Service Tag / Express Service Code / MAC Addr etc?

If anyone could give any suggestions I would greatly appreciate it…

I know my first step (once I identify the bios chip) is to read and verify the chip 3x… I assume I have to edit the new bios file and put my specifics into it somehow before reprogramming the eeprom…?


-Edited to add system specs

Dump both chips with programmer and send to me, do NOTHING else, DO NOT Write any BIOS from Dell you will further brick the board and loose your system specific data

I can’t answer any of your questions until you send me dump of both chips so I can see what’s what.

Okay will do, thank you sir!

The programmer should be here today sometime, I will tear down the computer now and when the programmer arrives I will get those files dumped and let you have a look. I appreciate the help Lost_N_BIOS, reading around on this forum I already know your the man! =D

That certainly reduces my stress out of this whole thing! Thank you again!

Here is a link to the stock BIOS download page as requested.


Hey L_N_B, I PMed you the two dumps…

I dumped them in linux using flashrom. One thing that concerns me… The 1MB chip dumped almost instantly all 3 times, but the 16MB bios chip took ~2 minutes 21 sec to dump each time, I used linux time command to time them after the first one seemed to take way too long. But I dumped it 5x and verified good each time… and just for good measure i diff’d all dumps to verify they are all identical too. Could this chip be bad maybe? And possibly what was causing the problems I had doing bios updates? I checked the datasheet for that chip and WB specs it at 50mb/s data rate, I was getting something like 113KB/s read rate if my quick math is right.

I’ll patiently wait for further instruction…

Thank you again good sir!


@St00 - Please test - Same as “BrickedAlien” thread, if it fails I will redo a few more for you (one with stock NVRAM only, one with redone ME FW manually)

Weee I am so excited to try it!!! Haha! I will post results as soon as I have them!

Thank you so much for all your efforts L_N_B!



Unfortunately its still the same… No signs of life… Power button doesn’t appear to do anything at all…

I appreciate the attempt though!

Is it normal for it to take 5+ min to write a 16mb chip and a little under 2.5 min to read it? Seems slow to me but I definitely don’t know what I’m talking about!! HAha


Yes, sorry, sometimes it takes a few tries to sort out a recovery BIOS due to trying to keep some of your original stuff in there when possible.
Hopefully next one gets it, and if not, hopefully one of the three I make you later does (so it’s not an EC FW issue)

Writes all depend on the programmer and software being used (some commands to write are slower than others), and it does also matter the chip type too. But yes, in general 3-5 minutes isn’t too bad for 16MB chip.

* edit - If NOTHING at all happens when you press power button, then something could be fried or you don’t have something connected fully/properly etc.
Even with BIOS chip removed from board, something should happen when you press power button


I was hoping you were able to help me out, I do think i have a similar issue as well.

Laptop working fine, except for high-ish temps, decided a bios update may help because of the description on dells’ site. Updated the bios, it was working fine, then I shut it down for the night.

Start it up the next day, getting the CPU error light blinks.

What will I need to get started (hopefully rolling back the bios or something) that will allow me to use my laptop again?