[Help] How to flash ASUS K501UW using CH341A (black PCB)

I´m having trouble updating the BIOS on said notebook. Thing is, a friend brought it to me, after he took it to a service shop and well… bricked notebook.
The BIOS has the extensión 303 (version i guess) but as I can´t boot a thing, I can´t go into crisis/recovery mode.
Any tips and/or guides for flashing this one? Because I´ve been searching and reading a lot but still no results on how to flash this one.
BIOS CHIP: Winbond 25Q64FVSIQ.
Stock BIOS: Can´t be obtained.
Updated BIOS: https://dlcdnets.asus.com/pub/ASUS/nb/K501UW/K501UWAS303.zip

@kanutinbonbin - First, dump the chip and send me the contents. For W25Q54FV you need to use Ch341A software 1.30 or 1.34 and choose W25Q64BV - http://s000.tinyupload.com/index.php?fil…695330485827902

Why did he take it to a service shop?? And what did they supposedly do to it? And, why would they give it back to him bricked?
I will give you BIOS to flash once you send me dump of current chips contents, this way if at all possible we can salvage some of the original board details (serial, UUID, LAN MAC ID etc)
If you’ve already erased the chip or tried to write to it Ask your friend if he has ANY previous BIOS backups, such as one made with FPT or AFU, if he does tell him to give to you so you can send to me.

BIOS from Asus is inside a capsule that needs to be removed, and is only a partial BIOS upgrade file (2/3 of the BIOS only).
Once removed from the capsule it needs placed into a proper full BIOS before you write it to the chip.

I´m reading it, but still, everything blank :frowning:
He took it there on a panic reaction because he was working, wanted to do an update and everything went down from there… I´m already guessing they tried to flash the BIOS and went wrong. As they recieved a bricked laptop, they weren’t responsible for the results (they said that, but didn’t stated what they did).
Seems like someone is losing almost everything because of this :frowning:
What can be done and how can i flash this?

Are you sure it’s connected properly? BIOS would have some data on it no matter what, unless they ran erase as the last move and handed it back to him like that (doubt anyone would do that)
If you are sure it’s all setup correctly, and you can tell you have a good connection (sometimes takes 10+ tries), then you’ll have to wait until I can find some other dump from this model or similar, then I can make you a BIOS to program
Right now, all dumps I’m finding are only at paid sites

You will loose board serial, UUID and Ethernet will never work (unless you know the original LAN MAC ID from router logs or something like that)

That’s almost all there is I think… Thanks for the effort!

Dumped and uploaded! Thanks for the help!


predump.rar (4.04 MB)

Thanks, BIOS looks OK (actual dump, not corrupted by programmer I mean) BIOS itself is corrupted though, NVRAM scrambled and first/MAIN BIOS volume corrupted as well.
I still need to find dump from this model to put board specific info back in properly, due to how and where this one is corrupted. I may be able to use dumps I already have from K501UX though, I will have to check.
You do have other system you can use while you wait on this one, correct?

Sticker only has partial serial on it (one of), partial due to date of manufacture is not shown there, we’ll have to make up, and that MAC may be wireless MAC ID. Can you confirm, does this system have Ethernet port, and wireless?
If yes, please look at the wireless card, it should have a sticker on it, if yes, please confirm it’s not the same one shown on that sticker in above image. I don’t need to see wireless MAC, just want to confirm it’s not the one on sticker above.
Original UUID will be gone forever, unless I can find in the scrambled data area of the dumped BIOS (doubt it, it’s corrupted and scrambled around)

I think K501UX it’s almost the same, except for the VGA, but there’s an update for the VGA bios on Asus site (might be useful?) . It includes Ethernet and the wifi mac is different as is printed on top. The image includes manufacturing date
Thanks a lot!


Yes, I thought so too, but couldn’t find exact/perfect comparison. However, due to the main difference you mentioned (VGA/Display/GFX Card etc might be different), I can’t use UX to be the ME FW Settings source or donor.
We must find good (Full) dump from this exact board, or you will have to purchase one from Vinafix or other similar site, then I can use that to redo the ME FW area. Well, we can with UX ME settings, since you have programmer, if it fails then you’ll have to buy a full dump from good source (I’ll show you once/if we have to do that)

So, you confirm Wifi MAC is not same as what you showed in first image on post #5? If yes, good, then that one on #5 would be the Ethernet MAC

If the UX BIOS lets me POST, then i could also do a little flash upgrade afterwards?
And yeah, the one on #5 is the Ethernet MAC

@kanutinbonbin - Sorry, I’m not sure what you are asking there about the UX BIOS, but don’t program or use it. Thanks for confirmation about the Ethernet MAC. I will make you BIOS using UX ME FW Settings as base for that, really that is all I was missing/needing from a UW dumped BIOS.
Hopefully it will be same or OK on your model, if not then we’ll have to find a dump from this exact model, or possibly if you ask Asus Directly for recovery bin they will send you one. (If you do, tell them you can put in serial etc, just system detail empty recovery bin will be fine)
Here, please test and see if everything works OK now - http://s000.tinyupload.com/index.php?fil…525209487842246

Be sure to use software 1.30 or 1.34 and W25Q64BV ID, or use ASProgrammmer and W25Q64FV ID May be OK.
If it fails to boot after you program in, dump the chip and compare with what you wrote, to confirm the verification and write was valid. This should be 100% bootable.

It´s been a little while since I answered. A little travel stopped me from reporting back so, sorry for the delay.

I tried using CH341A 1.30 on the chip, just like you said, but it didn´t work. So I´m thinking of asking Asus for the recovery bin.
A thing changed though: Notebook now shows charged light all the time.
I might add some details I observed too: Both, processor and GPU are not turning on. No heat even after 6 hours "turned on". SSD and RAM (soldered) show the same behaviour. It uses the battery but nothing more than that. I´m starting to think of a burned cap or issues on the power circuits but still, gonna try dumping the current BIOS on the chip tomorrow (3:23 AM here)

Thanks a lot dude! It´s been a ultra steep learning curve and a good one to be on for sure!