[HELP] HP Z440 CORRUPTED BIOS - NEED HELP WITH RE-FLASHING!

Hi

I have a HP Z440 workstation which was working fine up to a few days ago when I changed some settings surrounding UEFI, at this point I also by accident changed the graphics vga to UEFI only too. On reboot I got some beep codes indicating an issue with the graphics card. I tried other cards but didn’t have a UEFI capable card to hand so attempted to clear the cmos using the on board reset button. On reboot I now just get a black screen and the machine keeps power cycling every minute or so. I’ve tried the BBR procedure with no joy. I don’t believe the board is physically damaged but has a corrupted bios. HP have stated that the older bios firmware had issues and to upgrade to version 2.5 but without a bootable system i have no way of upgrading. I believe the BIOS version prior to failure was v1.25 but dont have any more info other than my backup bin files.

I’ve purchased a CH341a programmer and successfully read the bios chip contents twice over, verified that the data matches but now unsure of what to do next. I believe from reading similar posts that its not as simple as just downloading the v2.5 bios bin file from hp and writing to the chip as key info such as the serial number, UUID and MAC etc would be lost.

I have attempted to use HxD to read through the file to find this info but apart from the serial number im not sure where to find the missing info needed.

Ultimately I would like to re-flash my current chip with the newer BIOS and at the same time if possible update my Boot Block.

Could anyone help me with this issue or give me some pointers. I could provide my backup BIOS bin file if needed or any other info that may help.

Thanks very much.

@RUPZ - What is the BIOS chip ID? And what software/version did you dump BIOS with? DO NOT erase or write anything yet, in case your dumps are not valid due to incompatible software used etc.
I will eventually need a link to the HP BIOS download page, your backup x1 (but wait for this, in case I want you to backup again), and then your serial, UUID and LAN MAC ID if you know all those
For now, before you send me anything, tell me your BIOS chip ID

Hi

My bios chip is a Winbond 25Q128FVSQ or 0 hard to read off the chip as its so small.

Thank very much for your interest in helping me, its much appreciated!

Sorry i forgot to mention that I used ASPROGRAMMER v1.4.1 to complete the bios dump.

i am trying to do the samething for my Hp machine with Ch341 programmer 1.30 but it shows me a message after completion - chip main memory with the contents are in disagreement!

and now m,y computer is not even turning on.

@RUPZ I had a similar situation where I accidentally turned on the UEFI bios setting in the BIOS without selecting the option to NOT check the video card. I too had an older, but very functional video card in the system, but the video card ROM was not UEFI compliant.

Once this change is made in the workstation’s bios settings, then the BIOS will halt the system during the initial BIOS check with a bad video card beep code and flashing lights. The card isn’t bad, but since the BIOS expects that the video card will be compatible with a UEFI bios, it now fails the video check.

The issue is that once this is set, reloading the bios will NOT change this value, not even removing the battery or pressing the BIOS reset button on the motherboard will fix this. It won’t change it even if the bios recovery is done using HPs BIOS recovery methods. That value gets “stuck” in a non-volatile memory location on the motherboard, and can’t be changed until you can successfully get through the BIOS checks and are able to get into the bios screens.

The easiest solution is to find or borrow a newer video card that has UEFI bios capability built into its rom. They can be found for under $10 on Ebay if you can’t borrow one temporarily from another computer or from a friend. Most video cards from about 2014 on will be UEFI BIOS compatible.

Once you install the UEFI capable video card, the computer will then get past the initial BIOS checks, and you’ll be able to go into the bios settings and change it so that it won’t check the video bios for UEFI capability.

I’ve attached a screenshot of the setting in the BIOS that needs to be changed to allow for older non-UEFI compliant video cards – it’s in the “Advanced” tab “Option Rom Launch Policy” area, and the setting that needs to be set is called “Configure Option ROM Launch Policy”, and it needs to be set to “All UEFI Except Video”. If it is set to “All UEFI”, that’s what will cause this issue if you have a non-UEFI compliant older video card.

I hope this helps some folks get out of this trap…