[Help] L580 turns off after 30 seconds with me_cleaner cleaned BIOS

Hello, I have a thinkpad L580 type 20LX with i7 8550U cpu. I have tried to use me_cleaner and advanced bios options to disable ME, but regardless how I tampered with the ME the computer will shut off in around 30 seconds. And if I enable ME the computer will function fine. I am aware that ME has a watchdog timer that can reset the machine every 30 minutes, but my machine is shutting down every 30 seconds, regardless I am in BIOS or booted into an operating system. I have a T480 with the same cpu and it worked flawlessly with the -s (HAP bit) flag.

Here’s all the steps I have tried:
With original BIOS v1.45 (ME v11.8.50.3425):

  • me_cleaner with no flags, -S flag, or -s flag
  • patched BIOS to unlock advanced options and then disabling ME inside the advanced option

When that didn’t work, I updated the BIOS to the latest version (v1.46) and tried the following:

  • me_cleaner with the three options mentioned above (no flags, -S flag, -s flag)
  • unlocked advanced options and disabled ME inside the advanced menu

That didn’t fix it either, so I updated ME from v11.8.50.3425 to the latest version on lenovo website, and tried the me_cleaner and the advanced option method but to no avail.

I then began to poke around with the ME partitions. I whitelisted all partitions except for the NFTP (network partition and passed in the -k flag so that me_cleaner will not clean the FTPR partition, and ME refuses to initialize without the NFTP partition (the ME version number row is blank in BIOS), and sure enough the computer still shuts down after 30 seconds.

The last thing I’ve tried is I download a BIOS dump from here: https://www.badcaps.net/forum/troubleshooting-hardware-devices-and-electronics-theory/troubleshooting-laptops-tablets-and-mobile-devices/bios-requests-only/68959-lenovo-thinkpad-l580-type-20lw-20lx-nm-b461?p=1753932#post1753932.
And then I proceeded to try the me_cleaner and the advanced menu method mentioned above, and it still would shutdown after 30 seconds.

So after all of this, my questions are:
Has anyone experienced ME shutting down a computer every 30 seconds?
Is there any work around for this issue while also disabling ME?
Is this issue caused by CPU/PCH dependent or there’s something in the BIOS that enforced the shutdown?

We don’t support such tools here, better ask the authors of that tool.

I understand, and apologies about my ignorance. But I am looking for help with disabling ME in general and I am willing to try different methods. I’ve seen this post about cleaning the ME image but I am confused about what it meant by “cleaning”. Does that method limit ME’s ability to operate? From what I can see it only erases the ME configuration data instead of cleaning and removing the ME modules.

Is this the right place to ask for advice on how to disable or neuter ME? I’ve looked around and I’ve seen mostly posts on how to put ME firmware back onto their systems, again please put up with my ignorance but I can’t wrap my head around people going out their way to put ME firmware back onto their systems?

The linked thread covers reinitializing a corrupted ME configuration and ends up with a fully functional ME firmware.