[Help] MSI x99a Raider BIOS UI freezing and NVME issues

Greetings! I am currently having some issues with a bios I flashed via raspiberry-pi+SPI+flashrom. Currently whenever I try to save a BIOS setting change or try to open m-flash the interface freezes. I also appear to be having some kind of NVME compatibility issue.

Background: recently acquired the following parts for a new/used desktop:
MSI x99a Raider motherboard used
Xeon e5-2698 v4 used
RTX 3080
Intel DC P4510 Series TLC PCI E 3.1 x4 NVMe used

The motherboard arrived with a bios version that predated the xeon e5-2698 v4 support so I hooked a r-pi up with a soic-8 clip and using flashrom wrote the newest bios (E7885IMS.P71). Seemed like a great success it could now boot with my processor! I did a clear-cmos operation and ran memtest for 24 hours successfully, ram and processor all looked good, booted into ubuntu live just fine. When I went to install my Intel DC P4510 ssd, the machine stopped POSTing, so I removed the SSD and tried changing some bios settings to see if it would help. Now I noticed whenever I try to change+save a bios setting the interface locks up when I try save a setting. However on manual restart the setting appears to have persisted. But the lockup in the UI and lockup when trying to open m-flash seems like I’ve messed something up. Flashrom did erase stuff like uuid/serial/mac that I did not properly re-insert in the bios, but as I use linux I’m not sure that would actually impact me? Looking for any ideas on how I can fix the bios and get my ssd working (my original plan was to try to update the nvme module and microcode while I was at it but I’m clearly stumbling on simpler tasks)

On the x99a Raider I tried a different samsung 970 nvme drive and it worked fine, and I tested the Intel DC P4510 on another motherboard and it worked fine, so it’s the particular combination of the Raider+Intel SSD that’s having an issue, which makes me wonder if an updated nvme module would make a difference.

I have also tried writing the bios again via “afudos E7885IMS.P71 /P /B /N /E /K” in freedos and that did not appear to make a difference.

Thank you for the assistance!

Using an SPI programmer is ALWAYS the last resource, why did it in the 1rst place if the motherboard was ok, besides having an older bios version… modern bios updates and varies from OEMs will perform several operations/upgrades/micro controllers not visible to users, that will not be done/programmed via SPI as a straight image FW, besides the lost of personal motherboard data… as you already know.
Besides an compatibility/fw issue with the Intel DC P4510 (M.2??? or U2…), setup in bios (specific settings) issue, internal PCIe ssd boot rom?, i would try to revert back to the initial bios release and perform sequential individual updates from all released versions to the last.

The reason I did the SPI flash was that I could not even POST with the xeon (support added in later bios) and didn’t have any alternative CPUs to try. I’ll try your suggestion and flash through from the earliest bios image to current on MSI’s site using afudos unless there is a superior method (m-flash is not working). The intel DC P4510 is a U.2 form factor, I have tested it in a pcie adapter and an m.2<->u.2 adapter and it works in other systems but not this one.

Normally a stock bios should work, There’s normally nothing important for operation that has to be kept from earlier versions.

In addition your board has 2 bios chips with possibility to switch. Did you overwrite both chips? If not try to get a dump of the other bios, you might still have your data…

Instead of updating different versions I’d propose to dump the current bios and to compare it/ bios region to stock. Try using flash programming tool in ME System Tools v9.1 r7 from

Run as administrator Fpt(w(64) -d spi.bin

This will try to dump the complete firmware into spi.bin. Since you flashed stock bios your descriptor should be unlocked, should/might work.

Post/attach spi.bin

Part of my failure was following another guide (outside of winraid before I discovered winraid) on how to flash a bios via SPI and it did not contain any warnings, so I flashed both bios chips on my board… unfortunately I cannot get a stock dump to compare with in this case.

I did follow the suggestion of walking the bios updates and was able to get some improvement:

I used AFUDE561.EXE from MSI to write the following images in freeDOS

E7885IMS.P50 ← rebooted here: m-flash and bios setting/save works!
Plugged in Intel DC P4510 ssd, screen turns on but no longer POSTs, shows no output

E7885IMS.P60 ← used m-flash
Plugged in Intel DC P4510 SSD, screen turns on but no longer POSTs, shows no output.
Once i’m on P60 is when m-flash stops working and get freezing on settings saves

Then I stepped back to P50 to confirm everything works on that version, it does.
E7885IMS.P71 ← then went from P50 - skip P60 - to P71 via m-flash and get the same m-flash/settings issues.

P50 gets m-flash and settings updates working. Has outdated microcode and Intel DC P4510 ssd does not work, possibly would work with NVME update.

So walking the bios up helped me fix the m-flash and freezing issues by determining that P50 is the last good working version of the bios, I just need to figure out how to update NVME+Microcode and re-inject my UUID/MAC/Serial.

I have an X99A Raider motherboard at work. We use it in a dental imaging machine we have. The bios is actually custom made with modifications. Took a dump of the bios as well. Wonder if you acquired one of those boards instead. I personally think maybe its the ssd. Possible to update the ssd’s firmware?

I bought the X99A Raider off ebay so I’m not really sure what it was used for previously though there was some glue on the fan/front panel headers that suggests it may have been installed professionally into something. I did check the ssd with Intel’s SSD firmware tool and it said it was the latest firmware. The ssd works fine in a supermicro X10SDV-TLN4F board.

Wasn’t sure until you said there was glue on the headers. This is probably from a heated glue gun which is the norm for motherboards that were installed by Sirona for use in a dental setting. I have a copy of the original bios if you want. Think it ends in .P4 or something like that and is a pre-release bios I think. I have always wanted to update the bios but was never sure what the effect would be. Now I have an idea. Will post later if you want a copy.

Thanks I would be interested to see that if it’s not too much trouble.

Good news! I have succeeded in adding the new microcode and updating the NVME module. I had initially set out to do this with UBU but ended up using MMTool Simply inserted cpu406F1_platEF_ver0B000040_2021-05-19_PRD_E5BABFDB.bin for the microde update (no deletes/replace) and then I found the 3 NVME modules (nvme, nvmeint13, NvmeSmm). I replaced JUST the nvme module with NvmExpressDxe_5.ffs and then saved the bios image and tried it out. Microcode shows as updated and I can actually POST now with the Intel SSD installed. Can boot into pop_os and see the NVME drive! I still need to figure out how to re-inject my guid/serial/mac but I’m pretty sure I can figure it out. Any reason that not updating/removing nvmeint13 and nvmesmm might cause any issues? I would be perfectly happy to share my modded bios, just want to point out that it’s likely to still wipe out mac/serial/guid. Thanks!


Have attached the dump from my Raider X99a. Hope you find it useful. Personally its old and the company that made the machine never licensed any updates. Though this is the original bios as shipped if indeed your board was previously installed in Dental Sirona scanning Omnicam unit as I suspect.

sirona_dump.zip (5.3 MB)