[HELP] Possibly bricked T480

So, I recently purchased a used ThinkPad T480 from a garage sale. Upon testing it out, I get no POST, only the power LED blinking 3 times when plugging in the charger. Nothing happens when trying to hit the power button. I took a dump of the BIOS chip using a flasher and compared it against an update file from Lenovo, and they seem to be the same. Any help would be greatly appreciated.

Why is it always bios corruption the primary assumption on this kind of laptop issues?
This is becoming a “vicious” ideia on all users around…
Why cant it be an hw issue?
Anyway, moving on…
T480 power button blinks 3x. Won’t power on. - Thinkpads Forum
T480 Won’t Boot (3 Blinking Lights) : r/thinkpad (reddit.com)

You can share your dump on your preferred sharing service/cloud if you want some user to take a look on it.

1 Like

Sorry, I’ve tried debugging the board, testing bad fuses, caps, etc. and also tried absolutely everything I’ve found on Google, before creating this thread, but nothing worked. So I thought of this as a last ditch effort in trying to revive it.

Anyways, this is a dump of the bios from my board

EC firmware in padding and static bios parts are identical to stock bios. ME reads and unpacks in MEA and FIT

You might want to start with an empty = stock NVRAM / FTW store and clean the ME region, but actually I don’t think this might help…

Original bios / EC firmware version:

Clean / reinitialize ME firmware region:

Good luck.