[Help Request] Bricked NUC7i7DNH2E BIOS


Nuc model: NUC7i7DNH2E

Suspect having a bricked bios, could anyone look at it? Atm it autostarts with 5s fan full speed and fan slows down, but keeps spinning forever. No picture.
Think its version 0068. Tried flashing 0075 which i found at:
Cant post a link, but you can find forum search “NUC7i7DNH2E”. Title: “Intel NUC7i7DNH2E BIOS to flash with hardware”, with date: "Thu Nov 25, 2021 2:43 pm"
but after flashing its a brick, no reaction to on/off button. Suspect EC was flashed.

Bios dump here:
Cant add a direct link, but add the drive.google in front of:

Bios update file can be found at softpedia, google words: "DNi70068.bio"

Edit by Fernando: Thread title customized

Link with logon?

So sorry, updated the first post with working link.

Static parts are a 100% identical with stock bios 0068, did you try to flash you dump back?

EDIT: Did you use the last bios posted in the mentioned thread? Don’t use files which didn’t get a feedback… There might be a mistake, if I remember right I replaced the ME region with the configured one from the update file, but this regios has another public key hash than the bios region. If FVME is enabled and fused in chipset this might indeed keep the machine from starting.

Clean the ME region of your old dump according to [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization and try the resulting file…

  1. Yeah, flashed back original dump, same result. Wont power on and no reaction to on/off button.

    2. Yes, tried with last post with 75_2.001.zip, 75_2.002.zip files.

    3. Quickly tried with "MEInject.exe" tool to flash with "", cause im familiar with it, same result, no power.

    Will take me some time to digest the lengthy guide. Will post of the results when done…

Stuck at end of “7.” in the guide with “SMIP Signing Key” dummy.pem insertion, but missing that field in FIT. Different versions different location? or should use older version of the FIT?

The picture of “Build Settings” is twice the options available in the guide, opposite of what i’m seeing in FIT.

Used "CSME System Tools v11 r44"

Picture of the field missing and picture of “Build Settings”:

There is a error after loading the dump, maybe its related?
“Warning: The ME FW image loaded has been pulled from a previously booted system. Some FW settings will not be allowed to be changed.”

You’re working on a CSME11, not CSTXE 3 - 4?

MEInject.exe- No knowledge about that tool.

The error message is normal.

"The picture of "Build Settings" is twice the options available in the guide, opposite of what i’m seeing in FIT." Your picture and the picture in the guide are pretty much the same?

Link for MEInject.exe below, but seems like it not being maintained anymore. Think its really basic tool and only replaces the ME, has no options to configure…

Used fit.exe from “CSTXE System Tools v4 r6”, but says:
Error 30: Failed to decompose Full Image.
Error 10: Failed to open with processed commands.
Unable to open file: D:\games!mobo!Programs\ME_TXE_Cleaner!DumpMidaParandada\W25Q128JVXXQ_20220125_120931 - cleanme.BIN. Reverting to default configuration.

Tried to open with all versions of “CSTXE System Tools fit.exe”, same error message.

You’re working on a CSME11, not CSTXE 3 - 4?

This is CSME 11, use CSME System Tools v11 r44 and leave point 7. out (since you’re not working on a CSTXE firmware)! Go straight to point 8!

    • ok
      9. - There are 2 ME region files in “Decomp” folder, “ME Region.bin” and “ME Region_3000h_603000h.bin”. Replace both? one? if one, which one?
      Tried two variations.
      Replaced both, then Step 14 is “Configured”.
      Replaced only “ME Region.bin”, then Step 14 is "Initialized"

      Noticed that old one ME region was ~5mb, new one was around ~7mb
      10. - ok
      11. - ok
      12. - ok
      13. - skipped this step (CSTXE)
      14. - See step 9.
      15. - Flashed NUC with both ME regions replaced, NUC still bricked, cant run command on bricked machine, no power :frowning: “fpt -greset”

If you run FIT several times on the same image, it’ll use the same decomp folder. Best to start from scratch and delete the folders in the Win32 folder and start with just vsccommn.bin and fit.exe

Otherwise it’s unclear to me what you’re flashing just now? I assume your own FD, ME and cleaned ME, but which bios region? Empty or own NVRAM?

Thank you for explaining, deleted everything and redid the steps from scratch, image is in “Configured” state. Used “”.
Did no other changes to the image.

Same result, no reaction to on/off button :frowning:

Not good. As you mentioned in the beginning, EC firmware might be fried.

Did you use the MEBX reset jumper to reset CMOS/ Remove CMOS battery? All unnecessary hardware removed, just 1 RAM module installed, Ram reseated?

I cleaned the ME region of your dump myself and the result is 100% identical. So the last thing that could be is wrong settings in NVRAM, but…

Rename the attached files to NUC4.7z.001 NUC4.7z.002. They contain 3 variants of emptied NVRAM-
own-str.bin is your old NVRAM stripped, just the old defaults and machine specific data left
own-emp.bin is a completely empty NVRAM region even without defaults
own-new.bin is the NVRAM defaults that’s hidden in static parts and machine specific data

I’m not very optimistic.

Anyway- if you want to try please read the firmware after trying (and before flashing something new) and post it, might be interesting to see if the machine at least started to boot and populated NVRAM again.

NUC4.7z.001.zip (6 MB)

NUC4.7z.002.zip (1.75 MB)

Think that EC chip is ok, cause its outputting 3.3V to the on/off button, firmware part might not be.
Think EC firmware is in other winbond chip, uploaded it (third link). Maybe you can find it from extracted bios file, i couldn’t. There is a file named: EcRegionPointer.bin, but its empty.

Tried the jumper before and after flashing bios from another post, it did not go to recovery bios.
Without the jumper it did not start flashing with bio file on the flash drive (fat32).

Yes, tried different memory sticks, different memory slot, different adapter, reset cmos.
3.3V, 5V and 1V are present on the board. Checked bios chip with oscilloscope Data out (DO pin2) and Data in (DI, pin5), did not see any activity (or my cheap scope not picking it up).
DI is at 0V all the time, while DO is 3V. Shouldn’t data line without activity be 3V while idle? Pullup resistor bad somewhere or bad pch pulling it down? Both line are 1.33 in diode mode reading.
There are 4 winbond chips on the board. Bios chip: 25Q128JVSQ, think EC chip: 25X10CLNIG and two chips that are next to mcdp2800bc (displayport?): 25X40CLNIG

own-str.bin > no power, tried jumpers in all position > uploaded > own-str_NUC.bin
own-emp.bin > no power, tried jumpers in all position > uploaded > own-emp_NUC.bin
own-new.bin > no power, tried jumpers in all position > uploaded > own-new_NUC.bin
Compared with hex editor and they are the same. Can anything block the communication with bios? EC?

Uploaded the bios files after powering on the nuc, but its pointless, cause they were identical to the ones you uploaded. Second attachment is picture of the board. Third EC

OK, didn’t compare the read files myself, if they’re 100% identical as you wrote…

EC firmware is/ should be version 12 since 0067, the dump you attached does look like EC fw, but it’s version 09, last time used in 0040


Sorry, can’t help you here. Afaik EC comes first and ‘pushes’ bios, if you don’t see any activity there that’d be consistent.

I doubt that flashing the EC firmware will help, but it might be worth a try. Release notes don’t say anything relevant about EC firmware…

No idea about the other chips, might be related to TPM(?), video, store for settings?

EC12.zip (22.7 KB)

Yeah, you were right. Same behavior with EC12.

Here are the dumps of two other chips 25X40CLNIG.

Thanks. Almost identical content in these chips, sort of “settings”? All firmwares should work, it has to be something not firmware related…

I’m sorry but I can’t help you here.

I dont understand - if a bios flash fails - what does bricking mobo actually mean? The bios chip gets fried? Mobo gets fried?

i can confirm the ME is Clean and WORKED for a similar model i “replace as is” w uefitool A60.1 however usb install went dark… bios recovery worked.