[HELP] Unlock Advanced hidden menu from Insyde bios of Acer TRITON 500


I’m kind of lost with the way to unlock the Advanced hidden menu and all the settings related of this bios. I played a bit with H2OEZE and H2OUVE editor to see a preview of these hidden settings but could not get too far.

Could you give me an hint to accomplish this? Thanks in advance for any help.

(I have a SPI programmer.)

@mediadoctor - Please upload a programmer dump of your BIOS, I will check and let you know.
Also, please give your full exact model name, and or link your exact model BIOS download page, there is 8 x Triton 500’s This way I can download your stock BIOS on Acer site.


Thank you for you quick Reply!

Bios v1.10 Dump: https://cloud.mail.ru/public/ixmc/3PUFvbo4F re-uploaded
Bios v1.10 Stock: https://global-download.acer.com/GDFiles…=ACER&SC=EMEA_8

@mediadoctor - You’re welcome

Please give your full exact model name, and or link your exact model BIOS download page (not the actual BIOS download URL) This way I can keep BIOS in a correctly named folder on my end.

Hello, Lost_N_BIOS

Only one bios version for all modells.

I have PT515-51-74E7


@mediadoctor - Thanks for model name and link. Why is there a edited "re-upload" above? Do I need to grab that and toss your old one?
Also, looking back at your original dump now, this is not a programmer dump. What did you create that dump with? Same applies with new linked re-upload

Please dump BIOS with programmer since you have one, these are not programmer dumps. If there is two BIOS chips, do not combine BIOS, I can do that as needed. Put all files in a zip or 7zip
Programmer dump would be 8MB or 16MB etc, 12GB is not a programmer dumped BIOS (even though this boards BIOS is a 12MB base source file)

I will do everything this weekend.

I try make backup my Bios with ch341a 5v Programmer but my bios chip is mx25L12872f 3v and now i have brick :frowning:

Very sorry to hear something went wrong! Two things there, 5v issue is a myth, nothing you need to be concerned about and this did not cause any of these issues, this has been proven over and over again (It got me worried early on too)
The only time you need something different is when you have a 1.8V chip, then you need adapter or it wont read/write properly, but even then still will not fry the chip.
Second, when reading a BIOS chip you cannot erase it or brick a BIOS. Unless you accidentally hit “Auto” button and didn’t previously uncheck “Erase” and “Blank Check”.
Or, you shorted out some resistors around the BIOS due to bad connection or short etc. Did you see or smell magic smoke?

No smell and smoke!
Chip recognized but not propertly. May be have you fresh drivers for ch341a and last bild Win 10?

You could assemble smth wrong, you can check review of OwnOrDisown on youtube where he says that he tried to assemble 6 times before it started to work

PS @Lost_N_BIOS can you check please neighbor thread about new helios?

I tried to assemble many times


I think booblock is corrupted because notebook have no signs of life, only power diode light on if charger is on.
Is it possible to restore Bootblock on bios chip with programmer?

Chip is either recognized, or not. What do you mean by “not properly”?

If you have a dump then yes, you can restore the BIOS, if not you can find one from another system and try that. Best to dump chip first and have that checked out, before you try to erase or write anything, BIOS is most likely 100% fine.
It sounds like you have a short, or had a short while connected and now some resistor or voltage protection circuit blew out, etc. Since you connecting with programmer should not have done anything to the BIOS, unless you accidentally erased it.
Sometimes smoke may not appear, or you may miss it as it’s not very much at all. Can you show me close up images of area around the BIOS chip, sometimes you can see blown trace or resistor

But really, I need more info about what I asked above too, to better understand what is really going on here. Please dump the chip and send me the contents.
You may need to have main battery installed and or PSU connected (But not system powered on), or you may need to remove main battery and disconnect PSU (Some systems need one way, others the other way)

Can you explain please
1) is it better to connect clip tool to a chip first and only then connect programmer to usb port, does it matter?
2) if I was able to read a chip and made a dump, how to check that it’s correct and I have 100% guarantee that I can restore backup later?

With latest software version 1.34 chip will not recognized but with soft ver 1.29 chip recognized like mx25L12805D but i have mx25L12872f. I try flash stock bios from acer support but this not help, programmer used CH341A, writing to chip give message in the end "Chip with the contents are in disagreement"

Foto motherboard with bios chip


With PSU connected chip allways recognized correct, thanks. I try flash many versions bios but not help, notebook is brick :(.
Lost_N_BIOS are you watch the photo motherboard?

Can you help me with bios unlock?

@mediadoctor - sorry I’ve missed your replies for so long!! I’m always buried here

Did you ever dump your BIOS, before you wrote to the chip? If yes, please put in zip and send to me (if zipped file is only few KB’s then never mind, that is blank dump)

For MX25L12872F you need to use ASProgramer, so I bet for MX25L12873F you should too, here get 1.41 - https://github.com/nofeletru/UsbAsp-flash/releases/
If you did not get a good dump before you erased/wrote, then all original system details will probably be lost forever, unless there are on stickers on the board. Really only important one is LAN MAC ID, but you may be able to find and recognize that in your router logs
Good news, I think I have BIOS region dump from you, maybe from software, before you bricked BIOS.

If you never dumped with programmer, then I will have to find a BIOS dump from your exact model, or see if I can rebuild you new BIOS from scratch. You cannot write BIOS from Acer, unless you email them and tell them you need a recovery.bin file for this model.