Help with z87-hd3 AMI Apito 4 modding.

Hello guys, I have a z87-hd3 running i5-4670k with Bios F8 from Gigabyte.
So I read through this forum and any other forums about bios mod that I can find, then I finally try to modify my bios.
I used UBU to update all the firmware to lastest version, and successfully flashed it and boot without problem. In this mod, some problems cam up.
-When I try to use the ME tools, I was able to use fptw64.exe -f spi.bin and success, but any other function like Meinfo or FWupdate i got this error: "Error 9470 fail to load driver (pci access for windows)". This happened also when I open AFUwin, got same error. I then tried to flash back original Bios from gigabyte and load ME tools again but still got the same error "Error 9470 fail to load driver (pci access for windows)".
My original Me version is, updating version is with v9.1 tools. (I tried the with 9.0 tools but it not working at all even with fptw64 -f spi.bin to dump and v11.0 tools) My ME driver is v11.0 which is lastest ME driver for my win10 64bit.
I think my Bios Write Protection blocked that, so flashing or reading from software within window will not work? Maybe something else?
This problem happen when I flashed my modified Bios.After playing for awhile, my PC restart randomly without any error, the mod is just updated firmware to lastest and microcode to v22, Same exact size compair with original Bios. Flashing back to original bios fix this. So what have I done wrong?

Any help would be greatly appreciate.

Sorry if my English is bad, its not my first language, still learning.

@jerrysd :
Welcome to the Win-RAID Forum!

Since I don’t know, which BIOS modding part may have caused your problems after having flashed the modded BIOS, I can give you just the following advices:
1. Don’t modify your BIOS unless it is really necessary or useful for you.
2. If you are sure, that your system will benefit from the update of a specific BIOS module (e.g. the Intel RAID ROM, if you are running the Intel SATA Controller in RAID mode), you can use the UBU tool for that purpose.
3. It doesn’t make sense to let the UBU tool update everything, which the tool offers, if you don’t even know, what you need.

Your Intel ME problems have definitively nothing to do with the usage of the UBU tool.
Reason: The tool just updates modules of the BIOS Region, but not the Intel ME Region.
If you have questions regarding the Intel ME issues, you should better post them into >this< Sub-Forum. Our Intel ME Guru plutomaniac (or someone else) will help you.

Dieter (alias Fernando)

Hi @Fernando , thank you for the reply,
The reason I modify my Bios is that I want to learn about modding Bios, and unlock it fully for Overclocking purpose, and also disable the Bios write protection.

If you want to learn about BIOS modding, you should try to do it manually instead of letting the UBU tool do everything automaticly.

The UBU tool cannot do that.

I use UBU just for update. But to unlock, I was using the stock F8 bios from gigabyte and used AMIBcp. But no luck. What did I miss? Do I need to change the strings for the chipset setting options show up instead of just an empty chipset tab.

EDIT by Fernando: Unneeded fully quoted post removed (to save space)

I don’t know it.

@Fernando , well I read that to unlock those settings just change the defailt to User with amibcp, but I did that and no luck…

@jerrysd :
I am sorry, but I cannot help you regarding your problem.

Okay then, thank you anyway for your time, I will do more research and maybe It will be solve.