Help write bios on bricked notebook

I read this guide hoping to unlock it… I upload all on Mediaifre now

Tried to flash another time your dump plus S550CAAS_NV bios but geforce is still missing…

Do not flash constantly stuff, you will kill the chip. What’s the point of flashing that frankenstein BIOS region I uploaded when you have a proper dumped one? Wait and adjust your options first.

That guide does not mention how to unlock the FD because it’s not relevant to it. This is how to do it with a Hex Editor quickly, change 0x62-0x64 , 0x66-0x68 , 0x6A-0x6C to FFFF:



To verify the result, you can quickly use ME Analyzer or UEFI Tool:



For the new FD state to apply, the full SPI Image needs to be flashed with the programmer.

I assume the dump you payed for is the “s550c k56cm rev2.0.bin” file, right? That one seems ok, the motherboard tag is correct and the Nvidia VBIOS is included as it should. You can base your mod on that dumped BIOS since you don’t have a backup of your own and the stock from ASUS is problematic. Based on the paid dump of the exact same model, I created a new SPI Image which has the Flash Descriptor Unlocked and a clean & updated ME firmware. First time it boots, make sure to reset BIOS settings to default, as this BIOS comes from a dump. If it displays a black screen it may be that some NVRAM settings from the laptop the dump came from are causing small issues. Try removing the ram, power on and off and reseat them back. To flash this, use the programmer. After flash check the Nvidia card, it should work. From the firmware standpoint it has no reason not to. If it doesn’t then the problem is elsewhere, maybe drivers or maybe gpu hardware.

As far as extra BIOS modding is concerned, the HM76 chipset that your laptop has does not support RAID so updating the RAID oROMs does not benefit you in any way. They are not used under AHCI mode.


For the rest of UBU options, you can update the EFI GOP Drivers, the LAN stuff and the microcodes for SNB/IVB. The latest Intel VBIOS is 2171 but you need to update it manually (MMTool, not UBU) using the mobile version of 2171 and only after adjusting settings with Intel BMP Tool as explained by SoniX in his guide HERE.

SPI_Dump_ME_Unlocked.rar (3.48 MB)

YEAH, I finally found the right firmware for my laptop and all is 100% working!!! Also instant flash work now! I upgraded ME, think that I can’t ask more!!

The winner!

That’s good news. Turns out that you needed a dump from the exact same model as the latest bios has a tag of S550CM compared to the paid S550CB, dump K56CB and dump2 K56CM. Anyway, enjoy the repaired system.

This is the bios for my notebook, there is a way to flash it? I’ve just discovered that trackpad is missing…

Help, I really don’t understand how can I flash this bios!!

This time it seems the right time! Flashed another firmware from a S550CM, gpu and also trackpad are working!

Now, only to understand, I’d like to know why both with fpt and afudos I can’t flash bios from Asus support.

This last firmware flashed:…ns/outimage.rar

Can someone help me please with my problem. My Toshiba Satellite C660D-144 has black screen and keyboard lights stays on. I’ve tried to flash the bios through usb from Toshiba website the exact model bios, but it didn’t work. And tired to flash with (USB Programmer CH341A) but nothing is working. Its bricked do I need SPI flash and where I can get the right file. I’m not expert in this case please consider if I write something that doesn’t make sense. Please help me. Thanks

Only now I discovered that the webcam isn’t listed on devices list. Can be a bios problem?

Thank you for this post

* I have same NB asus s550cm model
could you send the last file.bin to write on my NB please