How to Remove Alert TPM Device Not Detected from 3501 11 Generation LA-K034P?

According to the Customers When update bios then This Error comes.

That can be solved via Downgrade bios too. But in some of the case, it can’t be solved.

Please, Share Complete Process for solution of this Error

i have same error
Did you come to a solution?

Still, i don’t have any solution Sir

Not useful?
Solved: Latitude 7480, alert TPM device is not detected - Dell Community

Yes Sir, Not useful for 3501

Intel® Platform Trust Technology (Intel® PTT) or discrete TPM?

i need TPM Alert Device not detected by bios editing

I dont see this issue addressed here on the forum, i think both of you should try your efforts in Lenovo helpdesk and their forums.
I even dont recall seeing this issue in other machines brands… but i cant see all.

Our member lfb6 already offer his help…he got no answer.

If you don’t care to spend a little time answering the most basic questions then people will not use time on your item either.

You didn’t even provide the most basic information regarding the device- are we supposed to find that information ourselves?

Give some (at least basic) information about the device, answer the question asked and provide the original bios dump of this device…

i had been recieved from customer Dell 3501 LA-K034P laptop.
i don’t have any backup bios of these laptop. i already returned this laptop. Sorry for improper information.
But Both laptop has same problem Alert TPM is not detected.

If it’s Intel I’d propose:

Dump complete firmware, open in FIT, check if Intel® Platform Trust Technology (Intel® PTT) isn’t disabled permanently (two methods, one disables PTT permanently since the setting is fused into PCH first boot)

Re-initialize Intel ME according to:

Empty NVRAM in bios region as far as possible (some machines have their DMI information written there).

Yes, This is what i want.
Thank You Much So Much.
How to make Empty NVRAM in BIOS Region ???
i mean, which part of BIOS Region have to be empty for make Empty NVRAM ?

Now, i found Backup file of Dell 3501 LA-K034P which have TPM is not detected Error
When Opened in FITC tool then

Intel(R) PTT Supported → Yes

Now, What i have to do ???

Please attach or post the dump.

Alert TPM is not detected
Old Backup file Download link: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Your dump seems to be bios 1.15 and ME

Dell Bios update 1.15 includes ME fw, but all other updates from 1.11 to at least 1.18 include ME so they downgraded again after update 1.15!

ME was last time included in update 1.10, so Intel ME got at least once not updated what raises suspicion that the ME firmware might be corrupted.

Follow this guide to re-initialize the ME firmware:

Regarding NVRAM- seems not to contain machine specific information, padding after NVRAM contains DVAR region which has serial, Windows code, service tag…

So it would be easiest to transfer the empty NVRAM EFI volume from an update to this bios region (your dump on the left, update bios region on the right)

Did you get solution bro?

No, Brother. Still, i can not found