[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

Hello, I would like to inform you that the procedure worked well on the ASUS H61M-C motherboard with an M.2 Kingston A-1000.
Olá, gostaria de informar que o procedimento deu certo na placa mãe ASUS H61M-C com um M.2 Kingston A-1000.

@Marco_Antonio_Silva :
Welcome to the Win-RAID Forum and thanks for your feedback, which may encourage other users to do the same.
Enjoy the performance of your NVMe SSD as system drive!
Regards
Dieter (alias Fernando)

I thank you for the post.

Hi, Fernando, thanks for your reply. i’ve just uploaded the “Disk Management” picture for your reference.

Partitions.jpg

F12.jpg

@a4cheong :
Thanks for the screenshots.
Please re-attach them after having done the following:
1. Disk Management: Right-click onto the Win10 Start button and choose the option "Disk Management".
2. BOOT order: Enter the "BOOT" section of the BIOS, set the "Windows BOOT Manager" into the first position of the boot order, insert any USB Flash drive and hit the F12 button.
This is how the pictures should look (but all in English language):

Disk Management.png

BOOT order within the BIOS.jpg

@all:
This thread has been designed for users, who want to get full NVMe support for their old PC with an AMI UEFI BIOS by trying to do the related procedure themselves. Since I didn’t spend the time writing and updating detailed guides like the one within the start post of this thread with the intention to do in the end everything myself, I generally do not modify anything upon request.
Users, who just want an already NVMe modded BIOS for their specific mainboard/system and are not able or willing to follow my guide, can search for it within >this< Sub-Forum or send a private request to our BIOS Guru Lost_N_BIOS.

@Lost_N_BIOS :
It is no problem to insert the NVMe and the “SAMSUNG_M2_DXE” module simultaneously.

@Fernando

Yes right I did same mistake earlier tried to do it by myself and then it switched during the discussion to a mod done by the Guru .
I will create an [OFFER] at your link for what’s was done earlier for my bios.

Would be great to clarify in the guide with MMTool. Guru said “NVME should not be inserted into CMSCore” Post link

Cheers.

@Svan :
You obviously misunderstood my guide (= start post of this thread). The NVMe EFI module should not be inserted into the CSMCORE module, but into the “DXE Driver Volume”, where the BIOS module named CSMCORE usually is located and listed (Note: Some BIOSes have more than 1 “DXE Driver Volume”).

In the very rare case, that a module named “CSMCORE” shouldn’t be listed at all by the MMTool or UEFITool, the NVMe module has to be inserted into the first (=upmost) Volume, which contains “DXE Drivers”.

EDIT: To avoid any future misunderstandings regarding the target location for the insertion of the NVMe module, I have just now added some additional information into this part of my guide.

I’m using ASUS P8Z77V_LX (https://www.asus.com/Motherboards/P8Z77V…pDesk_Download/) and attempting to get this working for a Samsung 970 Pro M.2 SSD using Hyper M.2 X16 v2.
I’ve attempted the method on the original post and have also attempted a method using MMTool to insert three Nvme files from a Z97. Both methods haven’t worked for me.

When attempting to use EZ Flash it says “Security verification failed” using the modded .CAP file.
I’ve used AFUDOS and it flashed successfully but when checking the UEFI BIOS nothing had changed and the SSD wasn’t detected.
Disabling CSM doesn’t work, it restarts beeps 1…1 2 3 and then tells me that it’s enabled CSM again.

The SSD is being detected in windows and I can use it within windows as storage but I’m wanting to boot from it.
Any suggestions?

Here are 3 reasons why I disagree:

  1. Not the BIOS modding procedure itself, but only the flashing of a wrongly modded BIOS is risky (may brick your mainboard/system). It is very easy to minimize such risks by posting the self-modded and the original BIOS into this thread and to ask for an analysis and a verification, that the BIOS has been correctly modded.
  2. Only by trying to do the BIOS modification yourself you will get knowledge about the structure of a BIOS and about what happens or may orrur while trying to get any natively not present BIOS module inserted.
  3. If you let the BIOS modding been done by someone else, you will be dependent on such expert in the future. Every time the motherboard manufacturer releases an updated BIOS version that you want to flash, you’ll need to bother an expert again and ask, whether he will do it for you.

@Outbreak :
Welcome to the Win-RAID Forum!
Please enter the BIOS, open the “BOOT” section and look for a Disk Drive named “PATA” or “PATA_SS”.
If it is listed, your BIOS modding and flashing work was ok and you should be able to get Win10 properly installed onto your NVMe SSD in UEFI mode.
If no such Disk Drive is listed within the BIOS, your BIOS modding work was not correct or the BIOS hasn’t been successfully flashed into the BIOS chip of your mainboard. In this case I recommend to attach the original and your modded BIOS as *.ZIP or *.RAR archive. Then we will analyse it and tell you our result.
Regards
Dieter (alias Fernando)

Thank you @Fernando
No additional drive was listed in the BOOT section.

I’ve attached the relevant files.
P8Z77-V-LX-ASUS-2501.rar (3927 kb) - Original BIOS .CAP file(Latest version)
P8Z77-V-LX-ASUS-2501_MOD_2.rar (3942 kb) - Modded BIOS .CAP file (using NvmExpressDxe_2.ffs)
P8Z77-V-LX-ASUS-2501_MOD_4.rar (3937 kb) - Modded BIOS .CAP file (using NvmExpressDxe_4.ffs)

Hope this helps,
Thanks.

P8Z77-V-LX-ASUS-2501.rar (3.84 MB)

P8Z77-V-LX-ASUS-2501_MOD_2.rar (3.85 MB)

P8Z77-V-LX-ASUS-2501_MOD_4.rar (3.85 MB)

@Outbreak :
The file named P8Z77-V-LX-ASUS-2501_MOD_4.CAP has been correctly modified and should support NVMe after having been successfully flashed.
So I suspect, that the flashing procedure didn’t work as it should.
Regarding the flashing procedure please have a look into the start post of >this< thread (Chapter B of the ASUS Guide).
If you should have any further questions regarding the BIOS flashing, please post them into the related thread.
Once you succeeded, please give us your feedback within this thread.
Good luck!

@Fernando thanks, I’ll give that a go.
Also attached bios.rar (3937 kb) - Modded BIOS .ROM file (using NvmExpressDxe_4.ffs)
Attempted to flash using AFUDOS *.rom /gan
The flash went ahead fine and completed but there was no changes to the BIOS, no PATA(_SS)

bios.rar (3.84 MB)

@Outbreak :
1. Is your NVMe properly connected via adapter to your mainboard?
2. What lets you believe, that the flashing procedure was successful?

@Fernando

Yeah it’s connected fine, I’m able to access the drive through windows explorer.

I’ve attached an image of the AFUDOS result after the flash attempt.

IMG_20190721_180952.jpg

@Outbreak :
Did you follow exactly this guide?

  1. Copy the original (untouched) BIOS file into the same directory as the file AFUWINx64.exe.
  2. Flash the original BIOS by running the following Command Prompt (as Admin):

    1
     
    afuwinx64.exe <NAME OF THE ORIGINAL BIOS>.CAP
     
  3. Replace the original BIOS within the AFUWIN64 folder by the modded one (must have the extension *.ROM!).
  4. Flash the modded BIOS by running the following Command Prompt as Admin:
    1
     
    afuwinx64.exe <NAME OF THE MODDED BIOS>.ROM /GAN
     
  5. The UEFI BIOS should now be fully re-flashed and updated! Reboot and give it a try!

@Fernando :

No, I couldn’t find a afuwinx64.exe that worked. I’ve found a download of it so I’m testing it now, will update in a moment.

Attached is the AFUWinx64 tool v3.07.01 dated 02/02/2015, which is currently offered by AMI for Aptio IV BIOSes.

afuwin64.zip (840 KB)

@Fernando
I tried the one I found and it flashed but didn’t add any PATA under boot.

I then tried the version you sent me but it it says
Unknown command or option : /GAN
1 - Error : Unknown Command