[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

@Lost_N_BIOS

Hello Lost_N_BIOS!
I have the same Gigabyte GA-Z87-D3HP motherboard, but the BIOS you modified is only available for money. Could you update the link or send me the file in the mail.

For me as well!

@Max2x :
Welcome to the Win-RAID Forum!
Why don’t you try to modify the BIOS yourself according to my guide (= start post of this thread)?
It is easier than you may think. If you are unsure regarding the result, you can attach the file as *-ZIP archive and we will tell you, whether the BIOS can be flashed or not.
Regards
Dieter (alias Fernando)

Hello Fernando!

However, he couldn’t make a working BIOS.
I think I’m no smarter than pollonegro.
But if I can’t get the BIOS created by Lost_N_BIOS, then I will try to do it myself.

@Max2x - I never post BIOS for Money only??? Maybe you clicked on some ad on that page instead of the download link?
Ohh! Sorry, I see what happened, it’s past the 30 day download time, sorry about that, I used that site because my usual wasn’t working for me that day!
Here is new link (also edited into that post) - http://s000.tinyupload.com/index.php?fil…179903205530343

@Lost_N_BIOS
Thanks for the answer!
I was only able to insert NvmExpressDxe_Small.ffs. And your BIOS contains NvmExpressDxe_4. I think it’s better.
I flashed your BIOS on my ga-z87-d3hp. Еverything works!
Tomorrow I will put Windows 10-I will unsubscribe according to the results.

@Max2x - You’re welcome, and thank you for letting me know about that link being that way too! I’ll have to remember not to use that site anymore
Great you got it flashed in and all went smoothly, good luck on the NVME setup!

@Vincent12 - I think you have Samsung 950 is why, but yours is OEM 951 (Same/same), to avoid confusion on that maybe @Fernando could add 951 model to that comment on page one too
Or, actually, this is why >> This works for you OK because your BIOS is already NVME compatible from the get-go with stock BIOS. So, this guide doesn’t really apply to you, but I still do wonder about the OEM 951 if it’s same as 950 on a non-NVME capable BIOS.

I will continue my post as promised…
After flash BIOS and installations A-DATA S11 Pro 512 GB I not saw in BIOS no new disks.
But I booted in Windows 10 with SATA disk Plextor 256 GB. There A-DATA S11 Pro 512 GB was defined.
With Acronis True Image 2020 24.5.1, I cloned Plextor on A-DATA S11 Pro, shut down the computer, and unplaged SATA Plextor.
Then I turned on the computer without going into the BIOS and booted Windows 10 from the new disk!
It was easier than I thought.
Thanks @Lost_N_BIOS for modified BIOS and @Fernando for this guide.

Hi there,

I was wondering if one of you more modding-savvy guys would be willing to create a modded bios for this board. I’m a little worried that I might create a file that will brick the thing. I’m just looking for the NVMe support, with no microcode updates. I’m using my PC only for gaming and the microcode updates are supposed to slow down some games by a few percent.

I’ve already tried a modded BIOS for the P9X79 Pro, which worked like a charm.

So the current BIOS is the 5001, which can be downloaded here: https://www.asus.com/de/Motherboards/RAM…/HelpDesk_BIOS/
The filename for USB Bios Flashback is R4F.CAP

Thanks for the help :slight_smile:

[EDIT] It seems like I didn’t search thoroughly enough! voodoo5_6k has already created what I was looking for:
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (278)

@Der_KHAN :
Welcome to the Win-RAID Forum!
I have moved your request into the already existing and absolutely matching thread about how to get full NVMe support for older mainboards with an AMI UEFI BIOS.
Why don’t you do the BIOS modification yourself? It is very easy by following the guide, which is within the start post of this thread.
Good luck!
Dieter (alias Fernando)

Has anyone have had luck to get NVMe support for Asus P9X79 ?

I have this adapter:
https://www.asus.com/fi/Motherboard-Acce…-2-X16-CARD-V2/

and this drive:
https://www.samsung.com/us/computing/mem…tb-mz-v7e1t0bw/

I’ve followed the instructions for modding a new bios. Won’t work. I’ve also tried other persons modded bios. Won’t work.
I manage to get Win10 to install. But after that, I can’t boot into win10.- Bios doesn’t detect any hard drives.

@peikko763 - yes, please use search here, I’ve done all the Asus P9X79 variants with NVME mod + Bifurcation menu mod too All tested and confirmed working

Hi
I’m new to your page. I’m sorry for spelling errors I’m using google translate.

can you help with the modulation for my asus P8Z77-V PRO / THUNDERBOLT motherboard. Processor i7 3770k.
Samsung 500GB 970 EVO PLUS NVMe M.2 SSD
Akasa M.2 SSD to PCIe Adapter

I would not appreciate it if you can help.
Thank you.

https://www.asus.com/tr/Motherboards/P8Z…pDesk_Download/

@Lost_N_BIOS :
Thanks that you answered to me.

I have read this forum lots. I also downloaded BIOS from here and it’s working.
Windows 10 installation can detect NVME and installation works. Also in modded bios I can see CSM settings.
But bios can’t find NVME boot.

Shall windows installation make new boot option to BIOS?
I have tried many different settings at bios but couldn’t find NVME :frowning:

EDIT by Fernando: Unneeded fully quoted post replaced by directly addressing tothe author and unneeded blank lines removed (to save space)

@converter :
Welcome to the Win-RAID Forum!
Within >this< thread you can find several already modded ASUS P8Z77-V BIOSes with NVMe support, but I am rather unsure, whether there is offered an NVMe modded BIOS for your specific P8Z77-V PRO THUNDERBOLT model.
My advice is to try the BIOS modification your own by following my guide (= start post of this thread). The easiest way to get the NVMe module inserted into your specific mainboard BIOS is to use the AMI MMTool v4.50. There is enough space within the DXE Driver Volume to get the uncompressed “normal” NVMe module named NvmExpressDxe_4.ffs properly inserted. I just have tested it.
After having done the BIOS modification you can attach the BIOS file here as *.ZIP or *.RAR archive and we will check your work before you are going to flash the modded BIOS.
Good luck!
Dieter (alias Fernando)

@peikko763 :
Nobody among the big amount of users, who had successfully inserted the NVMe module and got Win10 properly installed in UEFI mode onto their NVMe SSD, can see within the BIOS the real name of their NVMe SSD or a device with the word “NVMe” in it.
The shown name is either “PATA SS” (not bootable and only shown while CSM is enabled) or “Windows Boot Manager” (bootable in UEFI mode).
If you see a bootable device named “Windows Boot Manager”, everything is fine.

@Fernando :
Thank you for the answer.

I’ve attached the file. can you check.

P8Z77-V-PRO-THUNDERBOLT-ASUS-2104.rar (4.12 MB)

@Fernando and @Lost_N_BIOS

Thanks that you both answered me. I’m new here forum. Here is pics from my BIOS CSM and other settings.

I can’t find UEFI WINDOWS BOOT tool or PATA SS or other disks only disks which are old of my computer.

20191205_202100.jpg

20191205_202103.jpg

20191205_202144.jpg

20191205_202229.jpg

20191113_224124.jpg

I also now try to make linux USB boot drive https://superuser.com/questions/1378031/…GHwOG3-HsjUiuCI

Because modded bios don’t find NVME…

Windows USB installing stick find NVME and installation works perfect… problem is booting to installed win 10 which is installed to NVME drive.

@Converter:
You have inserted the NVMe module perfectly. So this BIOS is ready for being flashed by using the ASUS USB Flashback feature.
Good luck!

@peikko763 :
Please attach the modded BIOS, which you have flashed, as *.ZIP pr *.RAR archive.
Questions:
1. How did you flash the modded BIOS?
2. What sort of device is "Intel Volume0"?

@Fernando Intel volume 0 is 2x 256Gb Samsung SATA 3 SSD RAID 0 system volume.
I flashed bios with mainboard own BIOS flash button backwards at my mainboard&computer case (Attachment pic of this message)
Modded bios is from here :
[Request] Asus P9x79 BIOS with NVMe support

I have P9X79 motherboard.

If bios don’t work I think that boot from USB stick to NVMe is ok too to me. I would be glad if some way I can boot to windows 10 which is installed to NVMe :slight_smile:

P9X79.zip (4.76 MB)

20191205_222305.jpg